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Chapter 1: Introduction
Omron Adept Technologies, Inc. autonomous intelligent vehicles (AIVs) can autonomously navigate
within dynamic environments, such as a factory, warehouse, or laboratory, without external guidance or
control. The Mobile Robot Software Suite has tools for programming and configuring individual AIVs and
fleets, and has tools for centralized job dispatch and real-time monitoring.
NOTE: This guide uses the term autonomous intelligent vehicle (AIV) to denote the combined mobile
robot platform (the part of the AIV containing the core (CPU), battery, drive train, navigation sensors,
etc.) and the payload structure (the structure that performs the actual work of lifting, transporting,
etc.).
This user's guide covers the basic procedures for installing and using the Mobile Robot Software Suite.
Some advanced operating procedures are discussed in later chapters of the guide, and additional advanced
procedures will be added to this guide as it is revised for future software releases.
The following topics provide an introduction to the Mobile Robot Software Suite.
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About Mobile Robot Software Suite
The Mobile Robot Software Suite is a suite of mobile-robotics software applications for programming and
operating one or a fleet of mobile robots and the optional Enterprise Manager (EM). It uses a graphical user
interface (GUI) for communicating with and configuring the mobile robots, and to display and edit mobile
robot map files. The mobile robots use map files to determine where they are, plan navigable paths to goals,
execute tasks at programmed goals, and to control other autonomous robot tasks.
NOTE: Mobile Robot Software Suite version 5 software suite installs into a MobilePlanner5 directory.
This different install directory allows you to use the relevant MobilePlanner version with your fleet.

The Mobile Robot Software Suite
MobilePlanner
The MobilePlanner software is the "control center" of the Mobile Robot Software Suite. Its user interface
has the tools for all major AIV activities, such as observing a fleet of AIVs, commanding individual AIVs to
drive, creating and editing map files, goals, and tasks, modifying AIV configurations, and more.

Figure 1-1: MobilePlanner Interface
From the MobilePlanner interface, you can:
l

Connect to and drive the mobile robot.

l

Create floorplans (maps) of the environment by importing and analyzing a robot’s scan data.

l

Edit maps by adding goals (and adding tasks to those goals), docks, forbidden areas, and more. You
can also erase stray or unwanted artifacts, combine pieces of maps, and make other changes.
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l

Create a week-long schedule, which can include holidays. A schedule commands the robot to perform routes and other special activities at specified times.

l

Download and upload files, including maps and scan data, to and from a robot.

l

Set the system configuration parameters for the fleet.

l

With the optional Enterprise Manager (EM), monitor the location and status of all robots in a fleet.

l

View and interact with the job queuing manager.

For details, see The MobilePlanner Interface on page 55
MobilePlanner Operator Mode
Launching MobilePlanner without a USB license dongle opens MobilePlanner Operator Mode (which you
can also open from a shortcut), which gives a limited set of tools for monitoring robot and robot job status,
and allows for simple interventions in job execution sequences. For more information, see MobilePlanner
Operator Mode Overview on page 57.
SetNetGo
SetNetGo is the operating system that resides on mobile robots. You can use the SetNetGo software to configure your mobile robot's communication parameters, access diagnostic information (for example, download debug info file for service provider use, manage restore points, etc.), and perform software
maintenance (upgrades). You access the SetNetGo interface through a tab in the MobilePlanner software,
and then use that interface to enable the parameters needed.

Figure 1-2: SetNetGo interface
For details, See "Overview of the SetNetGo OS"

Mobile Robot Software SuiteUser's Guide 18484-001 Rev. B
Page 13

Chapter 1: Introduction

ARAM
The Advanced Robotics Automation Management (ARAM) software runs on the robot's core, and does the
following:
l

l

l

Performs all the high-level, autonomous robotics functions, including obstacle avoidance, path planning, localization, and navigation, culminating in the robot’s motion.
Manages wired and wireless Ethernet communications with off-board software, for external monitoring, development, and systems coordination, including coordination of a fleet of robots through
the optional Enterprise Manager fleet management appliance.
Enables external monitoring and control with the MobilePlanner application.

ARAMCentral
The fleet management software running on the Enterprise Manager (EM) appliance. ARAMCentral
provides:
l

Centralized configuration and map management.

l

Job queuing and dispatch.

l

Traffic management.

l

Single-point of integration and communication for software clients and other automation equipment.

MARC
At the lowest level, a microcontroller running Mobile Adept Robot Controller (MARC) firmware handles the
robot’s drive speed and heading. It also acquires sensor readings, such as from the encoders, gyroscope,
and sonar, and manages the robot’s power and emergency stop systems, batteries, and bumpers. The
MARC controller computes and reports the robot’s odometry (X, Y, and heading), and a variety of other lowlevel operating conditions to ARAM.
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How the Mobile Robot Software Suite Components Work Together
The figure below is a basic system architecture (for a fleet of AIVs) and illustrates the interrelationship
between Mobile Robot Software Suite’s various applications.

Figure 1-3: Components working together

Enterprise Manager 1100
The Enterprise Manager 1100 (EM1100) is a network appliance with built-in processor running Enterprise
Manager software. The EM coordinates the movement of up to 100 autonomous intelligent vehicles
(AIVs). It runs ARAMCentral software and manages maps, AIV configurations, traffic control, job queuing,
and remote I/O.

ARAMCentral/ARAM
Advanced Robotics Automation Management (ARAM) Central software runs on the EM1100 (see above).
ARAM runs on the AIV’s core, and operates its ranging sensors, performs all high-level autonomous robot
functions, and sends movement commands to the MARC.

MARC
Mobile Adept Robot Controller (MARC), which resides on the AIV’s core, manages the AIV’s speed and heading, sensor readings, emergency stop systems, bumpers, and joystick. It also computes and reports the
AIV’s odometry readings (X, Y, and heading) and other low-level operations which it reports to ARAM.
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MobilePlanner
MobilePlanner software is the control center for creating maps, managing AIV configurations, and more.
When installed on your PC, MobilePlanner communicates with the EM1100 and allows you to control and
program your AIV.

SetNetGo
SetNetGo is the operating system residing on the robot and EM1100. You use SetNetGo to configure and
establish network communication with the robot, download debug information, and perform software maintenance (upgrades). Access to SetNetGo is via the MobilePlanner interface.
NOTE: Optionally, you can connect to SetNetGo through a web browser. This is useful for IT personnel
who need to make changes but do not have access to (or need) the full Mobile Robot Software Suite.
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Map Overview
Maps are one of the most important features of MobilePlanner. In MobilePlanner, a map is a scanned representation of the floor plan in the mobile robot's operating space. Maps contain the static features in the
robot's environment, such as walls, doors, permanent shelving, etc. They also contain user-definable sectors, lines, and areas that help the robot perform its job.

Making a Map
Before MobilePlanner can create a map of the mobile robot’s operating space, you have to drive the robot
through the operating space as it scans the area with its laser and (if installed) Acuity. The resulting scan
file contains all the raw data for features in the space. To be usable for mobile robot navigation, you have to
have MobilePlanner convert the scan file into a map file.
Generally, you only need to make a map when deploying your mobile robot for the first time in a new environment. Occasionally you might need to rescan if the workspace undergoes extensive structural modifications or lighting changes, cubicles added in what was open space, a new wing to the building, or
remodel of an area. For more extensive map updates, MobilePlanner provides the tools to integrate a new
map, partially or wholly, into your original application (see Inserting a Map File into an Existing Map File on
page 120 for details).
The best time to create a map scan is when the environment is least busy; when you can minimize the
amount of time spent avoiding people and other non-stationary obstacles, and when you can move about,
opening and closing doors, without disrupting normal daily activities.

What Information is Stored in a Map File?
Map files contain four kinds of data about an operating environment that the robot uses in planning navigation and executing tasks:
l

Obstacles and features scanned by a laser, and/or overhead lights acquired by Acuity.

l

Objects such as goal points, forbidden lines, and sectors that control robot behavior.

l

Macros and tasks associated with goals.

l

Data that defines properties of special goal types and available tasks.

A map file name has an extension of .map. Scan file names have an extension of .2d.
Scan files for light localization have an extension of .z2d (scan file is a zip file referred to as the Scan Package) or .zmp (map file from scan - a zip file referred to as the Map Package).
l

l

For information on creating a map using the scanning laser, see Scanning the Operating Area on
page 1.
For information on creating a map Creating the Light Map on page 201.
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Mobile Robot WiFi Capabilities
Omron Adept Technologies’ mobile robots have multiple network interfaces, including a built-in wireless
communications capability to enable their autonomous operations. The on-board wireless card can use
802.11a, 802.11b, or 802.11g wireless standard on 2.4GHz or 5GHz channels, and the robot will automatically switch between wireless access points as it moves through its environment.
NOTE: If the mobile robot has difficulty connecting to a wireless access point, switches between 2.4GHz
and 5GHz channels, frequently disconnects, or has weak signal strength, try disabling the 2.4GHz channel. If the problem discontinues, inform your IT department of your finding.
The robots' wireless system can use the majority of the most common personal- and enterprise-grade
security methods and encryption, including:
l

Open

l

64-bit or 128-bit wireless equivalent privacy (WEP)

l

WiFi-protected access (WPA2)-pre-shared key (PSK) ASCII or HEX passphrase

l

Extensible authentication protocol-tranport layer security (EAP-TLS)

l

l

Protected EAP-Microsoft challenge handshake authentication protocol version 2 (PEAP-MSCHAPv2),
or
Advanced encryption standard/temporal key integrity protocol/counter mode with Cypher block
chaining message authentication code protocol (AES/TKIP/CCMP) encryption.

The mobile robots can also use certificates (small files containing identifying information that allows the
robot to connect to secure networks that require explicit identification and pre-authorization for access)
with the following extensions:
l

.pem - a privacy enhanced mail (PEM)-encoded X.509 certificate

l

.pem/.cer/.crt - a PEM or distinguished encoding rules (DER) encoded X.509 certificate

l

l

.p7b - a Public Key Cryptography standards (PKCS7) file containing one or more certificates (contains
no private key)
.p12 - a PKCS12 file containing one or more certificates (includes private key)

Your certificate authority (CA) server generates these certificates based on a certificate request (.csr) file.
You manually install the certificates on the robot. The robots can generate their own 1024-bit or 2048-bit
RSA keys, or use keys generated by the CA.
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Available Options and Peripherals
The following options and peripherals are available for your mobile robot (for more details, see the Peripherals Guide for your mobile robot):
Joystick
The joystick is an optional hand-held input device for driving the AIV. It attaches directly to the robot's joystick port, and has controls to move the AIV forward and backward, turn left or right, and adjust its speed.
It also has a configurable goal button for adding goals while mapping.
Acuity
In addition to using a safety scanning laser (navigation laser) to create a map of its environment, the AIV
can, with an upward-facing camera mounted on top of the platform, use overhead light localization for
navigation (the laser then provides obstacle avoidance). Called Acuity, this peripheral add-on is ideal for
dynamic environments - such as warehouses - in which objects on the floor undergo frequent location
changes. For more information on localization, see What is Localization? on page 194.
NOTE: If not installed by the factory, Acuity requires installation of the Acuity Support Package software via the MobilePlanner software suite. For information, see the Mobile Robots - LD Platform Peripherals Guide., found in Omron Adept Technologies, Inc. corporate Website.
High Accuracy Positioning System (HAPS)
The HAPS peripheral uses a sensor (called GuideSensor_Front in the Robot Physical configuration) installed
in the AIV to detect and follow magnetic tape applied to the floor. HAPS allows you to position the AIV at
pick-up and drop-off locations with a high degree of accuracy. For more information, see the Mobile Robots
- LD Platform Peripherals Guide., found in Omron Adept Technologies, Inc. corporate Website.
Low Front Laser
The now standard low front laser replaced the front sonar to provide improved detection of low obstacles
like empty pallets. The low front laser replaces the standard front bumper and sonar combination, and is
available as a standard installation or option for mobile robots.
Side Lasers
Certain mobile robots have side lasers to detect obstacles on either side (such as overhangs, tables, etc.) to
help the AIV navigate through tight areas, such as office spaces.
Touchscreen
The Touchscreen allows interaction with the mobile robot at any location. You can check the mobile robot’s
status, send the robot to goals, pause or release the robot, or localize a lost robot.
Call Buttons and Door Boxes
Call buttons issue a request for the AIV to go to the call button’s associated goal. Door Boxes act as remote
I/O, and can issue requests to open closed doors equipped with a door activator so AIVs can pass through
it. For additional information, see Mobile Robots - LD Platform Peripherals Guide.
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Glossary and Definitions
The following table lists acronyms and abbreviations, and defines key terms found in this user
guide:
Term

Definition

802.11a, b, or g

Standard for wireless local area networks (WLAN) in the 2.4GHZ and 5GHz frequency bands.

Acuity

Robot-mounted camera system for localizing the robot using overhead lights
versus its laser.

AES

Advanced encryption standard

AIFF

Audio interchange file format

AIV

Autonomous intelligent vehicle

ARAM

Advanced robotics automation management

ARC4

Alleged Rivest Cipher 4 (RC4)

ARCL

Advanced robotics command language. A simple, text-based, command-andresponse operating language. Used with the optional Enterprise Manager (EM) appliance, ARCL can help manage a fleet of mobile robots.

ARP

Address resolution protocol

A/V

Audio/Visual

Boolean

A type of data with two values, usually ‘true,’ or ‘false.’

CA

Certificate authority

CCMP

Counter mode with Cipher block chaining message authentication code protocol

Cost

An arbitrary numeric value assigned to map grids, lines, routes, etc. to determine
the cumulative, net effect of a robot’s actions. Breaks maps into discrete squares
called grids. Squares with walls, etc. have an infinite cost, and free squares, by
default, have a value of 0.1. By design, mobile robots always seek to execute their
assigned tasks and goals at the lowest possible cost.

Cost-Based Path
Planning

A method of planning optimal, ‘least expensive’ paths from “point a” to “point b” for
the robot to follow.

CPU

Central processing unit

DER

Distinguished encoding rules
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DHCP

Dynamic host configuration protocol

DNS

Domain name service

Dock

Map location where the mobile robot “looks for” the charging station. Dock map
icon should be 1 to 1.5 meters in front of the charging station, with the dock icon’s
black line pointing to the charging station.

Dongle

A small hardware device attached to a computer that contains the software (e.g.,
license key) required to run a specific program.

DROPOFF

Job segment classification - tells the EM only a specific robot can be assigned to the
job segment.

EAP

Extensible authentication protocol

EAP-FAST

EAP flexible authentication via secure tunneling

EM

Enterprise Manager. A network appliance for managing a fleet of robots.

Enterprise Manager 1100
(EM1100)

A network appliance with built-in processor running Enterprise Manager software.
Manages a fleet of AIVs, and provides a central location to manage maps and configurations (which it automatically propagates to the fleet); has a queuing manager
to match jobs to available robots; is a central point of communication for integrating fleet robots; and coordinates traffic, sharing location and trajectory information among fleet robots.

Ethernet

A type of computer network used in local area networks (LANs). Typically uses a Category 5 (CAT5) or (CAT6) Ethernet cable; supports data speeds up to 100 MHz.

FIFO

First-In-First-Out - refers to the method used to prioritize jobs (higher number
equals higher priority).

Fleet

Term for the group of robots connected to the Enterprise Manager (EM)

Forbidden (lines,
areas)

Lines or areas onto or into which the robot must not drive or enter on its own. In
special cases, you can direct a robot to enter a forbidden area.

Goal

Map-defined virtual destination(s) for mobile robots (e.g., pickup or drop-off points).

GUI

Graphical user interface

HAPS

High accuracy positioning system. Uses add-on sensors which detect and follow
magnetic tape applied to the floor. Allows for very precise robot positioning.

IP

Internet protocol. IP address is a computer’s unique internet “address.”

Job

A robot activity - usually consists of either one or two “job segments” (either
PICKUP or DROPOFF). The EM receives all job requests from ARCL.
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Joystick

A handheld, external input device for manually driving mobile robots. Connects to
the mobile robot’s JOYSTICK connection port.

LAN

Local Area Network

LEAP

Lightweight EAP

Localization

The process by which mobile robots determine their location in their operating environment. Laser localization uses the robot’s laser to scan its environment which it
compares to its internal environment map. In light localization, the mobile robot
uses overhead lights to determine its location.

Macro

A virtual “container” with a series or sequence of nested tasks and/or goals. Similar
to routes. You can use macros as many times as needed to perform the same
sequence of discrete functions in different tasks.

MARC

The Mobile Adept Robot Controller (MARC) firmware computes and reports the
robot's odometer (X. Y, and heading) readings and other low-level operating conditions to ARAM.

MobilePlanner

The primary software application for programming mobile robot actions.

MobilePlanner
(Operator Mode)

The version of MobilePlanner software running without the license dongle. Has
tools to monitor robots, robot statistics, monitor and add jobs. Does not have tools
to create or edit maps.

MSCHAPv2

Microsoft challenge handshake authentication protocol version 2

MP3

Moving picture experts group (MPEG) -2Audio Layer III

OS

Operating system (e.g., Mac OS, Windows OS, MARC, SetNetGo OS, etc.).

Path

The manner in which the mobile robots drive from place to place in their environment.

PEAP

Protected extensible authentication protocol (EAP)

PEM

Privacy enhanced mail

PICKUP

A job segment classification - tells the EM that any available, appropriate robot can
be assigned to the job segment.

PKCS

Public key cryptography standards

Platform

The base mobile robot (with or without payload) – includes chassis, drive train, suspension, wheels, battery, safety scanning laser, sonar, on-board core with gyroscope and software to navigate, interface connections for payload, and covers.

Pose

A mobile robot’s position (location and heading).
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Preferred (lines,
directions)

Lines, directions you want the mobile robot to travel.

PSK

Pre-shared key

RC4

Rivest Cipher 4 (aka ARC4 – Alleged RC4)

Resisted (lines,
areas)

Lines and/or areas the mobile robots resist (attempt to avoid) crossing or entering,
unless it must drive over/through resisted lines/areas to reach a goal.

Route

A “to do” list or series of tasks, goals, or macros for the mobile robot to follow.

Safety
Commissioning

Allows testing and commissioning (verification of proper function) of a robot's onboard safety systems. Uses a wizard to test E-Stop (tests brake activation) and
Safety Laser (tests max speed limits and obstacle detection). Per EN-1525, Commissioning must be done by specially trained people.

Sector

Map areas that direct specific robot actions, like ignoring sensor readings, driving on
the right or left, limiting the number of robots in the area at one time, etc.

SetNetGo

Software OS, resides on mobile robots and the optional Enterprise Manager appliance. Used to configure mobile robots’ communication parameters. Accessed via
the SetNetGo tab in MobilePlanner.

SNG

SetNetGo. The operating system that resides on the mobile robots.

Spline

Mathematical function for smoothing arcs and curves.

SSID

Service Set IDentification – identifies a wireless LAN

Tasks

Instructions for the robot to perform certain actions like reading inputs, setting outputs, movement commands, talking, waiting, etc. Tasks have adjustable parameters, which can be individually set for each copy of the task. There are two types
of tasks; instant (allows concurrent processing of tasks while original task is executing), and non-instant (can interrupt a currently running task).

TCP

Transmission control protocol

TKIP

Temporal key integrity protocol

TLS

Transport layer security

TriangleDrive

Using physical triangular-shaped features in the environment to aid in more accurate maneuvering. Traingles can be placed on charging stations, and other locations
where you need accurate positioning. Associated with certain tasks.

Virtual Doors

Specially designated areas on the robot’s map which the robot performs certain
tasks (like ‘move’ or ‘say’ tasks, flashing lights, etc.) and/or allow the robot to drive
through special areas (e.g., plastic curtains).
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WAVE

Waveform audio file format – also expressed as .wav.

WEP

Wireless equivalent privacy

WPA

WiFi-protected access

Related Manuals
In addition to this manual, you may want to refer to the following manuals which are available from the
Omron Adept Technologies, Inc. Website (www.adept.com, or www.ia.omron.com):
Manual

Description

Mobile Robot Safety Guide

Describes safety information for Omron Adept mobile robots.

Omron Adept Mobile Robot
User's Guide

Describes the installation, start-up, operation, and maintenance of
the mobile robot you are using.

Advanced Robotics Command Describes the Advanced Robotics Command Language (ARCL) verLanguage Enterprise Mansion for use with the Enterprise Manager software. ARCL is a simple
ager Integration Guide
text-based command and response server used for integrating the
Mobile Robot Software Suite platform with an external automation
system.

How Can I Get Help?
For details on getting assistance with your Omron Adept Technologies, Inc. software or hardware, you can
access the Omron Adept Technologies, Inc. corporate website at www.ia.omron.com.
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Safety and Regulatory
Omron|Adept Technologies’ mobile robots adhere to the following domestic and international safety regulations:
l

l

l

EN 1525 “Safety of Industrial Trucks. Driverless Trucks and their Systems”
ANSI 56.5:2012 “Safety Standard for Driverless, Automatic Guided Industrial Vehicles and Automated Functions of Manned Industrial Vehicles”
JIS D 6802:1997 “Automated Guided Vehicle Systems - General Rules on the Safety”

Warnings, Cautions, and Notes
Where needed, this user guide calls out critical, important, or emphasized text via special alert notifications. Below are explanations of the special alert notifications used in this manual:
WARNING: This indicates a potentially hazardous situation which, if not avoided, will result in
minor or moderate injury, or serious injury or death. Additionally, there may be significant property damage.
CAUTION: This indicates a situation which, if not avoided, could result in minor or moderate
injury or in property damage.

NOTE: Notes provide supplementary information, emphasize a point or procedure, or give a tip for
easier operation.

General Safety Precautions
Read the installation and operation instructions, as well as the Mobile Robot LD Safety Guide, before using
the equipment.
l

Do not ride on the mobile robot.

l

Do not exceed the mobile robot’s maximum weight limit.

l

Limit operation to areas with no slope.

l

Do not drop the mobile robot, run it off a ledge, or otherwise operate it in an irresponsible manner.

l

Do not get the mobile robot wet, or expose the mobile robot to rain or moisture. The robot has an IP
rating of IP40.
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l

l

l

Do not use power extension cords with the docking station unless properly rated.
Do not run the mobile robot if hair, yarn, string, or any other items are wound around the mobile
robot’s axles or wheels.
Never access the mobile robot’s interior with the charger attached. Immediately disconnect the battery after opening the battery compartment door.

l

Never short the battery’s terminals together.

l

Do not use parts (including chargers, etc.) not authorized by Omron Adept Technologies, Inc..

Safety Commissioning
EN 1525: “Safety of Industrial Trucks. Driverless Trucks and their Systems,” requires testing of the mobile
robot’s safety systems, both before leaving the factory, and again at the customer’s site by a trained and
qualified person. Safety Commissioning runs from within the MobilePlanner main menu.
To test E-Stop
1. In the MobilePlanner main menu, select Robot > Safety Commissioning.
2. In the Introduction window, click the ESTOP radio button, then click Next.
3. Press the AIV’s E-Stop button, listen for the brakes to engage, then click Next.
4. Select Yes (or No if the brakes did not engage - contact an Omron Adept Technologies, Inc. representative).
To test the Safety Laser
1. In the MobilePlanner main menu, select Robot > Safety Commissioning.
2. In the Introduction window, click the Safety Laser radio button.
3. With the AIV in an open area (at least 2 meters clearance around front and side), press the E-Stop
button.
4. Remove side panels, use the metal pins to hold the wheels off the ground.
5. Release the E-Stop button.
6. In the Safety Laser Commissioning window, click Next.
7. Click and hold the Drive button (until prompted to release), and verify Speed Zones trigger.
a. If AIV fails, select No, and contact an Omron Adept Technologies, Inc. representative.
b. If AIV passes, select Yes and proceed to next step.
8. Follow the setup instructions (and place an object in front of the AIV), then click Next.
9. Press and hold the Drive button until prompted to release.
10. When the wizard informs you the E-Stop triggered, click Continue.
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What to Do in an Emergency
Press the E-Stop button (a red push-button on a yellow background/field) and then follow the internal procedures of your company or organization for an emergency situation. If a fire occurs, use a type D extinguisher: foam, dry chemical, or CO2.

Additional Safety Information
We provide other sources for more safety information on our website at www.adept.com or
www.ia.omron.com.

Mobile Robot Safety Guide
The Mobile Robot Safety Guide provides detailed information on safety for our robots. It also gives
resources for more information on relevant standards. The robot safety guide ships with each robot.
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The Mobile Robot Software Suite has the tools and features to help you get your mobile robot up and running quickly. The following topics cover the initial steps needed to access your robot with the PC and to
begin using the Mobile Robot Software Suite.

How Do I Begin?

30

Install the Mobile Robot Software Suite

31

Configure the Mobile Robot’s Wireless Communications

32

Step 1: Connect Your PC to the Mobile Robot via Ethernet

32

Step 2: Set the IP Address on Your PC

33

Step 3: Access SetNetGo Software

34

Step 4: Configure Your Robot's Network and Security Settings

35

Step 5: Connect to the Robot Wirelessly

37

What’s Next?

38

Scanning Overview

39

Mobile Robot Driving Overview

41

Scanning the Operating Area

45

Convert the Scan into a Map

46

Now What?

48

Changing the Scan Settings

48

Set the Robot's Initial Location

50

After Driving the Mobile Robot

52
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How Do I Begin?
Before you can start using your mobile robot, there are a number of initial set-up and configuration steps
you need to complete.
NOTE: The specific procedures for unpacking and powering the robot are beyond the scope of this user
guide. Step 1 (below) is a very general sequence. For detailed set-up information, refer to your mobile
robot's user guide.
1. Unpack the robot, install the battery, power-up the robot, and install a dock. See the robot user's
guide for more information.
2. Install the MobilePlanner software on your PC (see Install the Mobile Robot Software Suite on page
31).
NOTE: While you can run MobilePlanner without the license dongle (which results in a version of
MobilePlanner called Operator Mode), you will need at least one license per fleet of robots before
you can create a map the robots need to navigate.
3. Connect your PC to the mobile robot via Ethernet cable (Step 1: Connect Your PC to the Mobile Robot
via Ethernet on page 32).
4. Configure your PC’s IP address (see Step 2: Set the IP Address on Your PC on page 33).
5. Connect to the SetNetGo interface (see Step 3: Access SetNetGo Software on page 34).
6. Configure the mobile robot for wireless communication (see Step 4: Configure Your Robot's Network
and Security Settings on page 35).
7. Establish a wireless connection to the robot (see Step 5: Connect to the Robot Wirelessly on page
37).
8. Scan your environment (see Scanning the Operating Area on page 45.).
9. Convert the scan to a map (see Convert the Scan into a Map on page 46).
10. Use MobilePlanner software to edit (erase stray and other dynamic features from) the map (see Editing a Map File on page 114).
11. Add docks, forbidden zones, goals, and route(s) between goals, etc. to the map (see Working with
Map Files on page 111).
NOTE: It’s important to add a dock to the map so the robot can recharge when its battery runs
low.
12. Save the edited map on the robot (see Saving the Map on the Robot on page 124).
13. Localize the robot (see Set the Robot's Initial Location on page 50).
14. Create some tasks, and have the robot begin performing them (see Start the Mobile Robot Performing Tasks on page 1).
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Install the Mobile Robot Software Suite
Before setting up a wireless connection to your mobile robot, you should install Mobile Robot Software
Suite on your PC.

System Requirements
Verify your system meets the following requirements to install Mobile Robot Software Suite:
l

OS: Windows 7 (32-bit/64-bit), Windows 8 (32-bit/64-bit),or Windows 10 (32-bit/64-bit).

l

CPU: 1.5 GHz Dual-core.

l

RAM: 1.5 GB (min) 4 GB RAM recommended).

l

GPU: 256 MB (min).

l

HDD/SSD: At lease 200 MB available space.

l

Monitor: XGA 1024 x 768.

l

Language support: English, Japanese

l

USB port with a Omron Adept Technologies, Inc.-supplied dongle with the MobilePlanner software
license.
NOTE: Using MobilePlanner software to manage a fleet of robots requires at least one licensed
installation (the license is supplied on a hardware dongle enclosed in the robot documentation
package or sold separately). However, you can run MobilePlanner (Operator Mode) without a
license dongle.

Installing Mobile Robot Software Suite
Ensure your PC meets the system requirements, then install (or download and install) the Mobile Robot
Software Suite.
NOTE: Mobile Robot Software Suite version 5 software suite installs into a MobilePlanner5 directory.
This different install directory allows you to use the relevant MobilePlanner version with your fleet.
1. Use one of the following methods to download and/or install MobilePlanner software:
a. By USB drive: insert the software media (USB drive included with your robot’s documentation) into your PC, and browse to the USB drive to locate the software.
b. From SetNetGo: When connected to the robot via Ethernet, you can open SetNetGo, click
the Software tab, and install MobilePlanner.
c. By download: Open a browser, and browse to http://www.adept.com/support/downloads/file-search, and log in (you must register first). In the Downloads Search tab, enter “mobileplanner” in Option 1, or select “Mobile Robot Software”
from the drop-down list in option 2, then press Begin Search. In the Search Results field,
select Download ID 900031, Adept MobilePlanner. In the Download Details tab, select
Download.
2. Launch the installer and, when the welcome screen appears, follow the prompts in each installation
wizard window to complete the installation.
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3. When the Installation Complete window appears, you can leave the ReadMe and/or Launch
MobilePlanner checkboxes checked, or uncheck them to not have those items launch.
4. Click Finish when done.

Configure the Mobile Robot’s Wireless Communications
Before you can start working with your mobile robot, you have to configure it for wireless communication
(via WiFi) with your PC (there are special conditions under which WiFi is not necessary - contact Omron
Adept Technologies, Inc. for guidance). To do this, you will first have to connect your PC to the robot via Ethernet cable to gain access to the robot's wireless settings. In general, the set-up process is as follows:
l

Connect your PC to the mobile robot via Ethernet

l

Set your PC’s IP address

l

Connect to SetNetGo

l

Configure the mobile robot’s network settings

l

Establish a wireless connection to the mobile robot

NOTE: The setup steps above assume that the mobile robot is powered up and ready. If this is not the
case, please refer to your mobile robot’s user guide for complete setup instructions.

Step 1: Connect Your PC to the Mobile Robot via Ethernet
To connect your PC to the mobile robot (MH60/MH90 mobile robot shown - check the guide for your particular robot):
1. Open the mobile robot's maintenance access panel (left side, upper right corner), by pressing the
access panel’s upper left corner (see image below) into the side of the AIV.

Figure 3-1: Maintenance Door location
2. Using a standard (pass-through) or cross-over CAT-5E Ethernet cable, connect your PC directly to
the robot's maintenance Ethernet port (see below). The robot will auto-detect the cable type.
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Figure 3-2: Ethernet Connection

Step 2: Set the IP Address on Your PC
Manually set your PC’s Ethernet port IP address to 1.2.3.x, where x is any number 1 - 254, except 4
(which the mobile robot uses), and a Subnet mask of 255.255.255.0. No special DNS or gateway settings
are needed.
NOTE: The robot's maintenance Ethernet port is always enabled and permanently set to IP address
1.2.3.4, with a Subnet mask of 255.255.255.0, for direct, wired access to the on-board systems.
1. Open your PC's Network Connections window.
2. Right-click on your PC’s Local Area Connection Ethernet connection, and select Properties.

Figure 3-3: Windows Local Area Connection Properties dialog
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3. In the Local Area Connection Properties dialog box, click on the TCP/IP protocol your network uses
(for example, Internet Protocol Version 4 (TCP/IPv4)), then click Properties.

Figure 3-4: Windows Internet Protocol Properties dialog
4. In the TCP/IP properties dialog box, click the Use the following IP address: radio button and
enter an appropriate IP address (for example, 1.2.3.5) and Subnet mask 255.255.255.0.
5. Click OK.
6. Close the Network Connections window.

Step 3: Access SetNetGo Software
The SetNetGo software lets you manage a variety of settings related to the robot's connectivity. You can
access SetNetGo from MobilePlanner (most common), or secure web browser (for example, Chrome, Firefox, or Internet Explorer) if receiving help from your IT department, or you don’t have access to MobilePlanner, etc.
To access SetNetGo from MobilePlanner
NOTE: Only start the following procedures if your computer is connected to the AIV via Ethernet cable.
1. Open the MobilePlanner software.
2. Enter 1.2.3.4 into the robot address field, then click Connect.
3. Click the SetNetGo button (the large part of that icon, not the checkbox).
4. Click the SetNetGo tab.
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To access SetNetGo via web browser
1. Start a web browser on your computer.
2. Enter the URL https://1.2.3.4 in the address bar of the web browser.
This is the AIV’s maintenance Ethernet address. When accessing the software from a wired maintenance Ethernet port, you do not need a username or password.

Figure 3-5: Browser address field
NOTE: You can ignore the certificate error that appears on the SetNetGo web-page; the error appears
because the hardware is not attached to the Internet.
The SetNetGo startup screen is shown below.

Figure 3-6: SetNetGo interface

Step 4: Configure Your Robot's Network and Security Settings
To access your mobile robot remotely, you should set up a static IP address. The SetNetGo interface allows
you to configure your hardware’s Ethernet settings, configure serial and TCP forwarding, and upgrade the
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on-board software. If you are not familiar with setting up a network or do not have an assigned IP address
for the robot, please see your system administrator.
NOTE: If you change any values in a SetNetGo screen, you must click Apply before switching to
another sub-screen, or those values will not be saved. For example, when changing wireless Ethernet
settings, be sure to click Apply before navigating back to the dashboard.
To configure network settings, click on the Network tab at the top of the SetNetGo screen.

Figure 3-7: SetNetGo interface
Network
Menu

Description

Wireless
Ethernet

Sets up your wireless Ethernet connection to your mobile robot, including
IP settings, WiFi network settings, security settings, and radio settings.

User LAN
Ethernet

This screen has user-configurable settings for interface mode, IP address, netmask, DHCP server for accessories, and DHCP IP range.

RS-232 Port
Forwarding

Controls forwarding of serial data to a TCP port on the wireless and internal wired
Ethernet networks, where the data is re-directed to a TCP port on an IP address
accessible via the Wired Ethernet interface (which must be set to accessory
mode). There is also port-forwarding for the two extra on-board serial ports to a
TCP port on the wireless Ethernet interface.

Ethernet
Forwarding

Use the settings on this screen to control TCP port forwarding from your User
LAN Ethernet interface to the wireless Ethernet interface.

Utilities

Use this screen to ping an IP address for testing and diagnostic purposes.
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Set the Username and Password to secure access to the robot
You should secure access to your robot(s) by enabling Access Control, adding one or more users, and
assigingn an access password. Click the Security tab, then click the Enabled radio button and populate
the username/password fields (see Setting Up User Accounts on page 104).

Step 5: Connect to the Robot Wirelessly
Now that you have installed the Mobile Robot Software Suite and configured the robot for wireless communications, connect to your robot.
1. (If not already running) double-click the MobilePlanner icon on your PC desktop.

Figure 3-8: MobilePlanner desktop icon

Figure 3-9: MobilePlanner Interface
NOTE: If running MobilePlanner without a license dongle, the interface will look slightly different
than above.
By default, the Fleet, Config, and Map buttons have checkmarks indicating those features will automatically load when you connect to the robot.
2. In the Connect field, enter the IP address of the mobile robot, then click Connect.
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3. Enter User Name and Password in the User Name and Password dialog box, then click OK.
NOTE: If the SetNetGo button is checked, this User Name and Password dialog appears. Enter
the Username and Password you configured in Step 5: Connect to the Robot Wirelessly on page
1.
If user accounts are enabled, a login dialog appears in which you must enter a user name, password,
and robot server IP address.
NOTE: After connecting to the robot the first time, MobilePlanner remembers your user name.
When connecting to the robot again, you can select your user name from a combo box instead of
having to re-enter, but you must still enter your password.
MobilePlanner completes its connection to the mobile robot. At this point, there is no map to load, so
MobilePlanner opens with a blank map window.

What’s Next?
Now that you have established a wireless connection to your mobile robot, you are ready to create a map of
the mobile robot’s environment. In general, the process is as follows:
l

l

l

l

Review the section on scanning (see Scanning Overview on page 39), and the section on scanning
tips.
Review the section on driving the mobile robot (see Mobile Robot Driving Overview on page 41)
Decide whether you will drive the robot by joystick or your PC (see Mobile Robot Driving Overview on
page 41).
Scan the mobile robot’s operating space (see Scanning the Operating Area on page 45).
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Scanning Overview
Before the AIV can perform autonomous tasks, it needs to have an accurate map of its environment. It is
best to create a scan that includes as many stationary features as possible in the workspace. After scanning, use MobilePlanner to turn the scan into a map, then begin assigning tasks to your AIV.

How Does the Robot Scan Its Environment
The AIV uses its forward laser, which scans in a 250 degree arc.

What Gets Scanned?
Scans are on a thin horizontal plane. For most platforms, the scan is taken about 8 inches (203 mm) off
the floor. So tables appear as four legs; a pedestal appears as a single pole, minus the feet.
Distance From Walls
The AIV’s sensing range is 14 meters (about 46 feet). While scanning, keep walls within that range as you
drive throughout the workspace. For instance in a large warehouse, run the AIV along the outer walls as
well as through the middle of the space.
Uni-directional Versus Bi-directional Scanning
Uni-directional scanning (or scanning in a single direction) works very well for hallways and small rooms.
Bi-directional scanning (or scanning in two directions) will ensure complete scanning of all features (such
as vending machines or bookshelves).
Doors and Windows
When scanning environments with doors, ensure the doors are open in places where the AIV will drive.
Some glass surfaces, particularly those with dark backgrounds, reflect the range finder signals; others
don’t or reflect weakly. Consider retrofitting particularly troublesome places with tape or other treatments
to obtain proper scans. Optionally, you can designate these features as obstacles in the map using the forbidden zone sector.
Dynamic Features
During scanning, MobilePlanner sees people walking by, swinging doors and other things moving throughout the workspace. If a group forms during scanning, have them follow behind (not stand in front of) the
robot’s scanner so they do not become permanent features of your map. When editing the map, erase
dynamic features (like the group) to improve the map’s quality.
Docks
When scanning, scan and press the goal button to mark the robot's dock so it can recharge when its battery runs low.

Scanning Tips
The following general tips will help increase the mobile robot’s scanning accuracy, and reduce possible map
errors:
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l

l

l

l

l

l

l

Remove any features like chairs, rolling cabinets, etc. that might not be present during normal operations.
Walk behind the AIV while scanning (and ensure others walking with the AIV also walk behind the
laser’s sensing area.
Drive the mobile robot into tight corners, down small corridors, and between stationary objects (with
enough room).
Scan in multiple directions - scan clockwise for one scan, counter-clockwise for another.
If scanning rough terrain (like diamond plate flooring), drive slowly (to reduce the chances of wheel
slip) and in multiple directions. This will help minimize introducing errors into the scan.
Open doors that might be open during normal operations, and doors the robot will have to drive
through.
Drive the mobile robot through previously scanned areas.
NOTE: Driving the robot back through previously scanned areas, and returning to its starting position can help minimize errors.
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Mobile Robot Driving Overview
Now that you have installed the Mobile Robot Software Suite and set up a wireless connection to your
robot, you are just about ready to drive the mobile robot around your workspace. You can drive the mobile
robot using either the joystick and walking around your environment, or operating it from the MobilePlanner software. Using the mouse and keyboard, you can dock and undock the mobile robot from its charging
station, drive the robot forward, backward, turn the robot, and control its speed.
CAUTION: Before attempting to drive the robot, be sure to read the appropriate
Omron Adept mobile robot user's guide so you are familiar with the robot's operation.

Before Driving the Mobile Robot
Whether you are driving the robot with the joystick or from MobilePlanner, be sure the robot is not docked.

Safe Mode
Safe Mode is the mobile robot’s default driving mode, and ensures the mobile robot does not run into anything in its environment. When driving the robot using MobilePlanner, Safe Mode prevents the mobile
robot from entering forbidden or restricted spaces. If driving the robot using the joystick, you can have the
robot enter forbidden or restricted spaces, but the robot always obeys the lasers for obstacle avoidance.
If you turn Safe Drive mode off, you can force the robot to continue driving (e.g., through a set of plastic
curtains in a doorway). Safe Mode only affects MobilePlanner, not the joystick.
When Safe Drive mode is off, the map background turns yellow (see below).

Figure 3-10: MobilePlanner, safe mode OFF
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To drive with safe mode off:
1. In the MobilePlanner main menu, click Robot > Robot Tools > Safe Drive.
2. Click Yes to acknowledge the Disable Safe Driving dialog prompt.
NOTE: If you turn Safe Drive mode back on when the robot is in a restricted or forbidden area, it will not
be able to drive itself out of the restricted area, and will require you driving it out using the joystick
(which always ignores location-dependent areas). Also, while a robot is in a forbidden area, even with
Safe Drive mode still off, pressing the Send Robot button will not cause the robot to drive out of the forbidden area. You must drive the robot out of a forbidden area using the joystick or your PC’s arrow keys
(see Driving Using the Software Interface (Drive Pad or keyboard) on page 43).

Driving Using the Joystick
This section provides information on the joystick. See your mobile robot’s user guide for further details.
Preparation
1. If not already done, power up the robot (press and release the mobile robot’s ON button) (the full
power-up sequence can take several minutes).
2. Wait for MobilePlanner and/or the mobile robot to indicate it is ready (via wheel lights, LCD or touch
screen).
3. Plug the joystick into the robot’s JOYSTICK connection port (MH-LD shown below):

Figure 3-11: Connecting the joystick to the robot
CAUTION: Driving the robot with a joystick overrides the hardware safety features (Estop, sonar). Use caution when driving the robot with a joystick.
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Figure 3-12: Joystick
l

l

l

l

Squeeze and hold the trigger in, then:
o

Push the directional control forward or back to drive the robot forward or back.

o

Push the directional control to the left or right to turn the robot to the left or right.

The robot slows to a stop when you release the trigger. To stop more quickly, continue to hold the
trigger down and pull or push the directional control to its limit in the opposite direction of the
robot’s travel.
Speed is related to the positions of the directional control and the SPEED control.
The joystick’s GOAL button is primarily for marking positions while making a map scan, but can be
configured to perform other actions while not making a map scan.

If driving with the joystick, proceed to Scanning the Operating Area on page 45

Driving Using the Software Interface (Drive Pad or keyboard)
Using MobilePlanner software and your PC's mouse and keyboard, you can: dock and undock the mobile
robot from a charging station; drive the robot forwards, backwards, and turn; and control the speed.
To drive the mobile robot from the software:
1. Ensure Show Robot is active, then click Center on Robot to locate the robot (a red oval icon) in
the map window (shown below).
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Figure 3-13: Robot on map (Show Robot active)
2. Select Robot > Undock from the main menu, or click Dock (on the robot tool bar) to turn docking
off. In the map window, you should see the robot move away from the charging station.
3. If the background in MobilePlanner is yellow (the robot is not in Safe Drive mode), select Robot >
Robot Tools > Safe Drive from the MobilePlanner main menu.
4. Click Drive to display the MobilePlanner Drive pad with Speed slider (figure below).

Figure 3-14: Drive pad with speed slider
5. Highlight (click on) the map window, and use the mouse to click on the drive pad buttons, or use keyboard’s arrow keys to control the robot’s direction. Use the speed slider (at the bottom of the Drive
pad) to control the robot’s speed.
NOTE: If the speed slider is all the way to the left (-), the speed is set to zero and the robot will
not move.
Continue with Scanning the Operating Area on page 45
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Scanning the Operating Area
Be sure to drive the robot to all of the places you would expect it to go on its own. Drive all the way around
a room, not just in and out of the doorway. Turn the mobile robot to point into corners and move around
stationary features. In other words, be thorough!
Also, while driving the robot, orient and stop it along the way to mark important goals (especially a dock
object). Later, you can edit these and add additional goals within MobilePlanner software.
1. (If not already done), Launch MobilePlanner and connect to the robot.
NOTE: Before starting these steps, make sure the robot is not charging. If the robot is docked,
undock it by clicking Robot > Dock (in the MobilePlanner main menu bar), or by clicking the
Dock button in the MobilePlanner toolbar (only visible if Show Robot is active).
2. From the MobilePlanner main menu, select: Robot > Map Creation > Start Scan.
3. Enter a name for your scan file in the New Scan Name field and click OK.
This initiates the scanning process.
NOTE: Before driving the robot, make sure it is in Safe Drive mode (a yellow background in
MobilePlanner indicates the robot is not in Safe Drive mode). To enable Safe Drive mode, click
Robot > Robot Tools > Safe Drive in the MobilePlanner main menu bar.
4. Use either the joystick or drive pad and drive the robot around its operating space.
NOTE: Be sure to drive the robot around the entire operating area to create an accurate scan of
your environment.
5. If you want to create a goal at the point where the robot is stopped, press the joystick’s black
GOAL button to mark a goal.
6. Continue driving the robot around until you have a thorough scan of your environment.
7. Return the robot to its starting position, and
8. After you have finished the scan, select Robot > Map Creation > Stop Scan from the MobilePlanner menu.
The resulting scan file resides on your mobile robot, but not on the PC running MobilePlanner. The file
name is the name you entered for the scan with the ‘.2d’ extension. If scanning using Acuity, the file
name has ‘.z2d’ appended to it, and includes additional data such as camera images used to map overhead
lights.
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Convert the Scan into a Map
After the robot scans the operating environment, you need to turn the scan file into a map file. To do this,
open the scan file (.2d) in MobilePlanner.
NOTE: MobilePlanner can process only one scan file at a time. Opening a second scan file disables the
toolbar Start button until the first scan is finished.
1. Open the MobilePlanner software.
2. Select File > Open on Robot, then select the robot, either from a list or by IP address.
The Open File on Robot dialog box appears.

Figure 3-15: Open File on Robot dialog
3. Check the Scan File: checkbox, select the scan file you just created from the pulldown list, and click
Open.
A new map window and the Scan Tools toolbar appear, and the conversion (registration) process
begins automatically. Initially, the map shows a red robot icon in the map window. During file processing, the software adds scan points to the map window and updates the robot's position showing
a blue trail to trace the robot's previous positions.
NOTE: Be patient! Converting a large scan file can take considerable time (and memory), and is
based on the size and layout of the area being scanned (for example, a small facility could take 20
seconds, a 20,000 square foot facility could take over an hour). If the small robot icon in the
lower right corner of the map window is still moving, the conversion process is still underway.
NOTE: Windows users: PC memory (RAM) is critical when processing a very large scan file. Processing large scan files with insufficient RAM can significantly degrade the performance of all
applications. If this occurs, it might be necessary to create smaller scan files and use the Map
Insert feature to assemble the pieces (see Inserting a Map File into an Existing Map File on page
120 for details)
When processing is complete, the robot icon and its trail disappear from the map window, and the
scan icon in the status bar stops animating. If the map has too many stray objects or otherwise does
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not appear as you need, you can adjust the scan settings and re-process the scan file (for details,
see Changing the Scan Settings on page 48).
4. Save the cleaned map file locally on your PC.
5. In the Scan Tools toolbar, click Finish to complete the conversion process.
NOTE: Unless working in batch mode, you must finish converting one scan before opening and
converting another scan.
6. Edit the map file to erase (Draw pane > Eraser) stray, non-stationary objects (like chairs, people,
etc.); add forbidden areas and sectors; create goals and macros; and assign tasks to your mobile
robot (see Editing a Map File on page 114 for more information).
7. Select File > Save on Robot to save the finished map file on the robot, then select your robot
from the MobilePlanner menu. Optionally, you can enter an Enterprise Manager address so it can be
shared between multiple robots.
NOTE: Select Yes when prompted to make the new map the robot’s current map so the robot
can localize, and appear on the map (when you click Show Robot).

Map Data
The finished map consists of points and lines (vectors derived from points) representing the walls and
other real features detected by the scanning laser.

Figure 3-16: Scanned environment

Mobile Robot Software SuiteUser's Guide 18484-001 Rev. B
Page 47

Chapter 3: Getting Started

Now What?
If you need to adjust the scan settings, see the next section. Otherwise, you need to localize the mobile
robot (let it know where it is). See Set the Robot's Initial Location on page 50.

Changing the Scan Settings
To adjust the processing, scan, clean, and map settings, click Settings from the Scan Tools toolbar.

Figure 3-17: Scan Processing Tools toolbar
Button

Description

Start

Initiates the scan session.

Pause

Temporarily pauses the scan session.

Rewind

Rewinds the robot’s path (blue trail) through the scanned area as shown on the MobilePlanner map.

Step

Allows you to step through the robot’s path, one segment at a time.

Finish

Completes the scan conversion process.

Save As

Allows you to save the newly created map with a specific name and location.

Clean

Allows you to manually remove unwanted scan points from the map.

Reset

Reset “uncleans” any cleaning work you have done on the map.

Settings

Allows you to change scan tool configurations.

Auto Fit

Scales the scan file image to the MobilePlanner map window as you add more information.

Track

Centers the robot in the scan image - works similarly to ‘center on robot’ in a normal map

Help

Opens a help file to search for specific help topics.
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The Scan Settings dialog box appears as shown below

Figure 3-18: MobilePlanner Scan Settings dialog
The following table describes the settings available from the Scan Settings dialog box.
Processing Settings

Description

Start scan when file opened

Disable this option to prevent the scan conversion process from
automatically starting when you open the scan file in MobilePlanner. Allows you to adjust the scan settings before conversion. To
start the process, click on the Start button from the Scan Tools
toolbar.

Clean after scans registered

Disable this option to leave all scan points in the map. Any cleaning must be done manually by pressing the Clean button.

Prompt to save after scan complete

If this option is disabled, then the Save Map File As window is not
automatically displayed.

Run in batch mode

Enable this option to process multiple scan files at the same time.
NOTE: The files must all be of the same type. For example,
they all must be basic scan files or all must be light localization
scan files, they cannot be a combination of the two.

<filename>.map, overwriting any
existing files

Select this option to overwrite the filename in batch mode.
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<filename>_<currentDateTime>.map, less risk of
overwrite

Select this option to have the current date and time added to the
filename with each new scan conversion processed in batch
mode.

Scan Settings

Description

Maximum Range

Specifies the maximum distance, in mm, used for the laser data.

Linear Error

The forward/reverse error, expressed as the average variation (in
mm) per meter of travel.

Lateral Error

The left/right error, expressed as the average variation (in mm)
per meter of travel.

Use Loop Closing

Used for open areas - indicates that the robot has returned to a
known location. Minimum Loop Probability allows you to set how
closely the current position must match a previous scan. Default
is 80%.

Use Gyro Error Model

Specifies allowable error to correct for when registering laser
scans collected during mapping.

Scan Matching Mode

Choose between Normal or Fast matching. If you select Fast, the
scan match is performed only when MobilePlanner is in the registration phase.

Clean Settings

Description

Grid Size

Sets the size (in mm) of grid cells used to check whether the reading represents a real map point. A small value gives more cleaned
readings; a large value includes more points in the map.

Max Range

Sets the maximum distance (in mm) from the robot in which
readings are considered for inclusion in the map. This value only
affects the cleaning process; it does not affect the range used during the registration phase.

Map Settings

Description

Resolution

This adjusts the resolution of the map created from the scan file.

Set the Robot's Initial Location
It is important to establish the mobile robot’s starting location, which is also known as localizing your robot.
When you "localize to a point" on the map, you provide the mobile robot with location data. This data allows
the robot to match its current location with the same location on the map.
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As the mobile robot attempts to find its location on the map, it provides a localization score, or confidence
level. This confidence level should be at 80% or better for the mobile robot to navigate properly.
For more detailed information on localization, refer to Robot Localization on page 193.
To set the robot's starting location:
1. Click the Map button, then click Show Robot.
The Map tool bar displays robot control icons.

Figure 3-19: MobilePlanner Map toolbar
2. Click Localize Robot.
This puts the map into localize-to-point mode (and changes the cursor to indicate the new mode).
3. Click and hold on a spot on the map where you want the mobile robot located. This is where you
want the confidence threshold, or Localization Score, to be 80% or better as shown below.
While still holding the mouse button down, drag the localization mark's direction indicator to the direction the robot is facing. The robot will choose the most likely pose near the clicked location. If the
initial localization does not look correct, localize the robot again until it appears in the correct location.

Figure 3-20: Localize to Point Dialog Box
6. Click Done when the robot's localization score is where you want it to be.
The robot is now localized and you have successfully set the robot's current position.
NOTE: You must set the robot’s current position the first time you put the robot in a different
map.
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What’s Next?
Now that your robot is configured, you have scanned its operating space and created a detailed map,
you can do any of the following:
l

l

l

l

To edit your map further, see Working with Map Files on page 111.
To learn about, and start using, MobilePlanner software, see Using MobilePlanner Software on
page 53.
To configure your mobile robot, see Configuring the Robot on page 125
If you are familiar with MobilePlanner and want to set up goals and tasks for your mobile robot
to perform, see Working with Macros, Tasks, and Route Builder Tools on page 131

After Driving the Mobile Robot
After you're done driving the mobile robot, select Robot > Dock from the software main menu, or click
Dock, to return the mobile robot to a charging station.

Auto Dock
The Config > Robot Operation > Docking > Autodock parameter is the primary control for the robot's
automatic docking, and is normally set to True.
If the Autodock parameter is set to False, and you don't want to manually dock the robot each time, using
the Auto Dock menu item (Main Menu > Robot > Robot Tools > Auto Dock) will override the configuration parameter. The robot will return to a charging station when the charge is running low.
NOTE: If the Autodock parameter is set to True, you can override that behavior by turning off automatic docking. If you do this, remember to turn it back on when you are done, or the robot will not
recharge and eventually stop running.

What next?
Now, set the mobile robot’s initial position (also referred to as its ‘pose’). See Set the Robot's Initial Location
on page 50.
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The MobilePlanner software is the "control center" of the Mobile Robot Software Suite. Its user interface
has the tools for all major AIV activities, such as observing a fleet of AIVs, commanding individual AIVs to
drive, creating and editing map files, goals, and tasks, modifying AIV configurations, and more.
The following topics provide details on understanding and using the MobilePlanner features.

Overview of MobilePlanner

54

The MobilePlanner Interface

55

MobilePlanner Operator Mode Overview

57

The MobilePlanner Menu

60

The MobilePlanner Toolbars

67

Using Monitor Robot

72

The MobilePlanner Map Window

74

Draw Tab

78

The Build Tab

82

MobilePlanner Status and Tray Displays

84
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Overview of MobilePlanner
MobilePlanner has features you can use to scan the robot environment, configure the robot, create and edit
maps, and more. The interface is designed to be user-friendly and efficient, which reduces the learning
curve and the time needed for deployment.

Figure 4-1: MobilePlanner user interface (with map)
NOTE: While MobilePlanner is not necessary for each robot, you must have at least one licensed copy of
MobilePlanner to create a map.
From the MobilePlanner interface, you can:
l

Connect to and drive the mobile robot.

l

Create floorplans (maps) of the environment by importing and analyzing a robot’s scan data.

l

l

Edit maps by adding goals (and adding tasks to those goals), docks, forbidden areas, and more. You
can also erase stray or unwanted artifacts, combine pieces of maps, and make other changes.
Create a week-long schedule, which can include holidays. A schedule commands the robot to perform routes and other special activities at specified times.

l

Download and upload files, including maps and scan data, to and from a robot.

l

Set the system configuration parameters for the fleet.

l

With the optional Enterprise Manager (EM), monitor the location and status of all robots in a fleet.

l

View and interact with the job queuing manager.
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These features allow you to create a map with goals, docks, and advanced lines and areas, and start the
robot working in its environment.

The MobilePlanner Interface
The MobilePlanner interface consists of the following main sections:
l

Toolbar: Provides quick access to connection, mode buttons (Fleet, Config, Map, SetNetGo), file
save, and undo/redo functions. Some of these items are also available from the File and Edit
menus. For details, see Opens a submenu, which lets you select and open a file located on a particular robot or the Enterprise Manager (EM). on page 61 and Lets you undo the most recent action
on the map file. on page 62.

l

Fleet button

l

Config button

l

Map button

l

SetNetGo button
NOTE: By default, the Fleet, Config, and Map buttons are checked, and will open each when you
launch MobilePlanner and connect to a robot.

The following figure is an example of the MobilePlanner interface showing a map of a single mobile robot,
containing routes and goals. Show Robot is on, in the figure.

Figure 4-2: The MobilePlanner Interface (Example)
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Configuration (Config Tab)
There are five tabs under the Config tab: Robot Interface, Robot Operation, Robot Physical, Enterprise, and
Debug. The many configuration parameters are covered in Configuring the Robot on page 125.
Map Tab
l

l

l

l

l

When the map (<IPaddress>.map) tab is selected, the main window displays a map of the mobile
robot's operating space. The map consists of points and lines representing the walls, doors and other
stationary features within the environment. For more details, see The MobilePlanner Map Window
on page 74.
The Draw and Build Tabs, to the left of the map window, provide map editing tools, and tools for setting the mobile robot up to do tasks at goals (route building).
Robot tools are above the map window, and visible when Show Robot is toggled on. You can use
these tools to drive, dock, adjust speed, etc. These items are also available from the Robot menu. For
details, see Activates the Drive pad for driving the robot in its environment. on page 63.
To the right of the Robot tools is the Monitor icon. For details, see Using Monitor Robot on page 72.
The Status area, located below the map window, (shown with Show Robot button toggled on)
provides information on the robot position, temperature, odometer, wireless connection, and more.
For details, see MobilePlanner Status and Tray Displays on page 84.

Map Features Legend
To view available map features in MobilePlanner, click Map > Legend. If Show Robot is on, the legend also
shows map items associated with the robot, like sensor readings, paths, etc. Use the scroll bar to see more.

Figure 4-3: Map legend list
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SetNetGo Tab
The SetNetGo tab connects to the robot’s SetNetGo interface, and displays the various configurations associated with the mobile robot.

Figure 4-4: SetNetGo interface
For details on the interface elements, see the remaining topics in this chapter.

MobilePlanner Operator Mode Overview
Launching MobilePlanner without the license dongle automatically opens a version of MobilePlanner called
Operator Mode (you can also select Operator Mode from the Windows Start menu).
Operator Mode provides a limited set of tools for interfacing with mobile robots or the Enterprise Manager
(EM). Its main window, the Fleet window, shows the status of all mobile robots in your fleet and their jobs,
and allows for simple interventions in job execution sequences. Operator Mode does not support any setup
operations, and the Map, Config, and SetNetGo windows are unavailable.

MobilePlanner Operator Mode Interface
Operator Mode’s simplified user interface focuses on monitoring fleet robots and jobs. It uses graphical elements to represent robot statuses, and the status of all jobs (complete, in-progress, canceled, etc.).
To launch MobilePlanner Operator Mode, click the Windows Start menu, and select Start > All Programs
> Omron > MobilePlanner (Operator Mode). When MobilePlanner (Operator Mode) opens, enter the
IP address of a robot IP address or EM, and click Connect.
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Figure 4-5: MobilePlanner Operator Mode UI
The MobilePlanner (Operator Mode) interface allows you to connect to - and monitor - multiple robots.

MobilePlanner Operator Mode Jobs Tab
The Jobs tab displays all jobs assigned to the robots (listed by job ID). For debugging purposes, you can also
add a job to the currently monitored robot by clicking the Add Job button (lower right corner of the window), which displays the Add Job window.
NOTE: The Add Job window is not the primary method for submitting jobs to the fleet.

Figure 4-6: MobilePlanner Operator Mode Add Jobs window
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Each job consists of multiple segments, and each segment has an associated goal. In this window, you can
add or remove segments to or from a job, then submit the entire job to the queuing manager.
In this window, you can also add another job to the current job queue, assign a Job ID, set the job goal
(double-click the field below Goal to display a drop-down list of goals), and set the job’s priority.

Statistics Tab
The Statistics tab displays relevant statistics for your robots. Those statistics include:
l

FleetRobotInformation: the number of robots currently connected to the Enterprise Manager
(EM); their progress, and which are available and unavailable.

l

JobCounts: the number of completed, canceled, and modified jobs and job segments.

l

LastTripReset: the time (in sec), and human-readable date and time since last reset.

l

QueueInformation: lists information about pending and in-progress jobs.

l

l

l

StateInformation: information about the robots’ states (driving time/distance, parking time,
docking info, etc.).
TripJobCounts: statistics related to the robots’ job completion (number of completed, canceled, or
modified jobs/segments).
TripStateInformation: statistics about the robots’ trips when completing jobs (distance driven or
time spent at a particular job).
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The MobilePlanner Menu
The MobilePlanner interface includes a menu bar to access to the tools for editing the robot's map file. It
also applies to other non-map windows, provides tools for driving the robot, initiating scans, route building,
and searching the Config, and importing/exporting Config files.

Figure 4-7: Menu Bar
The following table describes the menu bar selections.
Menu
Option

Description

File

Allows you to open a local scan or map file, a map, scan, or configuration file on a
mobile robot, save the map file, insert another map into the existing map file, and
download or upload a files to/from a robot. For more details, see File Menu on page
61.

Edit

Allows you to undo or redo your last command. For more details, see Edit Menu on
page 62.

Robot

Gives you control over various robot activities (stop, drive, dock/undock), allows you
to monitor the robot dashboard and/or enterprise details; create custom commands;
create an enterprise message of the day; and reload a configuration or stop the
robot. For more details, see Robot Menu on page 63.

Map

Allows you work with and edit the displayed map file. For more details, see Map Menu
on page 64.

View

Allows you to change the units used in the map, and turn the toolbar labels on and
off. For more details, see View Menu on page 65.

Tools

Allows you to update map features and preferences. For more details, see Tools Menu
on page 65

Window

Allows you to access the different files open in the workspace and change the way
the windows in MobilePlanner are displayed. You can choose to tile them in the workspace or have them cascade. For more details, see Window Menu on page 66.

Help

Provides help on the MobilePlanner interface. For more details, see Help Menu on
page 66.
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File Menu
Menu Option

Description

Open...

Opens a dialog, to search for and select a local map or a scan file to open.

Open on Robot

Opens a submenu, which lets you select and open a file located on a particular
robot or the Enterprise Manager (EM).
l

l

Robot Host Name or IP Address opens the login page, if the robot associated with that robot name or IP address is configured for authentication.
This submenu shows a list of the most recently used robots or EMs.
Select Robot... allows you to open the login dialog box and choose a file located on a different robot.

Displays the MobilePlanner Robot Login dialog box. Once you select a robot, you can
search for and select a Map or Scan file (if available) to open. You can also access
the Configuration and SetNetGo software on the robot.
Close

Closes the active file.

Import Config...

(Available when the Configuration Editor is selected.) Opens a dialog to import a
robot configuration file into MobilePlanner.

Insert Map...

(Available when the Map mode tab is selected.) Opens a dialog to search for and
select a local map file to open and insert into the active map file.
Used for small changes to the physical environment that affect the robot's route,
eliminates the need to rescan the entire workspace. See Inserting a Map File into
an Existing Map File on page 120 for more information on this feature.

Save

Writes changes to the active file, and saves either onto a robot (if opened from a
robot) or disk (if opened from a PC).

Save As...

Opens the Save As dialog. Used to save the active file under a different name and to
a particular location on the local PC.
Note that you can also save to different file formats (such as JPG or SVG). In those
cases, the new file is not displayed in the editor.

Save on Robot

Opens a submenu for saving changes to a particular robot's map file.
l

l

Robot Name or IP Address opens the login page for the robot associated
with that IP address. This submenu lists the five most recently used robots.
Select Robot... opens the login dialog box for choosing a different robot on
which to save the map file.
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If configured for the robot, the MobilePlanner Robot Login dialog box displays. Once
connected to the robot, you can save the map file.
This menu option is only available in Map mode.
Download/Upload

Opens a submenu to transfer any type of file to and from a particular robot (most
commonly, a sound file to use with ‘play,’ or playBackgroundSound’).
l

l

Robot Name or IP Address opens the login page for the robot associated
with that IP address. This submenu lists the five most recently used robots.
Select Robot... opens the login dialog box for choosing a different robot on
which to save the map file.

The MobilePlanner Robot Login dialog box displays. Once connected to the robot,
you can upload the map file to the robot or download a map file from the robot.
Exit

Closes the application.

Edit Menu
Menu Option
Undo

Description
Lets you undo the most recent action on the map file.
This menu option is only available in Map mode.
NOTE: Undo is unavailable if you saved the map.

Redo

Lets you repeat the most recent action that you undid in the map file.
This menu option is only available in Map mode.
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Robot Menu
Menu Option

Description

Stop

Stops the mobile robot when it is in motion.

Drive

Activates the Drive pad for driving the robot in its environment.
CAUTION: Toggle the Safe Drive button ON to prevent
the robot from running into anything while you are driving
it. if Safe Drive mode is disabled, the map background
turns yellow, indicating “use caution” while driving.
NOTE: With Show Robot turned ON, you can access robot drive icons
from the Map view.

Dock

Sends the robot to a dock.

Undock

Releases the robot from the dock.

Monitor

(Same as the Monitor button in the map and robot tools menu). Allows you
to view and/or configure various AIV details - battery info, digital inputs and
outputs, audio, add and execute tasks, macros, and routes.

Debug

Allows you to trace underway tasks for debugging.
NOTE: This is an advanced feature, used for debugging advanced functionality.

Custom Commands

Allows you to create and send custom commands to the robot, such as connection tests, debug log file starts and stops, and simple pop-ups (not an allinclusive list - many other custom commands are available).

Map Creation

Allows you to start and/or stop the robot's scanning process, from which you
can build a map file.

Messages

Allows you to create custom Enterprise and/or Robot messages of the day.

Robot Tools

Provides access to advanced robot tools, including localizing, reloading configurations, auto-docking, and issuing shutdown commands for a single
robot or all robots in the fleet.

Safety Commissioning

Allows testing and commissioning (verification of proper function) of a
robot's on-board safety systems. Uses a wizard to test E-Stop (tests brake
activation) and Safety Laser (tests max speed limits and obstacle detection).
Per EN-1525, Commissioning must be done by specially trained people. See
Safety and Regulatory Information on page 25 for details on Safety Commissioning.
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Map Menu
Menu Option

Description

Fit in Window

Adjusts the map so it all fits within the map window.

Grid

Displays the grid on in the map window. Grid line spacing is at 1 meter intervals.
NOTE: The MobilePlanner grid is not the path planning grid or localization
grid. It is simply for reference.

Origin

Displays the X/Y coordinates of the overall map. You must zoom the map view
out to see the origin lines.

Robot Data

Allows you to control the display of various robot-related map features such as
sonar, laser, path, and localization.

Map Data

Opens a submenu, which lets you toggle the features to view on the active map
file:

Rotate

l

Points

l

Lines

l

Lights (if using Acuity)

Opens a submenu, which lets you rotate the entire map in the map window.
l

Rotate Right

l

Rotate Left

l

Rotate Full 180 o

l

Reset to None

You can also save the rotated map as the default orientation.
Legend

Keeps track of all of the different features available in the map file. Each feature
is identified on the map with a different color rectangle or line. For more details,
see Map Modes on page 76.
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View Menu
Menu Option
Units

Description
Opens a submenu in which you can change map units. You can select:
l

Millimeters (default)

l

Meters

l

Feet/Inches

l

Inches

The units apply to values displayed in the status bar, in map object edit
boxes, and when using a measuring stick. See The MobilePlanner Toolbars on
page 67 for details.
Toolbar Labels

Toggles toolbar labels on or off. To hide the labels, uncheck this menu option.

Tools Menu
Menu Option

Description

Update Map Features...

Opens a dialog box in which you can choose to update the current map.

Preferences...

Opens a dialog box with tabs for Comm and Computer ID parameters.
l

l

Comm Tab: Allows you to select Robot Server (from pick list),
and set connection attributes for TCP/IP only, or Reuse login
information when reconnecting.
Computer ID Tab: Includes a field that displays the name of
the computer on which the MobilePlanner installation exists
(e.g., "John Doe's Laptop"), and allows you to select the goal
nearest the robot's current position.

Click OK after making any configuration changes.
Click Reset... reverts to initial installation-like state - resets all previous changes.
Click Cancel to stop without making any changes.
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Window Menu
Menu Option

Description

Tab

Arranges the open windows in tabs, just below the main toolbar. This
is the default display mode.

Tile

Arranges the open windows as tiles, open next to each other.

Cascade

Arranges the open windows in a cascade, or waterfall, formation.

1:<IPaddress>:map

Contains a list of the open map and/or configuration files, or
SetNetGo. Select from the list to make that the active window.

2:<IPaddress>:Configuration
3:<IPaddress>:SetNetGo

Help Menu
Menu Option

Description

About MobilePlanner...

Provides information on the current version of MobilePlanner.

About Qt...

Provides information on Qt, the toolkit MobilePlanner uses for
the user interface.

Mobile Robot Software Suite
User's Guide

Allows you to open a Windows type help version of this guide
while using MobilePlanner software.

What's This?

Selecting this menu option, or using the shortcut Shift + F1,
and then clicking on the MobilePlanner workspace displays a
pop-up containing a brief description of some features.

Open Output Log Folder

Opens the folder containing saved MobilePlanner output logs.

Mobile Robot Software SuiteUser's Guide 18484-001 Rev. B
Page 66

The MobilePlanner Toolbars

The MobilePlanner Toolbars
There are three toolbars possible in the MobilePlanner interface:
l

The main toolbar, which is located at the top of the MobilePlanner interface.

In Map mode only:
l

The map toolbar, which is located above the map.

l

The robot toolbar, also above the map.

The following sections describe each set of tools.

Main Toolbar
The MobilePlanner main toolbar is located at the top of the window, under the main menu.

Figure 4-8: Main Toolbar
The following table lists the toolbar icons and describes their functions:
Toolbar Icon

Description
Connects to the robot or server at the specified IP address. Use the drop-down list
to select a previously-used IP address, or type a new IP address directly in the
field.
When a robot or server is connected, this toggles to Disconnect.
Opens the Fleet window, which shows status and job statistics for all robots in
your fleet. It uses graphical icons to represent interrupted, canceled, in-progress,
pending, and completed jobs. Click the checkbox to have the Fleet window open
when you connect to a robot or EM.
Displays the Configuration mode tab, which is used to set configuration parameters. For details, see Configuring the Robot on page 125. Click the checkbox to
have the Config tab open when you connect to a robot or EM.

Displays the Map mode tab, which is used to edit the map. For details, see Editing
a Map File on page 114. Click the checkbox to have the map load when you connect to a robot or EM.
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Displays the SetNetGo mode tab, which is used to access the SetNetGo interface.
For details, see Using the SetNetGo Software on page 87. Click the checkbox to
have SetNetGo open when youconnect to a robot or EM.

Saves changes to the active map or configuration file on the robot.

Lets you undo the most recent action performed on the map file.

Lets you restore the most recent item you undid in the map file.

When MobilePlanner is in the Config mode, allows you to search all configurations
for specific key words. Allows you to find parameters by name, or search for a specific word in a parameter’s description (searching for ‘preferred’ in the example
below). You can edit the Config values in the main tab, but not in the search results.

Figure 4-9: Search window - searching for ‘preferred’
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Robot and Map Toolbars
The map toolbars control the view of the map, set a goal at the robot position, and localize the robot. There
are two different map toolbars available: one when the Show Robot button is toggled ON (the robot is displayed on the map); the other with the Show Robot button toggled OFF (and the robot is hidden from the
map).

Figure 4-10: Robot Toolbar (Show Robot ON)

Figure 4-11: Map Toolbar (Show Robot OFF)
The following table lists the toolbar icons and describes their functions.
Toolbar Icon

Description

Some of the following icons are available when the Show Robot button is toggled ON, but are disabled if
the robot cannot service the request because of low state of charge, or if E-Stop is pressed.
Stops the mobile robot any time you click this icon, even when navigating in
autonomous mode.
NOTE: You can also use your keyboard’s Esc key to stop the robot.
Sends the robot to a point you select on the map.

Sends the mobile robot to a goal you select on the map.

ON when the robot is on a dock or heading to a dock. Also sends the robot to a dock.
When OFF, releases the robot from the dock.
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Opens the Drive pad, which is used to move the robot in its environment. Be sure
that you have the Safe Drive button toggled ON, which prevents the robot from running into anything while you are driving it.
Highlight (click on) the pop-up window, and use the mouse or the arrow keys on the
keyboard to move the robot in the direction you want it to go.
CAUTION: When Safe Drive mode is disabled, the background of
the map turns yellow, indicating "use caution" while driving.

Opens the Localize Robot dialog, which is used to localize the robot to a point selected
on the map.

Allows you to create a goal and/or door with goals, place a cart, or place a dock at the
robot’s current location.

Centers the map on the current robot. This is helpful when you have multiple robots
in your workspace and you need to locate a specific robot quickly. It also allows you to
watch the robot as it performs tasks and moves through its route.

Adjusts the map view to fit in the map window.

Zooms map out (reduced magnification, more map visible).
NOTE: You can also zoom the map by using Shift + left click, or Shift + right click,
or by clicking and holding either the right mouse button or scroll wheel, while moving the mouse around the workspace.
Zooms map in (increased magnification, more details visible).

Allows you to pan around the map.
1. Click on the Pan icon to display the Pan Map box.
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2. Click on any of the four arrows of the Pan Map box to move that direction in
the map.
The keyboard arrow keys perform the same function as clicking on the Pan
Map arrows.
NOTE: If Center on Robot is turned on, you cannot pan the map window.
NOTE: You can also pan the map by clicking and holding either the right mouse
button or scroll wheel, while moving the mouse around the workspace.
The Pan Up, Pan Down, Pan Left and Pan Right icons are available when the Show Robot button is
toggled OFF.
Fit in Window,
Zoom In/Out

See descriptions above.
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Using Monitor Robot
The Monitor robot feature is available only when the Show Robot button is toggled on. It provides a convenient place to monitor important robot details (battery info, state, job counts, sensors, and queuing
stats), and the status of digital inputs/outputs.
It also provides a place for sending a robot on a route, adjusting audio input/output volumes, and inputting
Say commands (phrases that the robot speaks with its text-to-speech converter).
To access the Monitor:
1. Click the Show Robot button to toggle it on.
This exposes the Robot toolbar. For more details on the Robot toolbar, see The MobilePlanner Toolbars on page 67.
2. Click Monitor on the Robot toolbar to display a sub-menu with various robot attributes you can monitor.

Figure 4-12: Monitor robot drop-down menu
The following table describes the various robot attributes you can monitor.
Item

Description

Dashboard

Displays an information window listing jobs (number of interrupted, canceled,
in-progress, pending, and completed) and robots (that need assistance, had EStop pressed, busy, available, and unavailable).

Enterprise Details

Lists information about robots in the fleet - availability, status of assigned
jobs, queuing and state information, system status, and memory use.
NOTE: A robot must be in the Available state to be selected for a job.

Details

Lists specific details about the currently monitored robot - battery/charge
stats, robot pose information, wireless data.
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Item

Description

Digital I/O

Allows you to monitor custom input/output states, and toggle output states
ON (green) or OFF (black).

Audio

Controls incoming and outgoing audio volume.
Audio Incoming: MobilePlanner Out: controls the level out (for example,
'sendSpeech').
Audio (Output): Robot Out controls the volume of speech audio files the robot
plays.

Tasks

Lists current tasks assigned to monitored robot, and allows you to add them to
the selected route builder list (normally a goal versus a route).

Macros

Lists, and allows immediate execution of all existing macros.

Routes

Lists, and allows immediate execution of all existing routes.

Adjusting Audio Levels
The robot monitor also allows you to adjust the incoming and outgoing audio levels. These levels are set by
the slide controls shown in the following figure.

Figure 4-13: Audio Controls
You can adjust audio levels by moving the slide controls to the right (louder) or left (softer). You can also
amplify the effect of the incoming audio control setting by selecting the 2X check box.
Making the Robot Talk
The monitor robot window includes a text-to-speech feature. You can use the "Say" field to input a word or
phrase that you want the robot to speak.

Figure 4-14: Say Controls
When you click the Say icon, the text is converted to synthesized speech through the text-to-speech converter.
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The MobilePlanner Map Window
The MobilePlanner Map window displays the map file that you are editing. When you first start MobilePlanner, no map is displayed until you connect to a robot or Enterprise Manager appliance. You can also open a
map saved locally on your computer or network. For details on opening maps, see Loading a Map File.
Below is an example of the MobilePlanner interface with a map file opened. Note that the Show Robot button is toggled OFF, which exposes the tools on the Draw function tab.

Figure 4-15: The MobilePlanner Interface, Map Tab, Show Robot OFF
NOTE: To create the initial map, you must first use MobilePlanner to scan the robot's environment and
then turn the scan into a map. For details, see Scanning Your Environment.

Map Zoom
Maps initially open zoomed out to give you an overall view of the robot’s environment. To quickly find the
current robot in the map, click the Show Robot button, then click Center on Robot. The map zooms in,
focused on the robot.
NOTE: The Show Robot button must be ON to display the Center on Robot icon.
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Map Controls
You can use the mouse or the keyboard to adjust the map view. The following table describes the map controls.
To...

Do this...

Pan

Mouse: press and hold the right mouse button (or use the scroll wheel), move the
mouse around the workspace.
Keyboard: use the arrow keys to move right, left, up and down.
NOTE: You can’t pan the map when the Center on Robot toolbar icon is toggled ON.

Zoom in

Mouse: press the Shift key and click the right mouse button; or you can rotate the
scroll wheel forward (without the Shift key).
Keyboard: press the Shift key and the Up arrow.

Zoom
out

Mouse: press the Shift key and click the left mouse button; or you can rotate the scroll
wheel backward (without the Shift key).
Keyboard: press the Shift key and the Down arrow.

Map Features
Map features can be as simple as the static features of the environment (walls, doors, etc.) or, depending
on the features you add to the map, they can be quite intricate. In general, more map detail improves
robot navigation.
To create a detailed map of the environment, you need to scan the environment thoroughly and then edit
the map. This is done in the MobilePlanner software. For more information on environment scanning and
map editing, refer to Scanning Your Environment and Editing a Map File on page 114.
The following table describes the different features shown on the map.
Map Feature

Definition
This rounded rectangle represents the robot. Notice that the
black line indicates the direction the robot is currently facing.
The black dots and lines on the map are the walls, doors, and
other static fixtures in the environment.
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Map Feature

Definition
The blue dots and lines are the features the robot "sees" with
its navigation laser. Some robots have additional lasers which
produce different colored dots.

The yellow squares represent the location where the robot
should go, and the black line is the direction it should face,
when it starts to dock. The dock object should be approximately 1 to 1.5 meters in front of the dock.
The green squares represent a goal. The line indicates the
robot’s desired heading when it reaches the goal. Goals are predefined locations where you can send the robot.

Map Modes
When Show Robot is on, there are several map modes which provide a different robot function (see the following table):
Icon

Map Mode

Definition

Send Robot

Allows you to send the robot to a certain spot on the map. When active, clicking on the map causes the robot to move to that spot.
To activate this mode, click Send Robot on the Toolbar, then click
on the map with the left mouse button to send the robot to that
point. You can also send the robot by holding down the Ctrl key and
clicking on the map.
To specify the robot’s desired heading when it arrives at the designated spot, press the mouse button and drag.
To deactivate this mode, click the Send Robot icon to toggle it off.
After you click a point on the map, the mobile robot (the red oval)
autonomously drives to the point you selected.

Robot Control

Allows you to drive or send the robot using the keyboard. To activate
this mode, hold down the Ctrl key and press the arrow keys.

Localize to Point

Allows you to localize (mark the robot’s location) the robot on the
map. See Robot Localization on page 193 for details.

NOTE: When Show Robot is OFF, the cursor shape indicates what your mouse click or movement will do
(see the following table). These cursors are visible after selecting an object.
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Cursor

Function

Appears when you...

Open the Edit window (double-click), or drag the object
within the map.

Double-click or click-and-hold
on an object, other than on a
heading marker or endpoint.

Change the heading of a goal or dock, or resize a line.

Click on the goal/dock heading marker or either end of a
line.

Resize a rectangular object (the cursor is rotated 90°
depending on which corner you pick).

Click on a corner of an area or
sector.

Rotate the object.

Click on the heading arrowhead of an area.

Map Legend
As you edit the map file, you can create goals, lines, forbidden areas, docks and many other features in the
environment. Use the Map Legend to keep track of all of the different features that can be added to your
map file.
Select Map > Legend... from the main menu to open the Map Legend window.

Figure 4-16: Map Legend
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Draw Tab
You can use the Draw tab to add and edit map items (for details on map editing, see Working with Map Files
on page 111).
NOTE: The Draw tab is only active when the Show Robot button is toggled OFF.
The following table lists the toolbar icons and their functions.
Item

Description
Select a feature (point, line, area, etc.) on the current map.
The status bar on the bottom left side of the window displays information about the
feature you selected.

Remove points or lines from the active map. Does not remove custom/landmark
objects.
1. Click on the Eraser icon.
2. Use the pull down menu to select the eraser size from 5 mm to 10000 mm.
3. Click and hold the left mouse button, while moving the mouse over the
points and lines you want to erase.
Click Goal, then click on a map location to add a goal. In the Edit Goal dialog box
you can:
l

label the goal

l

provide a description

l

select the type of goal (if available)

l

adjust the X/Y position and heading. You can adjust the heading after placement by holding the left mouse button down, and dragging around the goal.
The heading will follow the cursor.

Click Dock, then click in the map at the new dock’s location. In the Edit Dock dialog
box you can:
l

label the dock

l

provide a description

l

select the type of dock (if available)

l

adjust the X/Y position and heading. You can adjust the heading after placement by holding the left mouse button down, and dragging around the
dock. The heading will follow the cursor.
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Mobile robots will not cross forbidden lines, or enter forbidden areas. To add a forbidden line or area:
1. Press and hold the left mouse button.
2. Drag the mouse to create the line or area and to adjust the size.
3. Release the mouse button (the line or area remains selected).
4. Press and hold the left mouse button.
5. Drag the selected line/area to move its location on the map.
6. For an area, click and hold on the heading arrowhead, then drag to rotate
the area.
Allows you to measure distances, display a measuring stick, add Preferred or Resisted Lines, or a Map Data Line to your map.

Place lines and rectangles to the x/y axis (or 45 degree angles). Deselect this button to draw or rotate at any angle.
To temporarily toggle this button while drawing a line or rotating a rectangle, press
and hold the Ctrl key. Release the Ctrl key after making the edit.
Places special areas on the map that the robots will avoid entering or crossing (e.g.,
door swing sectors, need to enter sectors, resisted sectors, etc. To add an advanced
area to the map:
1. Press and hold the left mouse button.
2. Drag the mouse to create the line or area and to adjust the size.
3. Release the mouse button (the line or area remains selected).
4. Press and hold the left mouse button.
5. Drag the selected line/area to move its location on the map.
6. For an area, click and hold on the heading arrowhead, then drag to rotate
the area.
Opens a submenu for adding a label to any advanced feature on the map.
1. Click on Advanced Points, then select Label from the submenu.
2. Click on a feature in the map you want to label, then use the Edit Label dialog box to enter a label, provide a description, and adjust the X/Y position
and heading.
NOTE: The label box is a special text box that does not scale when
zoomed.
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Using Advanced Lines and Areas
Advanced lines and areas (in Config > Robot Operation > Map Features) control the robot's behavior.
You can alter traffic flow, restrict the robot from entering an area, and have the robot use a preferred route.
For more information on creating these features and more, refer to Traffic Management on page 167.
Advanced Lines
Advanced Line

Definition

Measuring Stick

Places a line on the map to measure distances in the map. You can change the
measurement units by selecting View > Units from the main menu.

Preferred Line

Places a line on the map representing the path that you prefer the robot use.

Resisted Boundary

Places a boundary line that the robot resists crossing. If there is no other way
around an obstacle, the robot will cross a resisted boundary (though at a higher
cost). For more information, see Cost Based Path Planning on page 171.
You can adjust the amount of line resistance, which is preferred over a restricted boundary.

Restricted Boundary

Places a boundary line that the robot will avoid if possible.

Switchable Forbidden
Line

Places a boundary line that you can control with tasks or through ARCL.

Advanced Areas
Advanced Area

Definition

Door

Places an area on the map to handle doors.

DoorSwingSector

Places a sector on the map that corresponds to a door’s swing arc.

Door Virtual

Places a goal on the map for the robot to drive to before entering a door.

IgnoreLowLaser

Enables a sector in which the robot ignores low laser readings (e.g., for driving up and down ramps, crossing the threshold gap in an elevator, etc.).

IgnoreSonar

Places an area on the map that will disable the sonar sensors. This can be
useful for crossing known thresholds, so the sonar doesn’t prevent the
robot from driving over the threshold.
NOTE: If you have the low front laser, this section does not apply.

IgnoreTiltedLaser

Instructs the robot to ignore inputs from side-mounted lasers.
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ManagedDestination

Allows use of multiple goals as a single destination to determine robot occupancy of the sector.

ManagedMotion

Limits the number of robots allowed to drive in an area (sector) at the same
time.

ManagedMotionOverride

Makes contained robots appear to be driving. Used primarily in constricted
areas.

Movement Parameters

Places an area on the map where you can change movement parameters,
such as velocity, acceleration, and deceleration, in real time.

Need to Enter

Places an area on the map that the robot can drive to only if it is already in
the area or a goal that it needs to drive to is in the area.

PathPlanningSettings

Places a sector that changes path planning settings.

PreferredDirectionLeft,
PreferredDirectionRight

Places an area on the map that directs the robot to travel along the right or
left side of the path, unless there is an obstacle in the way.
The robot chooses the preferred side regardless of which way the robot is
traveling. In other words, it follows the preferred side whether it is traveling
up the hallway or down the hallway.

PreferredDirectionRight
Single,
PreferredDirectionLeft
Single

Enable sectors that cause the robot to prefer driving on the left or right, in
one direction only. Generally, the bi-directional PreferredDirectionRight/Left
should be used instead. if two single direction sectors are placed next to
each other, they must be aligned with care so robots do not collide.
Using a preferred direction single tells the robot to travel along the right (or
left) side of the path unless there is an obstacle in the way.
The robot chooses the preferred direction in one direction only. In other
words, the robot will prefer to travel on the right (or left) side only when it is
traveling up the hallway.

SingleRobot

Places an area on the map that only a single robot can be in at any one
time.

SwitchableForbiddenArea

Places an area on the map that can be controlled with tasks or through
ARCL.

TaskSector

Places an area on the map that has a task list of what the robot will do immediately upon entering and exiting the sector.

VolumeAdjustment

Places an area on the map where the robot's audio output can be changed.
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The Build Tab
The Build tab allows you to create macros, and add tasks for the robot to perform.
To display the route building tools, click the Build tab. The Build tools, shown in the following figure, are displayed on the left side of the map window. The Build tab displays two scrollable panes, each using tabs to
organize the lists available for use.

Figure 4-17: The Source Lists and Editable Lists Pane
The following table lists the toolbar icons and describes their functions.
Item

Description

Source Lists pane

Contains lists of robot tasks and goals that you can use to create macros
or routes for the robot to navigate. You can also put macros in other macros as well. To view the different lists, select the appropriate tab.

Editable Lists pane

Contains lists of all current routes, goals, and macros. You can also add
new tasks the existing lists that tell the robot what to do in certain circumstances, such as after reaching a goal, when docking, and when specific event occur, such as bumping into something.
If the MobilePlanner workspace is filled with multiple windows and some
tabs are not visible, move between tabs using the arrows.

New Route/Macro Button

Creates a new route and/or macro (depending on which window in which
you are working), and adds it to the Routes tab.
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Item
Pick Goal Button

Description
When ON and a route is selected, lets you click goals on the map, to add to
the route. After adding the goals to the route, you can drag the goals up/down to set their order.

For more information on creating tasks, goals, routes and macros, see Using the Route Builder on page
152.
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MobilePlanner Status and Tray Displays
The status and tray displays allow you to monitor the status of the robot (or robots) directly from the software interface.

Status Information
The status of the selected (red) robot is displayed directly beneath the map, as shown in the following figure.
NOTE: In MobilePlanner, the Status area is only visible when the Show Robot button is toggled ON.

Figure 4-18: Status Information
The following table describes some of the available status information.
NOTE: By default, the status area shows only a small sub-set of available robot details. To view other
data, see Displaying Other Robot-Specific Details (below).
Status Detail

Description

RobotX and RobotY The current X and Y position of the robot in its operating space.
RobotTh

Robot theta - the robot’s heading (which way it’s facing), in degrees, measured
counter-clockwise. 0 is the x axis.

TransVel

The velocity of the robot.

RotVel

The robot's rotational velocity (how fast it is turning).

Displaying Other Robot-Specific Details
There are many other robot-specific parameters you can choose to display in the status area. To view
and/or add other robot details, in the MobilePlanner main menu, select Robot > Monitor > Details.
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Figure 4-19: Robot details window
If you want to add a detail to the status area, click on the detail, then click the Show in Map button
(lower left corner). Or, you can right-click in the status area to Hide in Map.

Tray Information
Below the status area, there is a tray that contains information such as connection status and the pointer
location.
NOTE: The tray information is always visible.

Figure 4-20: Tray Information
The following table describes the items available in the tray.
Tray Icons

Description
Displays the temperature reading of the current robot.

Indicates the state of charge (in %). The icon turns yellow when the charge
begins to run low, flashes red when the battery is low and the robot needs to
dock.
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Tray Icons

Description
Status of the wireless connection from MobilePlanner to the robot/EM.

X:

Shows the X position of the pointer.

Y:

Shows the Y position of the pointer.
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The SetNetGo OS resides on the mobile robot and EM (optional for a single robot, required for a fleet of
robots using a shared space), and sets the configurations for certain onboard systems, such as wireless
communication settings.
You can access SetNetGo either from the MobilePlanner SetNetGo interface, or directly on the robot using
a secure web-based server. If needed, your organization’s IT group can configure your wireless Ethernet
for you, without needing the dongle to run the MobilePlanner software.

Overview of the SetNetGo OS

88

Using the SetNetGo Interface

89

Viewing the Status Logs

93

Network Tab

94

Port Forwarding

97

Software Tab

98

Uploading, Backing up, and Restoring SetNetGo

99

Uploading a New SetNetGo OS

100

Backing Up and Restoring SetNetGo

101

SetNetGo Recovery Mode

103

Configuring ARAM

104
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Overview of the SetNetGo OS
The SetNetGo software allows you to configure certain on-board systems, such as the Ethernet interface
settings, serial and TCP port-forwarding, and to perform systems diagnostics, such as examining and
retrieving log files.

Connecting to SetNetGo
The recommended way to connect to the SetNetGo OS is through the SetNetGo interface in the MobilePlanner software.
Connecting to SetNetGo via web browser:
You can also access the SetNetGo software via a web browser (such as Chrome, Firefox or Internet
Explorer) if, for example, your IT department is helping with network configurations, or you don’t have
access to your laptop with MobilePlanner installed on it.
NOTE: Web browser access must be enabled in SetNetGo > Security tab > SetNetGo Access.
To do this, connect one end of a CAT 5 Ethernet cable to your computer (which you have set to IP address
1.2.3.* (not 4)), then connect the other end directly to the robot’s Ethernet Maintenance Port. The robot’s
maintenance Ethernet address URL: https://1.2.3.4, and uses no user name or password.

Figure 5-1: Browser URL address
NOTE: You can ignore the SetNetGo certificate error. Click "Continue to this website (not recommended)." to display SetNetGo.

Figure 5-2: Browser certificate warning

Mobile Robot Software SuiteUser's Guide 18484-001 Rev. B
Page 88

Using the SetNetGo Interface

Using the SetNetGo Interface
The SetNetGo OS resides on the mobile robot and Enterprise Manager(EM), and is accessible through the
SetNetGo interface in MobilePlanner.
NOTE: If you are unable to access MobilePlanner, you can still access SetNetGo by connecting your PC
directly to the robot's Ethernet Maintenance Port (using CAT5 Ethernet cable). Or, you can launch a
Web browser (if Web Availability is enabled in SetNetGo > Security tab > SetNetGo Access), and
entering the URL https://1.2.3.4 (the robot's maintenance Ethernet address).
The SetNetGo start-up screen (from MobilePlanner) is shown below.
NOTE: If you need to request support, click the Download debug info button to obtain a debug file for
troubleshooting.

Figure 5-3: SetNetGo interface
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The SetNetGo menu, shown at the top of the screen, consists of the following tabs:
Menu Option

Sub-Menu Option

Description

Status

This menu option displays various logs and status updates. See Viewing the Status
Logs on page 93 for details.
Home

Returns you to the SetNetGo home screen.

ARAM (robot)
ARAMCentral (EM)
Log

Gives the option to display the entire ARAMCentral log, the last
200 lines, or continuous refresh displaying the last 200 lines of
the ARAM log within SetNetGo. It also allows you to view the
current log file or download of the last 7 log files.

Network

Displays the current status of network interface, the wireless
interfaces status and the routing table.

SetNetGo Log

Displays the SetNetGo log file.

SetNetGo
Resources

Displays status of your resources, including processes currently
running on the robot or EM, Kernel Log, Disk Usage, Memory
Usage, the Interrupts table, IO Memory usage and IO Port
usage tables, and USB Devices.

Debug Info

Downloads a .zip file containing detailed information on system
status for troubleshooting.
NOTE: Download a debug file before requesting support.

Network

Configurations for setting up your network. See Network Tab on page 94 for details.
Wireless Ethernet

These parameters allow you to enter static or dynamic IP settings (IP Assignment and Address, Netmask, Gateway, and
DNS1); select a WiFi network; configure security settings (i.e.,
encryption and authentication); and configure Radio settings,
including Watchdog Timer.

User LAN Ethernet

This screen has settings for interface mode, IP Address, Netmask, DHCP Server for Accessories, and DHCP IP Range. If you
are using an Enterprise Manager or a network-based hardware
accessory for a mobile robot, you must set up a wired Ethernet
port. Use Accessory mode (default) for individual mobile robots,
and server mode with an Enterprise Manager.

RS-232 Port Forwarding

Forwards a custom TCP port on the wireless Ethernet interface
to an RS-232 port on the robot’s core. The TCP port and serial
port settings are configurable.
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Software

Security

Ethernet Forwarding

Supports forwarding a custom TCP port on the wireless Ethernet interface to a custom TCP port on an IP address of a
device connected to the User LAN interface. The TCP port numbers and IP address are user-configurable.

Utilities

Use this tab to ping a specific IP address, initiate trace route (display packet path), and display the ARP table (correlate
MAC address and corresponding IP address).

Configurations for ARAM settings (including install new ARAM version)
ARAM Settings

Change advanced settings for recovery, such as reverting the
configuration back to defaults.

Manage Installed
Software

This tab displays current versions of installed software, with
options to view release notes, restart, uninstall, or disable application(s), and view runtime logs. Also allows you to download
MobilePlanner, and update the mobile software.

Manage user accounts and robot access (disabled by default).
ARAM Access Control

This tab allows you to enable or disable access controls that
restrict who can access to robots and Enterprise Manager with
MobilePlanner. Disabling removes access controls. If enabled,
allows you to specify specific access controls for admins, MultiRobot access, and certain users (click the Modify Permissions link
to the left of Delete, under Apply to view the default permissions for each user). You can also add new users to the
access list.

SetNetGo Access

Allows you to enable or disable Web availability via Wireless/User LAN interface, and set access password.
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System

Manage date/time, upload new SetNetGo OS, conduct backup and restore operations.
Date/Time

Set time, zone, and NTP Server.
NOTE: The robots will automatically synchronize with an
EM. Use NTP on the EM or for single robot operations.

Upload SetNetGo
OS

Upload and install a new SetNetGo version.
NOTE: The system can store two different OS images. You
can select which version to load into each slot, and choose
which is the bootable image.

Backup/Restore
Options

Allows you to configure restore settings (from the same, or a different robot), set a new backup restore point, or revert to a different restore point.

Reboot

Allows you to reboot the robot's computer (core) or Enterprise
Manager (EM). Normally not a visible option unless enabled by
checking the Remote Reboot radio button in SetNetGo >
Security > SetNetGo Access.
CAUTION: Rebooting the robot's core interrupts all robot operations, and could cause
damage to the robot. Rebooting the EM will disrupt all jobs and robots.
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Viewing the Status Logs
SetNetGo keeps track of various robot activities, including ARAM, networking, and resource use. This
information is stored in status logs that you can view through SetNetGo.
To view the status logs:
1. Connect to SetNetGo through the MobilePlanner SetNetGo interface.
2. Select the Status link at the top of the SetNetGo screen.
The SetNetGo Status screen appears as shown in the following figure:

Figure 5-4: SetNetGo interface
NOTE: The Download debug info button is critical for taking a backup of the current configuration, and providing this information when requesting support.
The status logs you can view depend on whether you are connected to SetNetGo through an Enterprise
Manager or a single mobile robot. Generally you can view the following type of status logs:
l

ARAM (on the robot), ARAMCentral (on the EM1100)

l

Network

l

SetNetGo Log

l

SetNetGo Resources

l

Debug Info
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Network Tab
Use SetNetGo to configure the mobile robot's network settings. For remote access to your mobile robot,
you should set up a static IP address. If you are not familiar with setting up a network or do not have an
assigned IP address for the robot, please refer to your system administrator.
NOTE: After changing a value in each SetNetGo screen, you must click Apply before switching to
another sub-screen, or those values will not be saved.
To configure your mobile robot's network settings:
1. From the MobilePlanner SetNetGo interface, connect to SetNetGo.
2. Select the Network link from the top of the SetNetGo screen.
The SetNetGo Network screen appears as shown in the following figure.

Figure 5-5: SetNetGo interface - Network tab
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Wireless Ethernet Settings
Select Network > Wireless Ethernet to set up the wireless Ethernet interface. The table below
describes the parameters that you can modify.
Wireless Ethernet Menu
Parameter Setting

Definition

IP Assignment

Select the Static radio button to set a known IP address. You can also use
DHCP, but a static IP address is recommended.

IP Address

Enter the IP address assigned to the mobile robot you want to access.

Netmask

Enter the Netmask.

Gateway

Enter the Gateway address.

DNS1

Enter the DNS1 address or leave it as 0.0.0.0 to disable.

WiFi Network Settings
Selected Network

Displays the wireless network to which you are currently connected.
NOTE: Clicking on a network name in the list will automatically populate the encryption and authentication fields.

Network list

Displays a list of available WiFi networks.

Security Settings
NOTE: The fields listed below will change based on the security method you select, and could
include username, password, private key (download or create new)/key length, hostname, and certificate (choose an existing or upload new). If unsure about settings, ask your IT department for
assistance.
Encryption

Set this to match the encryption method that is used on your network.
Options are 64-bit or 128-bit WEP, TKIP/RC4, CCMP/AES, and
TKIP/CCMP/AES.

Authentication

Set to match your authentication type. Use OPEN (default) when using
no authentication or when using WEP. Select WPA-PSK for WPA Preshared key, PEAP-MSCHAPv2, or EAP-TLS.

Pre-Shared Key (PSK)

If using WPA/WPA2-PSK, enter the shared key in this field.

Key Type

Select from (click the radio button) Passphrase (8-63 ASCII only), or Raw
Hex (64 Hex only).

Mobile Robot Software SuiteUser's Guide 18484-001 Rev. B
Page 95

Chapter 5: Using the SetNetGo Software

Radio Settings
Mode

Set to Managed/STA to operate as a standard wireless client.

Radio Mode

Select the mode that your network uses: 802.11a, 802.11b, or 802.11g.
Select Auto to allow the robot to choose the most suitable channel (may
lead to longer roam times).

Channel Set

Set to match the channels that are used at your site or leave them all
selected (default) to allow the robot to find the most suitable channel.
Roam times will be faster if there are fewer channels selected.

802.11b/g Channels (2.4
GHz)

Use this list to select a specific WiFi channel (1 through 13) in the 2.4 GHz
range

802.11a Channels (5GHz)

Use this list to select a specific WiFi channel (36 through 165) in the 5
GHz range

Wireless Log Level

Determines the level of WiFi scanning detail in log files and debug info.
Default is Normal. Set to Verbose for debugging efforts. If set to Verbose,
log files cover a much shorter period of time. Recommend leaving at
Normal.

RSSI Roam Threshold

Determines the frequency of background scanning. Default is 50. If signal
strength is higher than the threshold, scanning happens at 10X the Background Scan Interval. If signal strength is below the threshold, scanning
occurs every Background Scan Interval seconds.

Background Scan Interval
(sec)

Works with the RSSI Roam Threshold to determine how frequently the
robot performs background scanning. Default is 3 seconds (recommend
leaving at default)

Watchdog

If enabled, automatically pings the Enterprise Manager (if used) or the
gateway IP address. If successive pings fail for Watchdog Timer seconds,
the robot automatically resets the wireless interface.

Watchdog Timer (sec)

If pings to the EM fail consecutively for Watchdog Timer seconds, the wireless Ethernet interface automatically resets and attempts to reestablish
communications.
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User LAN Ethernet Settings
This section allows you to set the IP address
User LAN Ethernet Settings
Parameter Setting

Definition

Interface Mode

Use to set up a wired accessory interface (e.g., Acuity or the touchscreen)
for the mobile robot. This mode allows you to connect network-based,
hardware accessories to the jack. Onboard accessories will be able to communicate with the software running on the robot’s core, and reach the
rest of the network via the robot’s wireless interface.

IP Address

Set the IP address for this interface. Select a subnet that does not conflict
with settings on the wireless Ethernet interface.

Netmask

Enter the Netmask.

DHCP Server for
Accessories

Disable or enable (default) a DHCP server for an accessory on the robot.
NOTE: You must enable this parameter for both Acuity and the touchscreen (for more information on these options, see the Mobile Robots LD Platform Peripherals Guide.).

DHCP IP Range

Allows you to set the DHCP IP range for the address automatically
assigned to the accessories.

Port Forwarding
If your robot’s payload has devices connected to the User LAN or Serial (RS-232) port, you can forward
those ports and make the payload’s device accessible via WiFi. Configure both RS-232 and Ethernet port
forwarding in SetNetGo in the Network tab.

RS-232 Port Forwarding
Controls forwarding serial data to a TCP port on the wireless and internal wired Ethernet networks. You can
link an internal serial device and route it to an external port at a defined baud rate. This is useful for RS232 devices connected to the robot’s core, an accessing them over WiFi.

Ethernet Forwarding
These settings forward a TCP port on the User LAN Ethernet interface to a port on the Wireless Ethernet
interface. The Internal IP Address is the IP address of the device connected to the robot core’s User LAN
connection. Internal and External port setting route the Ethernet connection through WiFi.

Utilities
These tools allow you to view the ARP table, and ping or run a trace route to a specific IP address.
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Software Tab
The SetNetGo software tab has settings for ARAM, and to Manage Installed Software:
ARAMCentral/ARAM

Figure 5-6: SetNetGo, Software tab - ARAM Settings
l

l

ARAMCentral Settings (main software on the EM) - configure ARAMCentral’s features (disabling
ASync logging, disabling ARCL, and disaster recovery settings.
ARAM Settings (main software on the robot) - configure ARAM’s features (disaster recovery settings).

Manage Installed Software
The settings in this section allow you to view current versions and status (for example, Enabled Running, or
Disabled Not Running) of software installed on the EM or robot, upload.
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Figure 5-7: SetNetGo, Software tab - Manage Installed Software
You can also use the functions on this tab to restart, disable, install and/or uninstall MobilePlanner software, the MARC microcontroller firmware, and (for robots configured with Acuity) the Acuity Support package.

Uploading, Backing up, and Restoring SetNetGo
Through MobilePlanner, you can upload (upgrade to) a new version of SetNetGo by simply choosing the
proper file.
Your upload options allow you to choose whether to upload a new version of SetNetGo into the Boot Image
A slot (which is the default image slot), or the Boot Image B slot (which you then have to make bootable),
or have versions in both slots.
In case of a software failure, you can also restore SetNetGo from a file maintained on the same (or a different) robot. You can only restore to a specific restore point on a robot (identified by its date/time), but
only from the last restore point, and only on that robot.
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Uploading a New SetNetGo OS
1. In the MobilePlanner tool bar, click the SetNetGo button, then click the System tab, then click the
Upload SetNetGo OS menu item (left-side pane).

Figure 5-8: SetNetGo, System tab
The Upload New SetNetGo OS page, Current Versions field, contains information about the current
installed version (with option to view its release notes), and which image is the current bootable
image (Image A in the example above).
2. To install a new SetNetGo version into the Boot Image A slot, click the Choose File button, and
browse to the location of the new image file. To upload a file, click the Upload File button.
NOTE: Clicking the Upload File button will upload a new SetNetGo package, which will overwrite
the existing image in the Boot Image A slot, and ask you to confirm before proceeding.
3. Click Open when done.
4. To install a new image file into the Boot Image B slot (and make it bootable), click the Choose File
button then, when you’ve chosen the file, click the Make Bootable button.
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Backing Up and Restoring SetNetGo
As with any system, it’s a good idea to back up your system files frequently, especially after making configuration changes. After backing up, you then have a file from which you can restore your system back to
working condition if a version becomes corrupted, if you swap robot cores, or add a new robot to your fleet
that’s identical to the others.

Creating a restore point
When you back up your system, the resulting file is date and time stamped with the current day and time
of backup, and becomes a specific restore point (overwriting the your previously saved restore point).
1. In SetNetGo, click the System tab, then click the Backup/Restore Options item.
2. In the Restore-Point field, click the Backup now button.
The following advisory dialog appears.

Figure 5-9: SetNetGo Create Restore Point dialog
3. Read the confirmation then, if sure you want to proceed, click Ok.

Reverting to a Restore Point
Reverting to a previously saved backup (restore point) takes your robot’s core back to its configuration as
of the date and time of the restore point file you select. During the restore, you will lose your connection to
MobilePlanner while the restore process resets your configurations.
1. In SetNetGo, click the System tab, then click the Backup/Restore Options item then, under the
Restore-Point heading, click the Restore Now button.
The following advisory dialog appears:
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Figure 5-10: SetNetGo Confirm Restore dialog
2. Read the confirmation then, if sure you want to proceed, click Ok.
The selected file overwrites the previous settings in the robot’s core, and the robot disconnects from
MobilePlanner. After the restore is complete, you can reconnect to the robot.

Restoring Settings from DebugInfo File
If you swap a robot’s core, and want to update the new core with all of the existing configuration info from
that robot onto the new core, you would use the Restore from same robot option. This process does not
overwrite other software on the core; you should verify those software versions.
NOTE: The Restore from same robot option does not include WiFi credentials (i.e., key, passphrase, certificates) or overwrite currently existing versions of other software (you should determine which versions to use).
If you have a fleet of one type of robot and are adding another robot of that type to your fleet, you would
use the Restore from different robot option. This feature gives a quick method of configuring the new
robot so it performs identically to the others.
NOTE: The Restore from different robot option does not change IP address or robot calibration data
(including robot identifier). After using this option, you will need to re-set your robot’s WiFi, IP address,
and identifier.
1. In SetNetGo, click the System tab, then click Backup/Restore Options from the list on the left.
2. Under the Restore Settings from DebugInfo File heading, click Choose File for either the Restore
from same robot option (see explanation above for example use case), or the Restore from different
robot option (see explanation above for example use case).
3. In the Open window, browse to and select the file you want to upload, then click Open.
4. Verify the correct file name appears next to the Choose File button, then click the Upload button.
The following advisory dialog appears:
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Figure 5-11: SetNetGo Confirm Upload dialog
5. Read the confirmation then, if sure you want to proceed, click Ok.
NOTE: Both of these processes creates a new restore point.

SetNetGo Recovery Mode
If your system experiences a serious software malfunction, you can reover
1. In SetNetGo, click the System tab, then click on the Backup/Restore Options item.
2. At the bottom of the window in the Recovery Mode field, click the Reboot and Enter Recovery
Mode button.

Figure 5-12: SetNetGo Recovery Mode
3. If you are certain you want to proceed, click Ok.
4. After the system reboots into recovery mode, power the robot down, and follow normal start-up procedures.
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Configuring ARAM
This section covers using the SetNetGo to set up and manage accounts, and to update the ARAM software.

Setting Up User Accounts
The SetNetGo Security tab allows you enable or disable access control for accessing robots and Enterprise
Manager (EM) via MobilePlanner. This allows you to restrict users from performing specific tasks.
1. From MobilePlanner, click the SetNetGo button, then click the Security tab.

Figure 5-13: SetNetGo interface - Security tab
By default, access control for connecting to robots and/or Enterprise Manager is disabled.
2. To enable access controls, click the Enabled radio button.
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Figure 5-14: SetNetGo interface - Security tab
3. Click Apply to enable the account feature.
4. To both enable and set or change the access password for the admin, MultiRobot, or user account,
click the associated Enabled radio button, then click Apply next to each modified username.
5. Continue to the next section to set up user accounts.

To set up and manage user accounts
1. In MobilePlanner, open SetNetGo.
2. Click on the Security tab to display the ARAM Accounts page.
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Figure 5-15: SetNetGo interface - Security tab
3. Follow the instructions in the table below to add, delete, or edit a user account.
To...
Add a user
account

Perform the following steps
1. Enter a username in the Add a new user field.
2. Enter a password in the first password field (on the same line as the username).
User names and passwords can have letters, numbers, special Unicode marks,
underscores, and periods (.). Do not use spaces and other special characters.
3. Re-enter the same password in the second password field.
4. Click Add, and verify the new user account appears under the Username
column.

Delete a
user
account

1. Select the checkbox next to the username you want to delete.
2. Click Apply to remove the user account from the list in the Username column.
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Permission Groups
For each user account, you can enable and disable access to various features in MobilePlanner. For
example, enabling FileUploading allows the user to upload and download files from MobilePlanner to the
robot.
1. To modify account permissions for each user (for example, admin user), click Modify Permissions
(to the left, and below the Apply button) to display the Change Account Permissions page.
The example below shows account permissions page for the admin user who, by default, has all permissions assigned. Other users have different sets. Use the side scroll bar to see all permissions.

Figure 5-16: Change Account Permissions page
2. Select the checkbox(es) next to the permission(s) you want to grant to the selected user account.
You can quickly assign all permissions by clicking Select All, or click Select None to clear all
assigned permissions.
3. Click Apply to set the selected account’s permissions, and return to the ARAM Accounts page.
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Updating the Enterprise Manager software
For an updated Mobile Robot Software Suite package, contact Omron Adept Technologies, Inc. (see How
Can I Get Help?).

To update the Mobile Software suite:
1. In MobilePlanner, click the SetNetGo button, then click the Software tab, then click Manage
Installed Software from the left side list.

Figure 5-17: SetNetGo interface - Software tab
2. Click the Choose File button to access the directory where the update file is located, and click
Open.
3. Confirm the correct file name is listed next to the Choose File button, then click Upload.
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Figure 5-18: Confirm Upload dialog
4. If you are certain you want to proceed, click Ok.

Figure 5-19: Software Upload Status
The robot will be unavailable as it goes through its restart sequence (a status window shows restart progress).
If the installation was successful, the new Mobile Software version appears in Manage Installed Software.

Viewing Software Packages
Clicking a package name expands the selection and shows the options for that package, which can include:
l

Release notes.

l

The option to enable or disable the package (if the package is executable).

l

Log files.

l

Uninstall (if available).

Restarting ARAM
ARAM automatically stops when any changes are made, but you can click the Restart button to force
ARAM to restart.
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With Mobile Robot Software Suite software, AIVs know where they are and drive from one place to another
by themselves–without a human operator. To do this, the mobile robot must have a prepared map of the
static features in its operating environment. MobilePlanner software makes creating maps for one, or an
entire fleet of robots fast and easy.
This section explains map files and how to work with them in the MobilePlanner software.

Loading an Existing Map File

112

Editing a Map File

114

Adding Forbidden Lines and Areas

115

Creating and Adding Goals and Docks

115

Advanced Lines and Areas

120

Inserting a Map File into an Existing Map File

120

Saving the Map on the Robot

124
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Loading an Existing Map File
There is no map to display when you first start up the MobilePlanner software. You must use MobilePlanner,
with ‘Map’ checked, and connect to a robot or EM to open a map file to edit. Or, you can open a map saved
locally on your computer or (when the Map button is checked) open a map that is currently in use on a specific robot. You can also open maps on the robot that are currently not in use.

Opening a Map saved on your PC
When you use the Map button to open and edit your map files, you can save them locally on your computer
until you are ready to upload them to the robot. Local map info is also written in the debug info files.
Selecting File > Open from the MobilePlanner main menu displays a dialog that lets you search for and
select a local map file to open.

Opening a Map stored on a Robot
You can also click the Map button to edit a map file that is already in use on a mobile robot, which is helpful
for making quick changes to the map or the robot's route.
1. In the MobilePlanner main menu, select File > Open on Robot to display a submenu that lets you
select a particular robot.
2. Either choose from the displayed robot IP addresses, or enter a new robot IP address to open a map
on the specified robot.
A dialog box appears in which you can choose between Configuration, Map, Scan, and SetNetGo files.

Figure 6-1: Open File on Robot dialog
3. Check Map File to choose a map file located on the robot.
You can use the Map File list and/or click the Advanced button to search for and select a map file to
open, as shown in the following figure:
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Figure 6-2: Open File on Robot, Advanced dialog
4. Select the map file you want to edit.
5. Click Open to load the map file into MobilePlanner.
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Editing a Map File
After you create the initial map of your environment, you can use MobilePlanner to edit the map. First, use
the Eraser tool (Draw pane) to remove map features that are temporary or moveable fixtures, such as
chairs or forklifts.

Using the Drawing Tools
When editing your map file, you use the drawing tools to select and erase objects in the map, add goals,
docks, forbidden lines and areas, as well as advanced lines and areas. The drawing tools are shown below.
NOTE: These drawing tools are inactive (grayed-out) if Show Robot is active. The Cut icon is inactive
until you select something.

Figure 6-3: MobilePlanner Draw tab
Selecting and Erasing Objects in the Map
Use the Select button to select and highlight objects on the map. Press and hold the left mouse button to
move the object around the map window. Click the right mouse button to display a pop-up menu that
allows you to edit, duplicate, align, copy and cut the object.
If there are overlapping objects on the screen, you can right-click on the overlapping map objects. A submenu lists all objects under the cursor so you can select the desired object.
Use the Eraser button to remove data points and lines from the map. Press and hold the left mouse button
to move the eraser over the data points or lines you want to remove. You can adjust the size of the eraser
by selecting the pull-down menu from the Eraser button. Choose an eraser size from 5 to 1000 mm.
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Cutting a Selection
Use the Cut icon (or Delete key) to remove any objects you have selected from the map.
Snapping Objects in Place
Use the Snap button to force rotate objects (goals, docks, lines, and areas) at multiples of 45 degree
angles. Deselect this button to draw or rotate at any angle.

Adding Forbidden Lines and Areas
You can place forbidden lines and areas on the map to prevent the mobile robot from crossing the line or
entering a specified area.
NOTE: Forcing the robot to cross a forbidden line or enter a forbidden area is a special circumstance discussed in Restricting Traffic on page 181.
1. With the map active, click the Draw tab, then click Forbidden Line or Forbidden Area.
2. Click on the map where you want to place the forbidden line or area. Be sure to add forbidden lines
or areas around the robot’s work space so it doesn’t try to navigate outside of its space.
3. Hold the left mouse button , then drag the mouse to the location you want the line or area to end.
4. Click the right mouse button to display a pop-up menu that allows you to edit, copy or cut the forbidden line or area.

Creating and Adding Goals and Docks
Goals are virtual destinations that the mobile robot drives to in its environment. Docks are locations to
which the robot drives to prepare to recharge. You need to add both of these features to the map for the
mobile robot to successfully navigate through the workspace.
You can quickly add a goal or dock to the map using the Item at Robot button (robot tool bar), which allows
you to add the object at the robot’s location. Once added, you can move goals and docks around by clicking
on them with the left mouse button, holding the button, and dragging them to the desired location. You
can also click on the heading line and drag it around, or put it in the middle to turn the heading off.
Types of Goals
You can choose from different types of goals:
l

l

l

Door Goal:Doors and virtual doors are spots at which the robot positions itself before entering or
leaving a doorway (see Using a Door Goal on page 117). They appear green on the map, and are
only available if the Doors parameter is enabled (click the Config button, then click the Robot
Operation tab, then select Map Features).
Goal: This is the default goal. The X and Y positions are automatically entered based on the location
you selected on the map. Click on the check box to enable a heading and enter a heading in degrees
(you can also do this on the map by dragging the mouse cursor - see Editing a Map File on page
114.). The goal heading specifies the orientation of the robot when it arrives at the goal.
Standby: Standby goals serve three purposes, each designed to help keep the robots out of the
way of traffic and regions of interest (goals, tools, etc.);
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o

Buffering: waiting at a standby goal for another robot to clear an occupied goal or sector.
See Standby-Buffering_goals

o

Parking: allows available robots to drive to a waiting area for assignment to another goal.
Other parking goals include Preferred Parking goals (also known as ‘park at pickup/dropoff’
goals). See Standby-Parking_goals

o

Multi-Robot Standby (MRS): (also referred to as Taxi Line) allows (and enforces)
sequenced, orderly queuing of multiple robots from the same start (standby) position to the
same goal. For more information, see Traffic Control Concepts on page 169

To create a goal/dock:
1. With the map active, click on Draw tab > Goal or Draw tab > Dock.
2. Click the mouse on the map where you want to locate the goal/dock. Then, while holding the left
mouse button, drag the mouse around the goal/dock to set its heading.
NOTE: Place a dock object where the robot should go to "look at" the dock, not where the dock
actually is. The dock object should be 1 to 1.5 meters in front of the dock, pointed at the dock.
See the figure on the next page.

Figure 6-4: Dock as imaged by robot

Edit Goal Dialog Box

Edit Dock Dialog Box
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3. In the appropriate dialog box (Edit Goal or Edit Dock), enter the name of the goal/dock you want to
add to the map, for example "Reception."
4. Enter a description of this goal or dock (optional).
5. Select the Type of goal or dock you are adding.
6. Enter the X and Y position to adjust the location.
7. Enter a heading value in degrees (required for docks, optional for goals).
8. Click OK to place the goal or dock on the map.
Using a Door Goal
The door goals appear as a green square on the map. They allow you to mark a spot for the robot to position itself before entering or after leaving a doorway. The following dialog box appears when setting up a
door goal.

Figure 6-5: MobilePlanner Edit Goal dialog
Click on a parameter to see its description near the bottom of the dialog box.
Goals Using High Accuracy Positioning System (HAPS)
If your robot has one or more optional HAPS sensors installed, you can create goals that require the robot
to approach and position itself closely.
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The most simple of these types of installations have a goal on the robot's map, a length of magnetic tape on
the floor (the track), and one marker. The robot's goal is to approach and proceed down the track, and stop
at the marker.
You can also install tracks with multiple locations at which the robot stops. Each stop needs one track, one
marker, one goal per marker, and an Engage task for each goal.
Standby Goals
Standby goals allow you to set up buffering when a robot’s destination is already occupied by another robot,
and send robots to a parking area after completing a queuing job.
NOTE: To use standby goals, you must enable them. Click the Config button, then click the Robot
Operation tab, then click Map Features (in the left pane), then click the checkbox for the Standby
parameter.
Using Standby-Parking Goals
It’s best to place standby-parking goals in areas out of the way of traffic and other areas of interest.
To place a Standby-Parking goal on your map, do the following:
1. With the map active, click on the Draw tab, then click on the Goals drop-down list.
2. Select the Standby goal type.
3. Place the goal(s) on the map, then change the PrimaryPurpose parameter to Parking.
4. Use at least as many Parking goals as robots.
Using Standby-Buffering Goals
If a robot is waiting for another robot to clear a goal, it will use one closest to its destination. Best practice,
then, is to place Standby-buffer goals near tools and areas of interest, in locations that will not block robots
leaving the goal.
To place a Standby-Buffering goal on your map, do the following:
1. With the map active, click on the Draw tab, then click on the Goals drop-down list.
2. Select the Standby goal type.
3. Place the goal(s) on the map, then change the PrimaryPurpose parameter to Buffering.
4. Use at least as many Buffering goals as the anticipated number of waiting robots.
Adding a goal at the robot’s current position
You can add a goal (generic, door goal, cart goal, or docking station) at the robot’s current position as follows:
1. With Show Robot active, click the drop-down arrow on the Item at Robot button (robot toolbar).
2. Select the type of goal you want to add.
If you select one of the default goals (e.g., docking station), information about that goal is pre-populated in the dialog box.
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3. If you selected a generic goal, fill in the name, description, and type then click OK. For a default
goal, click OK.
Accessing the Docking Parameters
Docking parameters define the robot's actions during the docking process. To access the Docking parameters, click the Config button, click the Robot Operation tab, then click Docking.

Figure 6-6: MobilePlanner Config - Robot Operations tab, Docking parameters

NOTE: MobilePlanner software defines the various docking parameters, which will not be repeated
here. However, there are some parameters under Config > Enterprise > Fleet Docking that control docking behaviors.
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Advanced Lines and Areas
MobilePlanner has tools for adding special, or advanced, features to your map that perform the following
functions:
l

l

Advanced Areas: these are areas in which you can add doors (and their swing sector), control
speed (Fast or Slow), direct the mobile robot to ignore laser or sonar inputs, limit the number of
robots operating in the space at one time (ManagedMotion), set the robots’ preferred travel direction, direct the robots to enter (or resist entering), to name a few.
Advanced Lines: these include lines to measure distances on the map (measuring stick), lines representing the robot’s preferred path (preferred line), lines the robot will resist crossing unless there
is no other way around an obstacle (resisted boundary), lines the robot will avoid if possible, and lines
that can act like forbidden lines (SwitchableForbiddenLine).

Adding an advanced area or line
Advanced lines, points, and areas include features like closed doors, measuring sticks, switchable forbidden
lines or areas, one-ways, and many more. You must enable some of these features under the Config button, Robot Operations tab, Map features (likewise, you can also disable those you do not want to use). See
Restricting Traffic on page 181.
1. With the map active, click the Draw tab, click the drop-down menu triangle for either Advanced
Lines or Advanced Areas, to display the available types, then select the type you want to add.
2. Click on the map where you want to start placing the line or area and, while holding the left mouse
button down, drag the mouse to where you want the line or area to end.
3. If an Edit Advanced Line/Area dialog box appears, enter the needed information, then click OK.
4. Click the right mouse button to display a pop-up menu that allows you to edit, copy and cut the forbidden line or area.

Inserting a Map File into an Existing Map File
The Insert a Map feature is helpful there have been small or medium changes to the robot's environment.
You do not need to rescan the entire workspace and recreate the map file. Using the Insert Map feature you
can scan the area of the environment that has changed, turn that into a map, and insert it into an existing
map.
In certain situations, you might want to insert only a subset of the region's data into the original map. For
more information, refer to Using the Advanced Insert Option on page 123.

Inserting a Map Into An Existing Map File
In MobilePlanner, select a map to insert into an existing map.
l

Select File > Insert Map from the main menu. A dialog box appears, which lets you search for and
select a local map file to open.
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The new map appears in the active map as a blue rectangle, and the Insert Map toolbar allows you to
manipulate the inserted map.

Figure 6-7: MobilePlanner, Insert Map Tools
Using the Insert Map Toolbar
Use the Insert Map Tools to position the inserted map into the existing map. After selecting a map section to insert, the toolbar automatically displays.

Figure 6-8: Insert Map toolbar

Mobile Robot Software SuiteUser's Guide 18484-001 Rev. B
Page 121

Chapter 6: Working with Map Files

The following table describes the buttons on the Insert Map Tools toolbar.
Insert Map Toolbar Button

Description

Insert

Works on intrinsic map data (points, lines, lights, etc.), and inserts the new
map into the existing map at the blue rectangle. The Advanced insert lets you
choose a subset of the previously mentioned data, and make other adjustments like inserting user-created map items (e.g., goals, docks, sectors,
etc.). See Using the Advanced Insert Option on page 123 for details.

Cancel

Cancels the insertion.

Region

Defines the region to insert (useful if the default insert region is too big), or to
have the newly inserted area properly overlap the old area. See Define the
Insert Region on page 122.

Reset

Erases all rectangles and restarts the region definition.

Lock

Locks the inserted map at its current position in the map. This can prevent
accidental changes when panning and zooming the map. Turn off the button
to enable more changes.

90° Left/90° Right

Rotates the inserted map 90° left or right. Use the Degrees field to set
degrees of rotation (as measured from the x-axis in the counter-clockwise direction).

Up/Down/Left/Right

Moves the inserted map up, down, left or right. Allows small adjustments to
the inserted map's position.

Help

Opens help information on the insertion process.

Position the Inserted Map
You can adjust the inserted map's location and orientation to position it correctly in the existing map as follows:
1. Hold down the left mouse button and drag the inserted map like any other object.
2. Use the Insert Map Tools’ Up, Down, Left, and Right buttons to make small adjustments to the
insert's position.
Adjustment size depends on the map's zoom. To make a very small adjustment, zoom in; zoom out for a larger adjustment.

Define the Insert Region
The shaded blue rectangle is where the inserted map will replace a portion of the existing map. By default,
all black data points on the blue background will be deleted (unless doing an advanced insert with ‘retain
overlapping,’ in which they will remain).
If the default insert region is too big, click the Insert Map Tools' Region button to define a new one. The
default region clears (and becomes gray) and the insert locks at its current position. Use the mouse to draw
a set of blue rectangles over the exact area to be replaced.
You should define the insert region after moving the map insert to the correct location.
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You can use Edit /Undo and Redo from the MobilePlanner main toolbar while defining the insert region
(Undo deletes the last added rectangle). To erase all rectangles and restart the whole process, press the
Insert Map Tools' Reset button.

Complete the Insertion
After correctly positioning the map insert and defining the insert region, click Insert to finish the insertion. It might take a few seconds for the original map to update. The process is complete when the shaded
blue area disappears and the Map Insert toolbar closes.
If the resulting map is not correct, then press Edit / Undo from the MobilePlanner main toolbar to restore
the map to its original state (which might take a few seconds).
NOTE: The insertion process is not automatically resumed; you must restart it.

Using the Advanced Insert Option
Occasionally, you might want to insert only a subset of the region's data into the existing map.
To use advanced options
1. In the Insert Map toolbar, left-click on the Insert button.
2. In the pulldown menu, select Advanced.

Figure 6-9: MobilePlanner, Advanced Insert options dialog
The dialog box has check boxes for each data type in the inserted map. To display non-data types,
click the Include user-created map items... checkbox (shown checked in the image above).
3. Click the checkbox for each data type that you want to insert. Note that any corresponding map
items are displayed in blue.
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4. To retain the original map data as well as the inserted data, check the Retain overlapping items .
. . checkbox.
5. Click the Insert button to complete the insertion and close the dialog box.

Saving the Map on the Robot
The scan file that came from your robot is saved on your local PC until you explicitly save it elsewhere.
To save the map on the robot, from the MobilePlanner menu, select:
File > Save on Robot
Select the .map file that you just edited, and click Save to save the map onto your robot.
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There are hundreds of parameters you can set in MobilePlanner to customize your robot's operation in
your environment. Other sections in this manual describe localization and mapping parameters; this section describes robot operation parameters.
This section covers the following topics:

Types of Configurations

126

Setting the Configuration Parameters

126

Saving and Importing the Configuration Parameters

128

Managing Files

129

Setting Up Data Logging

130
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Types of Configurations
MobilePlanner allows you to view, modify, save, and import various robot and enterprise, and debug configurations. You can set robot interface, operation, and physical configurations; enterprise configurations
(queuing tasks, enterprise features, and EM connection), and debug configurations that control the output
of debug log files.

General Configurations
General configurations include site-specific parameters for the robot interface (A/V config, connection
timeouts, language/location, speech synthesis, etc.), robot operation (bumper settings, docking behavior,
localization settings, path planning settings, task features, etc.), enterprise features and EM connection,
and debug information. General configurations are consistent across your site. If you have a fleet of robots,
the general configurations reside on the Enterprise Manager (EM). If you have a single robot, the general
configurations reside in the robot’s core.

Model and Calibration Configurations
These configurations relate to the robot itself. Model configurations include robot model-specific parameters
like movement maximums, battery information, Acuity camera configurations, the MARC configuration,
robot type, sensor type(s) and location(s), enterprise queuing tasks, etc. Calibration configurations include
general physical robot information and parameters. Model and calibration configurations always reside in
the robot’s core.

Setting the Configuration Parameters
Configuration parameters determine the available features on your robot. You can enable or disable them,
or assign them a value. You can set these parameters in MobilePlanner.
Using the tabs listed here, you can set parameters for everything from audio feeds, to docking, mapping,
localization, server setup, move settings, and many more.
There are five robot parameter tabs:
l

Robot Interface

l

Robot Operation

l

Robot Physical

l

Enterprise

l

Debug

Click on a tab, such as Robot Interface, to open and view its sections. Clicking on a section name displays
the individual parameters in that section. The following graphic shows the A/V Config section selected:
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Figure 7-1: Robot Interface Pane, A/V Config Parameters (not all shown), Parameter Icons
Most configuration windows in MobilePlanner software describe most of the parameters, and most are not
repeated here. Where needed, this user guide explains more complex parameters.
To set a parameter, select one of the tabs in MobilePlanner, then select a Section in that tab to see the
available parameters. You can then modify the specific parameter in the parameter table.
In this table’s Value column, you can enter a value (numeric or text), choose a value from a drop-down
selection, or click a checkbox. Most text fields have drop-down menus for selection.
Most parameters are not stand-alone and interact with other parameters. This user’s guide discusses various parameters. For example, if you are localizing the robot, you will find the parameters related to localization in the Using Laser Localization on page 197 section of this guide.
If you change any parameter settings, you have to click Save for those changes to take effect. When
MobilePlanner sends the update to the robot, a small spinning icon and “Update Pending” message appear
in the MobilePlanner status bar until the robot applies the changes (at its next idle period). You can also
stop the robot if you want the changes to be applied more quickly.
If the parameter has a restart icon then, after ARAM writes the change, it displays the following dialog indicating the configuration change:
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Figure 7-2: Robot Configuration Change

NOTE: ARAM automatically restarts automatically after some parameter changes.

Saving and Importing the Configuration Parameters
You can save parameter settings on either a robot or in the Enterprise Manager appliance:
1. In MobilePlanner, click the Config tab.
2. In MobilePlanner's main menu, select File > Save As, and give a file name and location for the file
on your local PC.
The Save <robot IP address> Configuration window opens.

Figure 7-3: Save Robot Configuration window
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3. In the Save <robot IP address> window, select the type of file you want to save (General, Robot
Model, or Calibration), then either accept all checked configurations (default), or de-select the individual configurations you don’t want.
4. Click Save when done.

Importing
You can import parameter settings from your PC to either a robot or the Enterprise Manager (EM) appliance:
1. Select MobilePlanner > Config.
2. From the main menu, select File > Import Config ..., then select the file from your local PC.
3. Click Save from the main toolbar.
NOTE: If ARAM restarts after saving a configuration, you will need to repeat the above steps until the
software no longer restarts.

Managing Files
MobilePlanner allows you to manage files associated with Mobile Robot Software Suite, including:
l

raw map-scans (.2d) files

l

maps (.map) files

l

log files

l

data files

Downloading/Uploading, and Saving Files
You can upload/download map, scan, log, and data files using File > Download/Upload from the top
bar. Select the robot you want to use, and then select the file or folder on the robot and the file or folder on
the PC that you want, and click either Upload or Download.
You can save map files using File > Save As... or, if the file already exists and you just want to save modifications, use File > Save (Save only affects the previously saved file).
You can also simply click the Save icon in the Toolbar.
You can import a configuration file onto the current robot using File > Import Config...
NOTE: Import Config applies to the config copy on MobilePlanner, and must be saved before it is on the
current robot.
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Setting Up Data Logging
The ARAM software can log all kinds of data into one or more files. These data logs allow you to manipulate
the data, using your own third-party data-processing software.
NOTE: Log Config is a Section of parameters you can set in MobilePlanner. These logs are not the same
as the files generated with data logging.
To set up data logging, click the Config tool, then click the Debug tab. When checked, the Show Expert+
Parameters checkbox displays advanced parameters that, by default, do not appear in the parameter list.

Figure 7-4: MobilePlanner Config, Debug tab (Show Expert+ Parameters checked)
The Debug tab has sections for configuring debug files and setting logging parameters.
NOTE: Each section has a description of what it does (though some parameters are not visible until you
check the "Show Expert + Parameters" checkbox).
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An AIV is unique in its ability to navigate freely and safely in a workspace, autonomously driving from one
goal to another to perform various tasks (the lowest-level work the robot performs). MobilePlanner gives
you the flexibility to manually program a complex series of tasks for the robot to perform at a goal before
moving on to the next goal and performing additional tasks.
Or, instead, you could create macros that include all of the tasks the robot is to perform at a given goal.
You can add tasks and goals to macros, then use the macros within a route or several routes. In other
words, macros are "reusable." You can also have individual tasks call a macro and execute the sub tasks
within the macro.
For example, you could create a macro in which the robot heads to Goal1, speaks a phrase and waits for a
human action, after which it then heads to Goal2, where it waits for a specified time, then heads to Goal3.
You can use the MobilePlanner software to add tasks, goals, and macros into your facility’s map, associate
tasks with routes and goals, and assemble series of goals, tasks, and macros into routes.
This chapter discusses the following topics:

Robot Tasks

132

Robot Jobs Overview

150

Using the Route Builder

152
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Robot Tasks
Tasks are activities that the mobile robot can perform, such as going to a goal or checking sensors. The
robot executes tasks at goals to accomplish useful work, such as enabling DIO and telling the robot to
move. These tasks are already available on the robot but need to be defined and associated with the map
that you are creating.
There are both instant and non-instant tasks available for the mobile robot to perform. Instant tasks allow
other tasks to be started before the instant task finishes. Non-instant tasks force the next task to wait until
they are completed.
You can add tasks to goals and routes. For details, see Using the Route Builder on page 152.

Assigning Tasks
You can assign tasks to a route or goal, or use them in macros. You can find available tasks under the Robot
Tasks tab in the Source Lists pane.See Setting Up Special Tasks on page 146.)
Many tasks need to have their corresponding ARAM parameters enabled to be available. For more information on enabling ARAM parameters, refer to Configuring ARAM on page 104. If you don't see a task displayed in the Source Lists pane, it might have previously been turned off. To display the task, enable (or reenable) the appropriate ARAM parameter.
Assigning tasks
1. In MobilePlanner, click the Map button, then click the Build tab.

Figure 8-1: The Route Builder
2. In the Source Lists pane, click Robot Tasks tab to view tasks that are available on the robot.
3. In the Editable Lists pane, click the Routes, Goals, Macros, or Special tab that corresponds to
where you want to assign the task.
4. To assign a task to a route, in the Source Lists, Robot Tasks tab:
a. Click on the task you want to assign, and drag it over to the desired route, goal, macro, or special item, or
b. Highlight the task, then highlight the desired goal, macro, special item or route, and click the
Add button (the arrow between the lists).
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NOTE: By default, tasks added to goals become part of the goal's "after" list (the robot
will perform the task after it arrives). The process also creates a "before" list for tasks the
robot will execute before driving to the goal (you can also move tasks to the “before” list).
If the task has associated parameters, the dialog box shown below (for a "sayInstant" task)
opens:

Figure 8-2: MobilePlanner task description dialog
5. Click inside the Value field to add and edit each parameter's values.
For more information on using individual tasks, refer to the task type (such as wait, driving, etc.) in
the Working with Macros, Tasks, and Route Builder Tools on page 131 section.

Using Instant and Non-Instant Tasks
In general, there can be only one sequence of non-instant tasks running at a time. Robots can start an
instant task without waiting for a previous instant task to finish. Non-instant tasks must finish before the
robot starts another task. In other words, both kinds of tasks are on the task list, but the non-instant
tasks must finish before the robot starts next task on the list. When an instant task runs, the task after it
can start right away, in other words, can happen without interrupting whatever else is happening.
Instant Tasks
Instant tasks allow the next task in the list to start while the instant task is still running, so the robot can
be running two tasks at once. The following are examples of instant tasks available in the software. The
complete list of instant tasks and descriptions are available directly in the software.
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Instant Task

Description

ARCLSendText

Sends a given string to the ARCL server.

customOutputOff

Turns a custom output OFF.

customOutputOn

Turns a custom output ON.

playBackgroundSound

Plays a random background sound (at 'Least Important') from a set of
prefixes and suffixes (wild cards do NOT work), waiting a length of time
between sounds, optionally resuming interrupted sounds, and with
the ability to stop playing in some different circumstances.
NOTE: to interrupt this sound, set the audio task Cancel less
important to True.

playInstant

Play a sound file and then continue while the sound plays.

popupSimple

Requests client applications to show a simple pop-up message (Client
applications include MobilePlanner).

sayInstant

Speaks text with a synthetic voice.

sendSoundInstant

Send sound from a robot sound file to all clients and continue immediately.

sendSpeechInstant

Send synthesized speech to all clients and continue immediately.

Non-Instant Tasks
Non-instant tasks run in their own time slot (the robot must wait for them to complete before starting the
next task in the list).
The following are examples of non-instant tasks . The complete list of non-instant tasks and descriptions
are available directly in the software.
Non-Instant Task

Description

arbitraryServerSend

Sends the given text to a specified server and port.

cartCapture

Task to capture a cart.

cartRelease

Task to release a captured cart.

customInputsCheckAll/Any/Each

Checks whether all/any/each specified custom inputs properly
triggered and executes a macro.

deltaHeading

Changes the heading by the specified relative amount.

followGuide

Used with HAPS - task to follow a magnetic guide strip on the
floor.

gotoRandom

Drives to a random goal (could be optionally constrained by a
matching name prefix).
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Non-Instant Task

Description

laserCheckBox

Waits for something to enter the rectangular area surrounding the robot. Macros may be triggered upon detection
or timeout.

laserCheckEmptyBox

Waits for the rectangular area surrounding the robot to be
empty. Macros can trigger upon detection or timeout.

macroRepeat

Repeats the specified macro a given number of times or until it
fails.

move

Moves forward by the specified distance, provided that no
obstacles are encountered.

play

Plays a sound file and waits until it finishes playing.

say

Speaks text with a synthetic voice and waits until it is finished.

sendSound

Sends sound from a robot sound file to all clients, continues
when done.

sendSpeech

Sends synthesized speech to all clients.

setHeading

Turns to a specified global orientation / heading.

triangleDriveTo

Drives to the triangle, stops a specified distance in front of it.
The 'Triangle Drive To' parameters in the Robot Configuration
apply to instances of this task.

triangleDriveToAdvanced

Drives to the triangle, stops a specified distance in front of it.
Allows override of all of normal triangle driving parameters.

trianglePointAway

Turns away from the most recent triangleDriveTo destination.

trianglePointAwayAdvanced

Turns away from the most recent triangleDriveToAdvanced
destination.

wait

Waits for the specified number of seconds. The wait may be
interrupted by an explicit continue command.

waitActive

Calls a macro, and optionally waits a given number of seconds
or until told to continue by command and control.

waitIndefinitely

Waits until commanded otherwise.

To verify if a task is instant or non-instant, right-click on the task and select Description. Or, go into ‘custom responses’ (Build tab > Editable Lists > Special tab) and click into one of them - the non-instant
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tasks are grayed out, instant tasks are active. Task classification appears in the "Class" category, as shown
in the following figure.

Figure 8-3: Task Class Category

Using a Wait Task
A wait task tells the mobile robot to wait a given number of seconds (or until told to continue by another
command), before continuing. A wait task is not an instant task.
1. Open the map you want to edit. For details, refer to Using MobilePlanner Software on page 53.
NOTE: Ensure that Show Robot is OFF, or you will not be able to proceed.
2. Click the Build tab.
3. Click the Robot Tasks tab in the Source Lists pane to view the tasks currently available on the
robot.
4. Add the Wait task to the route, goal, or macro where you want the mobile robot to pause before continuing its route. Refer to Assigning Tasks for details.
5. Enter the number of seconds you want the mobile robot to wait in the Value field of the seconds to
wait parameter, as shown below.
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Figure 8-4: Parameters for wait Task
6. Click OK to close the parameter dialog box and save your changes.

Using Driving Tasks
Driving tasks cause the robot to move about its environment, carrying out various tasks at each goal. Driving tasks can include the following:
Task

Task Description

move

Tells the robot to move the specified distance.

deltaHeading

Changes the robot's heading.

setHeading

Turns the robot toward a specified heading.

triangleDriveTo

Tells the robot to move the specified distance away from the triangle
(or dock) that is in front of the robot

trianglePointAway

Tells the robot to point away from the triangle (or dock) that it went to
last.

TriangleDriveTo Tasks
Triangle drive is a method for accurate mobile robot maneuvering, relative to a physical triangle placed in
its environment. Triangles can aid in precise positioning at docks, conveyors, and other areas where you
need the robot to accurately position itself.
TriangleDriveTo tasks require placing a physical triangle somewhere in the robot’s environment. The shape
should be unique to the immediate surroundings so the mobile robot can clearly image the shape, and not
confuse it with other surrounding features. If you need to build a custom triangle, use a shape and size similar to the triangle on the mobile robot’s dock, and position it so it sits 3 inches above and below the mobile
robot’s laser. In the image below, the mobile robot’s laser correctly images the triangle shape.
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Figure 8-5: Triangle Goal map representation
MobilePlanner can show the line extending out of the triangle’s vertex (enable ‘TriangleAdvancedNewApproach’ in MobilePlanner via Map > Robot Operation > Task Features and/or Triangle Drive To).
By default, the TriangleDriveTo and TriangleDriveToAdvanced tasks are enabled. You can find them by clicking the Config button, then selecting the Robot Operation tab, and clicking on Task Features and/or
Triangle Drive To. Once enabled, you can add them to goals or macros from the Build tab > Source Lists
> Robot Tasks.
Most configurable parameters have explanations in the help text at the bottom of the task window. The following table explains some of the more complex parameters:
Parameter

Description

MaxLateralDist

A value other than 0 varies the allowable distance between the mobile
robot’s center point and triangle’s vertex line.

MaxAngleMisalignment

A value other than 0 disallows triangles if the robot’s heading and triangle’s
vertex line differ by the set value (a good parameter is 10 degrees).

ApproachDistFromVertex

The distance between the triangle’s vertex and robot’s initial approach
point. Must be 250-500mm greater than the value for FinalDistanceFromVertex (below).

TriangleRotVelMax and Tri- Can improve accuracy (with cost in speed). Value of 100mm/s and 20
angleTransVelMax
degrees/s yield highest accuracy, but lowest speed.
FinalDistanceFromVertex

The robot’s final position after completing the triangle drive movement.The
robot’s front clearance must be large enough to allow the robot to move
this close to the triangle. Value is in mm.

AngleBetweenLines

Angle of the triangle’s vertex. Outward facing triangles (vertex points
towards robot) use positive values; inward triangles use negative values.

Step 1: Enable Movement Tasks
Not all available tasks are enabled by default. Before you can use those tasks, enable them in MobilePlanner
by clicking the Config button, then clicking the Robot Operation tab, then clicking Task Features. After
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clicking the checkboxes you want to enable, click Save to save your changes.
The following table lists some examples of the driving and movement parameters that you can enable.
NOTE: Some of the parameters in the following table require checking the Show Expert + checkbox.

ARAM Parameter

Description

Engage

When used with HAPS - calls a macro when the AIV arrives at
the goal, so the AIV can be sent on a series of tasks, such as a
followGuide task to go to a marker on the magnetic strip.

MovementParametersTempTasks

Enables tasks for temporarily changing movement parameters.

TriangleDriveTo

Enables the triangleDriveTo task.

Step 2: Assign Movement Tasks
Driving tasks are not instant, but the MovementParametersTempTasks are.
1. Open the map you want to edit.
2. Click the Build tab to display Source and Editable Lists panes.
3. In the Source Lists pane, click the Robot Tasks tab to view available tasks.
4. Add the driving task to the route or macro (for details, see Assigning Tasks on page 132.
5. Enter the parameter values for the assigned task.

Figure 8-6: Parameters for setHeading Task
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The following table shows examples of some of the task parameters and the tasks that use them.
Task Parameters

Associated
Task(s)

Parameter Definition

heading

(Integer) The number of degrees to turn the robot. Positive
values turn the robot left or counterclockwise. Negative values turn the robot right or clockwise. For deltaHeading, if the
absolute value exceeds 360, the robot makes at least one full
rotation.

deltaHeading,
setHeading

distance

(Integer) The distance (in mm) the robot should move from
the current position.

move,
move2,
moveProx

speed

(Integer) The speed (in mm/sec) the robot should move from
the current position.

move,
move2,
moveProx

6. Click OK to accept the parameter value and save any changes you made.

Using Speech and Sound Tasks
Speech and sound tasks control the robot's audio. As the mobile robot navigates the operating space, it can
(for example) play a sound file while driving, make a noise to alert anyone in the area that it is entering a
room, or announce what task it intends to perform next.
The speech and sound tasks combine instant and non-instant tasks, as shown in the following table.
Instant Tasks

Non-instant Tasks

l

playInstant

l

play

l

sayInstant

l

say

l

sendSoundInstant

l

sendSound

l

sendSpeechInstant

l

sendSpeech

l

playBackgroundSound

Instant tasks send audio to the mobile robot as it continues on its path. Non-instant tasks cause the robot
to wait until the speech or sound is done playing. For example, if you want the mobile robot to announce
that it is entering a room and then wait for a moment to allow people to get out of its way, use the say task
rather than the sayInstant task.
The robot speaks say tasks with a computerized voice. Play tasks play a sound file on the mobile robot.
Sound tasks encode a file from the robot and send it out to all MobilePlanner instances connected to that
robot.
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To use speech and sound tasks
NOTE: Speech and sound tasks are normally enabled by default.
1. Click the Config button, then click on the Robot Interface tab, then click on A/V Config, and
enable the Audio parameter (click the checkbox). For more details, see Configuring the Robot on
page 125.
2. For sound tasks, ensure the sound file is stored on the robot. You can use File
> Upload/Download.
3. Click the Map button, then click the Build tab.
NOTE: Ensure Show Robot is OFF, or you will not be able to draw or edit objects in the map
pane.
4. In the Source Lists pane, click the Robot Tasks tab to view tasks currently available on the robot.
5. Add the speech or sound task to the goal, route, or macro. For details, see Assigning Tasks on page
132.
6. Enter the parameter values for the assigned task. If using a speech task, enter the text for the
robot to speak in the Value field. If using a sound task, enter the name of the sound file in the
Value field. If needed, click the Browse button to search for the sound file.
7. Click OK to accept the parameter value and save any changes.
Using Sound Files with Tasks
Both the play and sound tasks use sound files. Play tasks play a file on a specified mobile robot. Sound
tasks encode a file from the robot and send it out to all the MobilePlanner instances connected to that
robot.
All sound files must be in AIFF WAVE (.wav files), .ogg files, or MP3 format.
Making the Mobile Robot Speak
Using MobilePlanner software, you can make the robot talk while it continues with other tasks.

Adjusting the Audio
You can use the MobilePlanner software to adjust the audio input and output (if turned ON), and adjust
both the software and robot audio using the audio slide bars.
1. Click the Map button from the main window to display the map window.
2. Click the Monitor icon to display the list of available items to monitor (see below).
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Figure 8-7: MobilePlanner Monitor drop-down menu
3. Click Audio to display the Audio dialog.

Figure 8-8: MobilePlanner Audio dialog box
4. Click on a slider bar to move it right (increase) or left (decrease) audio in or out.
5. If desired, you can enter a text string the robot will speak (when configured to do so).
6. Click OK when done.
Accessing and Adjusting the Audio Parameters
1. Click the Config tool, then click the Robot Interface tab.
2. Select A/V Config from the Sections column to display audio and video parameters.
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Figure 8-9: MobilePlanner A/V Configuration page

I/O Tasks
Digital Input/Output (I/O) provides an interface between the robot’s equipment and sensors and the payload which often requires power (I/O inputs and outputs can, for example, control conveyor rollers). For
example, if you have a robot with a conveyor payload aboard, you can use digital I/O to turn the rollers on
and off, check sensor inputs, and execute one or more macros based on a tote’s location (whether the tote
is on the robot’s conveyor or on the feed conveyor).
The mobile robot’s core provides 16 digital inputs and outputs, and has a User Interface connection for creating custom user interfaces with the robot’s E-Stop, ON, OFF, keyswitch, and brake release buttons.
With MobilePlanner, you can:
l

l

l

Configure core digital inputs and outputs, and give these inputs and outputs aliases which make it
easier to use them when needed.
Create custom I/O tasks that turn payload power on or off to activate automatically-toggled proximity sensors.
Detect single inputs and execute specific macros.
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Using I/O Tasks
Custom inputs and outputs are digital inputs, outputs, and peripheral power outputs. You make them custom by setting their input type to custom, and (optionally) giving them an alias.
1. Click the Config button, click the Robot Interface tab, then click Core Digital Inputs or Core
Digital Outputs in the Sections column.
2. Configure the devices, then click Save.
3. In MobilePlanner’s main menu, click File > Open to open the map you want to edit.
NOTE: Ensure that Show Robot is OFF, or you will not be able to proceed.
4. Click the Map button, then click the Build tab.
5. In the Source Lists pane, click the Robot Tasks tab to view the tasks currently available on the
robot.
6. Add the task to the route, goal, or macro (see Assigning Tasks for details).

Digital Inputs
To configure the digital inputs, click the Config button, then click the Robot Interface tab.
Tasks: customInputsCheckAll and customInputsCheckAllInstant
These tasks check whether all specified custom inputs trigger and properly execute a macro.
Parameters
timeout

Description
Duration (in sec) to check the custom inputs.

timeoutMacro Macro to invoke if no inputs are triggered before the timeout.
triggerMacro

Macro to invoke if all inputs are triggered before the timeout.

input<n>
n = 1 to 8

Names of the custom inputs to check. Prefix the names with '!' to check the inverted value.

Tasks: customInputsCheckAny and customInputsCheckAnyInstant
These tasks check whether any of the specified custom inputs trigger and properly execute a macro.
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Parameters
timeout

Description
Duration (in sec) to check the custom inputs.

timeoutMacro Macro to invoke if no inputs are triggered before the timeout.
triggerMacro

Macro to invoke if any of the inputs are triggered before the timeout.

input<n>
n = 1 to 8

Names of the custom inputs to check. Prefix the names with '!' to check the inverted value.

Tasks: customInputsCheckEach and customInputsCheckEachInstant
These tasks check the custom inputs and executes a particular macro for each triggered input (on only if
‘tasksForBetterCustomIO’ is ON).
Parameters

Description

timeout

Duration (in sec) to check the custom inputs.

timeoutMacro

Macro to invoke if no inputs are triggered before the timeout.

input <n>
n = 1 to 8

Names of the custom inputs to check. Prefix the names with '!' to check the
inverted value.

input <n> macro
n = 1 to 8

Macro to invoke if input <n> is triggered before the timeout.

Digital Outputs
To configure the digital outputs in MobilePlanner software, click the Config button, then click the Robot
Interface tab.
Task: customOutputOff
This task turns off the specified custom output.
Parameters
output

Description
Name of the custom output to turn off.

Task: customOutputOn
This task turns on the specified custom output.
Parameters
output

Description
Name of the custom output to turn on.
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Setting Up Special Tasks
You can set up and use tasks for the mobile robot to perform in certain situations, such when docking or at
every goal. You can also make the robot say a phrase when an specific event occurs (e.g., when path planning is failing, replanning has happened, or the robot failed at a goal, etc.). These Special tasks allow you to
define custom responses to events that the robot might encounter.
Special tasks can include:
l

Performing a task before or after every goal.

l

Performing a task at a dock.

l

Custom responses.

l

Queuing Manager tasks.

NOTE: Special events don't have to be unusual. Going to a Goal or Point can be a special event.
To customize robot operation:
1. In MobilePlanner, click the Map button, then click the Build tab.
2. In the Editable Lists pane, click on the Special tab.
Since you cannot assign a goal to a Special task, the Goals tab is grayed out. Also, selecting one of
the special events in the Special tab only enables instant tasks. All custom responses have to be
instant, but other lists in this tab can allow non-instant tasks.

Figure 8-10: Build tab lists - details
3. In the Source Lists pane, highlight a task from the Robot Tasks tab and drag it to the desired special event in the Special tab.
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NOTE: Most custom responses (e.g., Dock responses) have to be instant; all others can be noninstant.
Custom Responses
You can customize the mobile robot's operation using the Custom Responses found in the Special tab. The
predefined conditions or events that trigger a custom response include:
NOTE: The following list is not an exhaustive list. The Custom Responses defined for a particular mobile
robot depend on the parameters that you enabled or disabled. For configuration details, see Setting the
Configuration Parameters on page 126.
l

Fault responses.

l

Localization.

l

Path Planning (Failed, replanning).

l

‘sayInstant’ tasks (such as ‘excuse me’).

l

Bumping into something (has four sub-events, based on what the robot is doing when the bump
occurs).

l

Map Creation (has two sub-events, for starting and stopping a scan).

l

Patrolling a route (has four sub-events).

Using custom responses, you can make the mobile robot talk when it encounters one of these events, and
tell the people around the mobile robot what to expect.
All custom responses must contain instant tasks, such as sayInstant. Although the conditions that trigger
a custom response are predefined for the robot, you can customize the robot's operation by adding one or
more instant tasks to these events. For example, if the mobile robot bumps something in front of it, the
robot can respond appropriately (for example, the robot could speak a phrase when it bumps into something).
Events automatically trigger the custom responses that make the robot respond to its environment.
If there is no task associated with a specific Custom Response, the robot won't do anything special when
that condition occurs.
Performing a Task Before/After Every Goal
Special tasks can include instant and non-instant tasks the robot performs before the robot departs for a
goal or after it reaches any goal.
Drag instant tasks from the Source Lists pane to either event in the Special tab in the Editable Lists pane.
NOTE: You can override these tasks for specific goals within specific routes by un-checking the
before/after this goal checkbox.
Performing a Task at a Dock
Special tasks can include instant tasks the robot performs when docking. The robot already has a set of
defined docking events, including:
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l

Forced dock

l

Idle dock

l

Requested dock

l

Driving to dock

l

Driving into dock/docked

l

Dock now unforced

l

Dock now forced

l

Undocking/undocked

You can add instant tasks to these docking events (e.g., have the robot announce it is going to dock
because it is ‘idle.’). Drag instant tasks from the Source Lists pane to the appropriate event in the Special
tab in the Editable Lists pane.
Queuing Manager List
Robots can perform a variety of special tasks when they reach goals. For example, you can use the
JobTypeCheck task to specify different macros depending on whether a goal is pickup, dropoff, or neither.
Other examples of special tasks include:
l

Before/After Pickup

l

Before/After Dropoff

Drag instant tasks from Source Lists to a queue-related event in the Special (Editable Lists pane).
Editing a Special Task in the Editable Lists pane
1. Right-click on the task you want to edit.
2. In the pop-up window, click Edit.
If the task has associated parameters, the following dialog box opens:

Figure 8-11: MobilePlanner parameter description dialog

Mobile Robot Software SuiteUser's Guide 18484-001 Rev. B
Page 148

Robot Tasks

Click in the Value field to add and edit the parameter’s value . Click on a parameter to see its description.
3. Click OK when done.
Copying a Special Task from the Editable Lists pane
1. Right-click on the task you want to copy.
2. In the pop-up window, clicking Duplicate creates a copy of the task.
3. Drag the copied task anywhere within the current tab.
Deleting a Special Task from the Editable Lists pane
1. Right-click on the task you want to delete.
2. In the pop-up window, click Cut (or press the Delete key) to remove the selected task.

Editing a Task
To edit a task, from the Editable Lists pane:
1. Right-click on the task you want to edit.
2. In the pop-up window, click Edit.
3. Click inside the Value field to edit the value for each parameter.
NOTE: You can reorder or move tasks to another goal/macro/route by dragging them there.
Copying a Task
To copy a task, from the Editable Lists pane:
1. Right-click on the task you want to copy.
2. In the pop-up window, clicking Duplicate adds a copy of the task.
3. Drag the copied task to any position within the current tab.
Deleting a Task
To delete a task, from the Editable Lists pane:
1. Right-click on the task you want to delete (or click, the press the Delete key).
2. In the pop-up window, clicking Cut removes the selected task.
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Robot Jobs Overview
Jobs are basic activities for the robot(s) to execute. Advanced Robotics Command Language (ARCL) sends
job requests to the Enterprise Manager (EM) for assignment to a robot.
NOTE: Jobs are the recommended method for commanding the robot or fleet of robots.
Jobs typically have one or two job segments (if queueMulti is enabled). All segments are classified either as
PICKUP or DROPOFF.
l

l

PICKUP: A PICKUP job request tells the EM that any available, appropriate robot can be assigned a
PICKUP task.
DROPOFF: A DROPOFF job request tells the EM that only a specific robot can be assigned a
DROPOFF task.

Once the EM receives the job request from ARCL, it assigns a job ID and unique job segment ID (or, you can
optionally assign a job ID).
Job Priorities
MobilePlanner prioritizes submitted job requests either by Non-First-In-First-Out (Non-FIFO) or First-InFirst-Out (FIFO) priority. The requestor can specify the job priority, or jobs can use the default value for
queuePickup, queuePickupDropoff, and queueDropoff commands. You can enable this in Config > Enterprise tab > Enterprise Features, EnterpriseQueuingConsumptionMethod.
l

l

Non-FIFO: Non-FIFO executes the highest priority jobs first, followed by lower priority jobs. Its goal
is to minimize the robots’ driving distance.
FIFO: In FIFO, the system prioritizes jobs by which was submitted first, second, and so forth.

The default PICKUP priority is 10, and the default DROPOFF priority is 20. You can expedite a job by raising
the pickup priority, while keeping the dropoff priority the same. For example,
l

queuePickupDropoff goal1 goal2 10 20

l

queuePickupDropoff goal3 goal 4 10 20

l

queuePickupDropoff goal5 goal6 11 20

If you queued all of the above jobs at the same time, the third job’s higher priority means the robot will
execute the third job before jobs 1 and 2. Otherwise, job1 or job2 will start.
Job vs Job Segment
All submitted jobs carry a specific JobID (also referred to as the “job). Each part of a job is a ‘job segment,’
even if the job has multiple parts to it (for example, a Pickup-Dropoff sequence).
Custom Job ID
MobilePlanner uses the jobID is to track the status of a request, and a job ID must be unique among active
jobs. Active jobs can share a jobID with previously completed or cancelled jobID still in the system. You can
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use a custom job ID that matches some other information in your automation system when submitting
the pickup or pickupDropoff request.
Basic Job Commands
The following are some basic example job commands:
l

l

l

“queuePickup goal1”: submits a request to send any available robot to “goal1.”
“queuePickupDropoff goal1 goal2”: requests that any available robot first drives to “goal1,” then,
once completed, drives to “goal2.”
“queueCancel jobid JOB7”: immediately cancels job7, regardless of whether a robot is performing
that job.

Basic Job-Supporting ARCL Commands
The following ARCL commands support job queuing:
NOTE: In ARCL command syntax, commands are not case sensitive, values in angle brackets < > are
required, and values in braces [ ] are optional. Refer to the Advanced Robotics Command Language
Reference Guide, and Advanced Robotics Command Language Enterprise Manager Integration Guide
for more information.
l

queuepickup <goal_name> [priority] [job_id]

l

queuepickupdropoff <PICKUPgoal_name><DROPOFFgoal_name> [PICKUPpriority] [job_id]

l

queuecancel <canceltype> <cancelvalue> [echo_string] [reason]

l

queuedropoff <goal_name> [priority] [job_id]

l

queuequery <querytype> <queryvalue> [echo_string]

l

queueshow [echo_string]

Job Example
The following is an example of a job with two simultaneous connections.
l

Connection 1 submits a job “queuePickup goal1 goal2.”

l

The EM assigns a job ID of JOB7 and job segment IDs of PICKUP7 and DROPOFF8.

l

Connection 2 sees the broadcast messages about the jobs entering the “Pending” state, but does
not see the command response.
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Using the Route Builder
With MobilePlanner Route Builder, you can set up tasks for the robot to perform and goals for it to drive to.
You can also customize robot operation and build routes for the robot to follow. All of this information is
embedded into the map file. Once you download the map file to the mobile robot, you can use MobilePlanner to drive the robot in its operating environment, and perform tasks.
NOTE: Jobs are preferred over routes in industrial environments.
Use the Route Builder to set up the following:
l

l

l

l

l

Tasks: Activities that the mobile robot can perform, such as going to a goal or checking sensors.
Tasks give the robot useful work to perform. These tasks are already available on the robot, but need
to be defined and associated with the map that you are creating.
Goals: Virtual destinations that the robot drives to in its environment. These goals are defined in
the map, and represent real-world places in the operating environment.
Macros: Containers for sequences of tasks and goals. Once these macros are created, you can
select the macro, rather than all of the individual tasks and goals, for the robot to perform. You only
have to define a macro once, but can use it as many times as necessary. You can also use macro
templates, which are special macros that can accept simple parameters. You define parameter types
when you create a new macro template, and specify the values when you use the template in
another macro, route, etc.
Custom responses: Actions such as making the robot talk (e.g., when its path is blocked, fails the
path, or does global replanning, etc.), performing a particular or sequence of tasks at all goals, when
docking, or when a special event (such as a bump or E-Stop) occurs.
Routes: A "to do" list or a series of tasks, goals, or macros for the mobile robot to follow.

The Route Builder Interface
MobilePlanner’s Route Builder allows you to set up macros, tasks, goals, and routes for the mobile robot to
follow.
1. Click the Map button, then click the Build tab.
The Route Builder (Build tab) appears in the window, as shown in the following figure.
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Figure 8-12: The MobilePlanner Map Workspace with the Route Builder Open
The Route Builder Elements
The Route Builder has two panes: Source Lists and Editable Lists. Each section uses tabs to switch
between the different available options.

Figure 8-13: The Route Builder Elements
The Source Lists pane lists available robot tasks, goals, and macros you can add to new routes, goals, macros, and special tasks.
The Editable Lists pane displays routes, goals, macros, or special tasks. The tabs allow you to switch
between the different types of objects that you can build.
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You can drag Source Lists objects into any of the Editable Lists routes (or macros) you are working on, or
use the arrow icon between the lists.
Source Lists: Robot Tasks, Goals, and Macros Tabs
The tabs in the Source Lists pane display the tasks, goals, and macros you can use in building new routes,
adding tasks to goals, and building macros and special tasks.
NOTE: Some of the Robot Tasks listed below need to be specifically enabled by clicking the Config button, then clicking the Robot Operation tab, and the Task Features section.
l

l

l

Robot Tasks: Lists the tasks available for creating new objects (routes, macros, etc.) on the map.
Tasks are robot and accessory-related operations, such as moving the robot, talking, or playing a
sound. These tasks are already available on the mobile robot, however you must include them in
one of the Editable List items for the robot to know when and where to perform them. For more
information on using tasks refer to Robot Tasks on page 132.
Goals: Lists the goals available for creating routes or macros. Goals are locations on the map that
are destinations for the mobile robot. For more information on using goals, see Setting Up Goals.
Macros: Lists available macros which you can add to tasks or goals. Macros are reusable containers
for multiple tasks. For more information refer to Creating Macros on page 156.

For detailed information about a task, goal, or macro, right-click on the item and select Description.

Figure 8-14: Accessing the Task Description
Click on the task parameter to read a brief description of the selected task. The figure below shows an arbitraryServerSend task. To set up different tasks and their parameters, refer to the specific task (Using Audio
Tasks, for example).
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Figure 8-15: arbitraryServerSend Task Description
Editable Lists: Routes, Goals, Macros, and Special Tabs
l

l

l

l

Routes: Lists created routes, and allows you to build new routes. For details, see Creating Routes
on page 163.
Goals: Lists created goals or destinations. You can add tasks for the robot to perform at the specified goal. For more information on using goals, refer to Setting Up Goals.
Macros: Lists created and defined macros, and allows you to create new macros. Refer to Creating
Macros on page 156 for more information.
Special: Used to customize robot operation. Custom tasks allow you to have the robot perform certain activities at every goal or at a dock. They also allow you to program the robot to take special
actions when specific events happen. For more information, refer to Setting Up Special Tasks on
page 146.

Macros
Macros are reusable sequences of tasks which have their parameters set when you add them to the
macro. So every time you use a macro, the tasks inside use the same settings. Macros are extremely
effective if you have groups of tasks that you need to repeat in multiple places.
For example, you might have a robot delivering parts to various places. At each of the multiple delivery locations, it needs to navigate to each, pause, announce its arrival, wait for the part recipient to retrieve the
part, then move on to the next delivery site. Instead of manually programming each of these tasks at each
goal, you can use macros to replicate this same functionality across multiple goals.
You can create macros in Editable Lists (in the Build pane) by clicking the New button. Then, drag the
appropriate tasks from the Robot Tasks list (under Source Lists) into the macro in the desired point. After
adding the tasks to the macro, you can reorder and reconfigure them as needed.

Macro Templates
Macro templates are simple, text-only features for adding simple parameters to macros. Allowed parameters for macro templates are named $1 to $9. They do not allow variables or expressions.
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To create a macro template, click the Map button, Build tab, then use the New dropdown menu directly
below the Editable Lists pane and select Macro Template.
For details, see Macro Templates on page 158.

Creating Macros
Macros are containers that hold a series of tasks, goals, and other macros. After you create a macro, you
can reuse it as many times as needed. Macros can hold goals and use tasks with conditionals, and they can
be embedded within macros and other tasks. As a result, macros are very versatile.
To create a macro:
1. Click the Map button, then click on the Build tab.
The Source and Editable Lists appear on the left side of the map.
2. Under Editable Lists, click the Macros tab.

Figure 8-16: MobilePlanner Build tools - Macros tab
3. Click on the New button an the bottom of the Editable Lists pane.
This adds a new macro to the Macros tab which, by default, has the name "Macro1." This new macro
name increments by 1 with each new added macro. See Renaming the Macro on page 158 for directions on changing the macro name.
4. Highlight a task from the Robot Tasks list and either drag it to the desired macro in the Macros tab or
click the Add arrow (between the two panes).
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The new macro expands with each added task, as shown below.

Figure 8-17: Macro detail
5. Click the Goals tab to access the goals available to add to the macro, then drag the desired goal into
the new macro you are creating. You can also pick a goal from the displayed map to add to the
macro (see Picking a Goal From the Map on page 158 for details).
6. Click the Macros tab to access existing macros. You can then drag an existing macro into the new
macro.
The macro below shows an example of tasks, a goal, and a macro named "Greeting" added to the new Macro1 macro.

Figure 8-18: Macro details
Using the Add Button
In addition to dragging a task, you can use the arrow (Add) button to add a task to the macro.
1. Click on the Macros tab in the Editable Lists pane.
2. Highlight the macro to which you want to add a task, goal, or macro.
3. Click on the Robot Tasks, Goals, or Macros tab from the Source Lists pane.
4. Select the task, goal or macro you want to add to the new macro.
5. Click the Add button to add the task, goal, or macro.
If parameters are associated with the task, a dialog box appears that allows you to adjust parameters appropriately.
For specific parameter information, refer to the task type (such as a wait task) for more information.
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Picking a Goal From the Map
You can add goals to macros by clicking the goal on the map. This allows you to add multiple goals within
the same vicinity.
1. Be sure that the goals you want to add to the macro are visible in the map window. For details, see
Using MobilePlanner Software on page 53.
2. From the Editable Lists pane, select the Macros tab, then select the appropriate place in the desired
macro to add the goal.
3. Click the Pick Goal button at the bottom of the pane (next to the New button).
4. In the map, click on the goal to add the goal to the macro (you can select multiple goals without having to click on the Pick Goal button each time).
To move the goal within the macro:
1. Click on the goal name in the macro list.
2. Drag it to the position you want the goal to be.
Renaming the Macro
1. Right-click on the macro you want to rename.
2. In the pop-up window, click Rename to change the macro name to editable text.
3. Type in the new name for the macro.
Copying a Macro
1. Right-click on the macro you want to copy.
2. In the pop-up, click Duplicate with the left mouse button.
A copy of the macro appears in the Macros tab.
Deleting a Macro
1. Click the macro then hit the Delete key, or
2. Right-click on the macro you want to delete then, in the pop-up window, click Cut with the left
mouse button to delete the selected macro.

Macro Templates
Using macro templates, you can easily add a variable to a set of tasks. This makes reusing macros or task
sets with slight differences (depending on the goal or application) fast and easy. For example, you can create macro templates for changing wait times, status to wait with, line to log, activating a different IO, etc.
NOTE: If you are using a map created under an older version of MobilePlanner, you will need to update
it. After updating, it will not be backwards compatible with older MobilePlanner versions.
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To update your map
1. In MobilePlanner’s main menu, click on Tools > Update Map Features.

Figure 8-19: Update Map dialog
2. Read the notes and information in the pop-up window, then click Continue to update the map.
3. After updating the map, you will need to save and reload the map.
Macro Templates and Grouped Items will then be available for use, and there will also be a few
default group items like door goals, docks, and cart transporters.

Creating a new macro template
NOTE: To use macro templates, you must have (at minimum) MobilePlanner 4.4.0 and ARAM 4.8.
1. In the Build pane, Editable Lists, click on the Macros tab, then click the New button drop-down
arrow, and select Macro Template.

Figure 8-20: New Macro Template dialog
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2. Enter a name and description for the template, and set variable number(s), type(s), and descriptions.
Types can be Text, Integer, Double, or Boolean.
Type

Allowed Value

Default

Text (or
String)

Any letters or numbers

Zero

Integer

Number without decimal

Zero

Double

Number either with or without a decimal

Zero

Boolean

True or False

False

3. Enter up to nine parameters in the macro template.
Parameter names use ‘$1’ to ‘$9.’ You can enter a text description of each ‘$#’ variable in the
Description field.
4. Add tasks to the template.
Add ‘$#’ to call a variable (‘#’ is limited to previously defined parameters).
5. To add the new macro template, drag and drop from the Source list into the Editable list.

Custom Groups
Using custom groups, you can define a reusable group of complex map objects, such as goals, sectors, etc.
This allows you to place repeatable tasks (e.g., cart goals) on your map quickly and consistently, which
helps to speed up application building time. Custom groups can interface with macro templates. Once created, you can add grouped items from the build tab as you would an advanced area.
Notes on using custom groups:
l

l

You cannot edit or delete custom group definitions.
You cannot modify originally selected map items, and they do not automatically become members of
a new group instance.

l

You cannot nest groups. The software ignores groups already in the original selection list.

l

You cannot ungroup groups (i.e., you cannot convert them to top-level objects).

Custom groups also contain all tasks and macros (which you can individually edit) from every goal and sector that you included in the group.

Creating a new custom group
NOTE: Update the map format, then create a backup of your map before creating the custom group.
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1. Ensure Show Robot is OFF.
2. Highlight all map objects (goals, sectors, etc.) you want to include in the group.
3. Right-click on the map location that is the group’s anchor point (its origin), and select Advanced >
Create Custom Group.

Figure 8-21: Create Custom Group explanation dialog
4. Read the information in the pop-up, then click Continue to create the custom group.

Figure 8-22: Create Custom Group dialog
5. Enter the custom group’s name and description.
6. Click OK.
The new group will appear under the Custom Groups button drop-down menu in the Draw pane.
To edit a single item in the group, right-click and select the component you want to edit.
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Adding a grouped item
After you create a grouped item, you can add it to the map as follows:
1. Verify that Show Robot is OFF.
2. In the Draw tab, click the Custom Groups drop-down arrow, and select a grouped item.
3. Move the cursor (appears as a ‘pencil’) to the grouped item’s intended location, and click to place the
item on the map.

Figure 8-23: Add Grouped Item dialog
4. Click OK to add the grouped item.

Adding New Goals to the Robot’s Current Location
MobilePlanner software's robot monitor allows you to interact with the robot (for example, you can move
the robot to a new location or goal, then add another new goal to where the robot is located).
1. Drive the robot to the location where you want to add a goal or task (for details, see Driving the
Robot for the First Time).
2. When the robot is at the desired position, click the Item at Robot button (in the toolbar), and select
Create Goal.
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Figure 8-24: Edit Goal dialog
3. In the Edit Goal dialog, enter the information, then click OK.

Creating Routes
A route is essentially a "to do" list for the mobile robot. It is a series of ordered tasks, goals, and macros for
the robot to complete. Tasks are robot and accessory-related operations, such as talking or playing a
sound, reading inputs, and triggering outputs.
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Figure 8-25: MobilePlanner interface - Build tab lists
Building Your Route
To build routes for the robot, simply drag a task, goal, or macro from the Source Lists to the Editable Lists
> Routes tab, as described in the following procedure.
To build a new route:
1. Click the Build tab to display the Route Builder.
2. Click on the Routes tab in the Editable Lists pane.
3. Click on the New button on the bottom of the Editable Lists pane to add a new route to the Routes
tab.
The default name for this new route is "Route1," and each new route name increments by 1. See
Renaming the Route on page 166 for details on renaming a route.
4. Highlight a task from the Robot Tasks tab (in the Source List pane) and drag it to the desired route in
the Routes tab.
The new route expands with each added task, as shown below.
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Figure 8-26: Route detail
5. Click the Goals tab to access the goals available to add to the route, then drag the desired goal into
the new route you are building. You can also pick a goal from the displayed map to add to the route,
see Picking a Goal From the Map on page 166 for details.
6. Click the Macros tab to access the macros available to add to the route, then drag the desired
macro into the new route you are building.
The route below shows an example of tasks, goals and macros added to the new Example route.

Figure 8-27: Route details
Using the Add Button
In addition to dragging a task, goal or macro into your route, you can use the arrow button to add the task
to the route.
1. Click on the Routes tab in the Editable Lists pane.
2. Highlight the route to which you want to add a task, goal or macro.
3. Click on the Robot Tasks, Goals or Macros tab from the Source Lists pane.
4. Select the task, goal or macro you want to add to the route.
5. Click the Add button to add the task, goal or macro to the route.
If parameters are associated with the task, a dialog box appears in which you can adjust parameters
appropriately. For specific parameter information, refer to the task type (such as a wait task) for
more information.
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Picking a Goal From the Map
You can add goals to routes simply by clicking the goal on the map. This allows you to easily add multiple
goals to the route that are in the same vicinity on the map.
1. Be sure that the goals you want to add to the route are visible in the map window (see Using
MobilePlanner Software on page 53 for details on using the workspace).
2. From the Editable Lists pane, select the Routes tab.
3. Click on the Pick Goal button at the bottom of the pane.
4. Highlight the route in which you want to add the goal.
5. In the map, click on the goal you want to add to the route.
This adds the goal to the route. You can select multiple goals without having to click on the Pick Goal
button each time.
To move the goal within the route:
1. Click on the goal name in the route list.
2. Drag it to the desired position.
Renaming the Route
1. Right-click on the route you want to rename.
2. In the pop-up window, select Rename to change the highlighted route to editable text.
3. Type in the new name for the route.
Copying a Route
1. Right-click on the route you want to copy.
2. In the pop-up window, select Duplicate with the left mouse button.
A copy of the route is displayed in the Routes tab.
Deleting a Route
1. Right-click on the route you want to delete.
2. In the pop-up window, select Cut (or use the Delete key) with the left mouse button to delete the
selected route.
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This section describes managing traffic flow in your operating environment. Whether you are using a
single mobile robot or a fleet of mobile robots, defining how the robot moves within the space allows you to
better control the robot's behavior. As a result, you can prevent the robot from running into problems,
allowing it to complete the tasks assigned to it more efficiently.
In MobilePlanner, you can add objects and areas to the map and manage how the robot moves through its
environment. You can add areas that direct or restrict traffic, and that control speed and docking behavior.

Understanding Traffic Control

168

Traffic Control Concepts

169

Path Planning and Collision Avoidance

171

Directing Traffic

175

Controlling Robot Speed

179

Restricting Traffic

181
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Understanding Traffic Control
MobilePlanner provides traffic control guidelines for the robot to determine the best path through the operating space. You can control robot traffic by adding areas to the map that tell the mobile robot which direction to go, how fast to drive, or how many robots you want to allow in an area at one time. With
MobilePlanner, you can add these features and more to the map.
This section discusses the following traffic control features:
l

Using Preferred Lines on page 175

l

Using Preferred Directions on page 176

l

Using Forbidden Lines and Areas on page 181

l

Adding Switchable Forbidden Lines and Areas to the Map on page 182

l

Using Resisted Lines and Sectors on page 185

l

Using Need to Enter Sectors on page 188

l

Using Single Robot Sectors on page 189

l

Controlling Robot Speed on page 179
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Traffic Control Concepts
In environments with more than one mobile robot, managing traffic becomes increasingly more critical.
The main goals in managing traffic flow are safe and efficient operations, and minimizing traffic jams and
collisions. The following sections describe some of the more important traffic control concepts.

Taxi Line (Multi-Robot Standby goal)
Much like a row of taxis waiting outside the airport, the concept allows multiple mobile robots to approach
and arrive at the same Standby goal (called a ‘Multi-Robot Standby’ goal), in sequence, without bunching
up and causing a traffic jam.
The Multi-Robot Standby (MRS) goal acts as a traffic control tool. The MRS goal extends the standard
Standby map object to enforce sequenced queuing for multiple robots at a single starting point, each of
which then moves linearly - in sequence - to an end point. Along the way, the robots become available as
they reach the end of their ‘after’ task.
The following figure shows the general design. The MRS start point is at the left, the MRS end point is on
the right.

Figure 9-1: Taxi Stand (Multi-Robot Standby) goal design
An ideal implementation is at a map corridor that frequently becomes congested with multiple robots. By
placing the start point some distance from the goal (for example, at the corridor entrance), the robots
move through the corridor - in sequence - and reach the end point of the ‘after’ movement near the corridor’s exit. Another ideal implementation is for high throughput sources of parts that need to go to many
places (like a plant that has a few gantries serving a few hundred goals. The robots waiting in line near the
source means a much higher throughput.
Implementing Taxi Line
Using this feature requires setting the Boolean ‘AllowMultipleRobots’ on standard standby objects (standbys with this Boolean flag active become Multi-Robot Standbys), and each goal using a nearby MRS must
also have a Managed Destination sector placed over it, with the ‘AlwaysBuffer’ parameter enabled, and the
sector’s ReservedBuffer parameter set to the name of the MRS.

Figure 9-2: Taxi Stand implementation example
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NOTE: You can only use MRSs as ReservedBuffers. An MRS with no sector referencing it as a
ReservedBuffer will display an error when saving the map, and will be ignored during normal operations.
Each MRS can ONLY be reserved by one map object.
A typical implementation is to place a standard goal on the map to use as the end point of the buffering line.
The figure below shows how this would work with a single robot (the dashed lines are for illustrative purposes only - they do not appear in the map).

Figure 9-3: Taxi Stand (Multi-Robot Standby) goal design, single robot use
As shown above, each mobile robot drives to the MRS start point (line 1), rotates to the correct pose (line
2), signals the Enterprise Manager (EM) of its arrival, then executes an ‘after’ task (in this case, a
‘gotoStraight’) to the associated goal (lines 4, and 5). With multiple robots, the sequence works as shown
below. In line 1, a second robot is moving towards the end goal, which is already occupied by another waiting robot. It assumes a position behind the first robot (line 2), and is then joined by two more robots (line
3).

Figure 9-4: Taxi Stand (Multi-Robot Standby) goal design, multiple robot use

Managed Motion Sectors
Certain situations might require multiple robots drive in narrow spaces, like hallways and aisles. Without
proper management, the robots could bunch up and cause traffic deadlocks. The Enterprise Manager (EM)
uses managed motion sectors to control robot traffic flow in difficult areas, by directing the robots to wait at
standby goals while awaiting permission to enter the sector. It allows only one robot to drive autonomously
through the sector at a time, while still performing tasks (such as pickup/dropoff) without requesting EM
permission. Managed Motion can use Taxi Line queuing, with each sector capable of having up to four
reserved buffers.
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Standby Buffering
Standby buffering is another type of ‘StandBy’ behavior in which a mobile robot must wait for another
robot to clear a sector or goal. The awaiting mobile robot can automatically select and move to a nearby
‘StandBy’ goal to wait.

Preferred Lines, and Directions
You can specify preferred lines, and directions that govern how your mobile robots move through their
environment. Once placed on a map, the mobile robots will, if possible, use the preferred areas. If something prevents a mobile robot from keeping to the preferred line or direction, it will seek out another path.

Resisted Areas and Lines
You can also place areas and lines on the map that you want your mobile robots to avoid, but, if unable to
complete a goal without moving into - or crossing over - one of these areas, it will do so (with a higher
cost). Typically, resisted areas, lines, or directions are for special cases, such as setting up travel lanes in
which moving is allowed but should be avoided (for an explanation of cost-based path planning, see Cost
Based Path Planning on page 171).

Forbidden Areas and Lines
As the name implies, these areas, lines, and directions are areas or lines the mobile robot’s must never
enter or cross over. These could be loading docks (or other areas that might lead outside), stairs, internal
structures with walls, or other areas where the robot could pose a hazard.

DistanceUncrossable and DistanceAdjustment Lines
If the straight-line path between the robot and its goal intersects a DistanceUncrossable line, the robot will
not drive to the destination. You can use these lines to guide a robot to the appropriate dock or standby
goal. The DistanceAdjustment line artificially increases the distance calculation between two points.
Queuing uses the distances to determine such actions as which dock to go to.

Path Planning and Collision Avoidance
MobilePlanner’s tools allow you to plan the most expedient routes for your mobile robots, while keeping
them from running into objects in your facility - and each other. There are may traffic control mechanisms
associated with path planning.
This section discusses cost-based path planning, difficult spaces, and virtual doors.

Cost Based Path Planning
ARAM uses a path planning scheme called Cost Based Path Planning. In this scheme, a robot instructed to
proceed to a goal searches the map for the most efficient path from its current location to the goal, based
on what it knows about the map. This path, called the global path, is the optimal path from point a to point
b. The robot then follows that path to the goal while avoiding unmapped obstacles. If the robot detects
unmapped obstacles, it alters its local path to avoid them. If unable to proceed along the global path, the
robot can re-plan a new global path.
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The Path Planning Grid
The ‘cost-based’ aspect of this path planning scheme breaks a map into discrete 100mm squares (typically
sufficient), called the path planning grid (which is not the same as MobilePlanner’s 1000mm (1 meter) reference grid), and assigns a cost to each square. Free (empty) squares (those not close to any obstacles)
have a cost of 0.1. The cost for squares containing walls and other fixed objects is infinite (meaning the
robot will never enter those squares because the cost is far too high).
NOTE: Although you can improve path planning accuracy by decreasing the path planning grid squares
(done in the PlanRes parameter), doing so increases robot processing time. For example, changing the
PlanRes parameter (Config > Robot Operation tab > Path Planning Settings section) from
100mm to 50mm quadruples processing time.
Using cost-based path planning, the robot plans a path with the lowest cost, and follows that path to its
goal. If it detects any unmapped obstructions, it alters its path to avoid them. And while the resulting path
deviation might be longer, the robot will always choose the path of lowest cost.
Factors Affecting Cost
Generally, a grid’s cost increases as its distance to an obstacle decreases, and occupied grid squares have
infinite cost. Preferred lines and directions generally have the lowest cost, while resisted lines and areas
have higher costs. Forbidden lines and areas (like those with walls or other fixed obstructions, loading
docks, etc.) have an infinite cost, meaning the robot will never cross or enter them
For more information about preferred, resisted, restricted, and forbidden lines and areas, see Understanding Traffic Control on page 168.

Path Planning Parameters
MobilePlanner has dozens of path planning-specific parameters that control how the robot moves through
its environment, including (not an all-inclusive list):
l

The robot’s maximum traveling and rotating speed.

l

Turning radius.

l

Grid resolution.

l

Fast and slow speeds.

l

Robot padding and clearances (at fast and slow speeds).

l

Robot rotational speeds at goals.

l

The amount of resistance for resisted sectors and lines.

l

Preferred and resisted lines, areas, and directions.

To view and set these path planning parameters (when connected to a robot), click the Config button,
then click the Robot Operation tab, and select Path Planning Settings.
NOTE: MobilePlanner has the most complete and up-to-date descriptions of all path planning parameters, which will not be repeated here.
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Dealing with Difficult Spaces
Clearance settings limit how close the robot can move to detected obstacles. You can increase or decrease
the required clearance based on the robot's speed, and have the software stop the robot if it will come too
close to an obstacle in its path before it can stop by decelerating.
Changing clearance settings alter the robot's behavior if it moves very slowly through doorways or other
tight spaces, or stops too quickly when it senses an approaching obstacle. Conversely, if your robot moves
too close to obstacles or doesn't slow down rapidly enough, these settings can improve its behavior.
You can set the clearance and padding parameters in MobilePlanner by clicking the Config button, then
clicking on the Robot Operation tab, and selecting Path Planning Settings.
l

Front Clearance: a narrow (100 mm/ 3.9 inches default), fixed buffer zone at the front of the robot
that does not change with robot translational velocity.

Figure 9-5: Front Clearances
l

Side Clearance at Slow Speed (75 mm/ 2.9 inches default) is the minimum side clearance applied at
any translational velocity.

Figure 9-6: Side Clearances
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l

Front Padding and Side Clearance grow as robot speed increases if you set these parameters. This is
done as a safety precaution for faster-moving robots. The values for Front Padding at Slow and Fast
Speeds, as well as Side Clearance at Slow and Fast Speeds can be set larger or smaller than the values shown in the figure above based on your facility, the expected level of traffic, and the general
nature of the environment the robot will be working in.
As the robot accelerates, Front Padding and Side Clearance increase from Slow Speed size towards
Fast Speed size.
NOTE: If side clearance at high speed is set too large, the robot will speed up and slow down in
hallways and similar spaces. This is because the side clearance grows until it touches the wall, forcing the robot to slow down until its side clearance shrinks. It is best to have a small gap between
sideClearanceAtSlowSpeed and sideClearanceAtFastSpeed.

Virtual Doors
Virtual doors (DefaultDoorWithGoals, for example) are areas on the map that allow the robot to drive, automatically and seamlessly, through special areas. For instance, they allow a robot to drive through plastic
curtains that it would normally avoid.
When a robot plans a path through a virtual door, it instead drives to a specified goal beforehand, and
optionally to another specified goal afterward. As with normal goals, tasks can be done at the goals associated with virtual doors.
The following dialog opens when you insert a virtual door in a map:

Figure 9-7: Edit Advanced Area dialog
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With MobilePlanner, you can direct robot traffic by adding preferred lines and directions to your map.
Preferred lines make the robot drive as though it’s on a virtual rail, and reduce the ‘cost’ of grid squares it
crosses. Though a preferred line might be longer than a straight path from Point A to Point B, the preferred
line reduces the cost of each cell it crosses (the Preference parameter divides the cost of each cell the line
crosses by 2, which means it costs half as much to drive close to the line), so it could be the least expensive
in terms of the cost.

Using Preferred Lines
Before adding a preferred line to the map, enable (click the checkbox for) the PreferredLine parameter (in
Config > Robot Operations > Map Features, PreferredLine row):
1. Click the Map button to open the map you want to edit (see Using MobilePlanner Software on page
53 for details).
NOTE: You can have MobilePlanner add grid lines to the map to help you place lines and areas
more accurately. In MobilePlanner’s main menu, click Map > Grid.
2. In the Draw pane, click Advanced Lines, then select PreferredLine from the list (the cursor
changes to indicate it is in drawing mode).
3. Place the mouse cursor on the map where you want the preferred line to start.
4. Click and hold the left mouse button, drag the mouse to where you want the preferred line to end,
then release the mouse button.

Figure 9-8: Edit Advanced Line dialog
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The following table describes the parameters available on the Edit Advanced Line dialog box.
Parameter

Definition

Name

An optional name for the preferred line.

Description

An optional description for the preferred line.

Type

Set to PreferredLine. Selecting a different type from the pull-down menu
changes the map’s highlighted area to the selected type and updates the
dialog box.

Start Point

X and Y coordinates of the PreferredLine starting point.

End Point

X and Y coordinates of the PreferredLine end point.

UseDefaultPreference

True or False (Boolean) value. If set to:
l

l

True: uses the default preference setting, ignores the Preference
value.
False: the robot overrides the path planning settings with the
value of the Preference parameter.

Use Path Planning Settings to specify default settings (see Path Planning
and Collision Avoidance on page 171 for details).
Preference

Integer representing the line’s preference. A normal line has a cost of ‘1’,
so a setting of ‘1’ turns off the line’s preferred behavior. A line with a preference of ‘2’ means driving on the line costs half as much. Higher preferences yield a lower cost. Applies only when UseDefaultPreference is
false. See Cost Based Path Planning on page 171 for more information.

Using Preferred Directions
Preferred directions cause the mobile robot to attempt to drive on the specified side. In the image below,
the robot does not move directly down the center of the hall, but along the right wall (the preferred directions).

Figure 9-9: Preferred direction
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If the robot cannot drive in the preferred direction for some reason, it will change its path to reach its goal,
including driving against the preferred direction on the left side of the hallway (above). MobilePlanner
allows you to add the following preferred directions to the map:
NOTE: You must enable each of the preferred directions listed below (Config button > Robot Operation tab > Map Features) and Save before they will appear in the Advanced Areas pulldown menu
(in the Draw tab).
l

l

l

l

PreferredDirectionLeft: Places an area on the map that tells the mobile robot to drive on the left,
in both directions.
PreferredDirectionLeftSingle: Places an area on the map that tells the mobile robot to drive on
the left, in one direction only. If you use this option and have two of these areas next to each other,
align the two areas carefully. This is an advanced option. Use PreferredDirectionLeft for most
applications.
PreferredDirectionRight: Places an area on the map that tells the mobile robot to drive on the
right, in both directions.
PreferredDirectionRightSingle: Places an area on the map that tells the mobile robot to drive on
the right, in one direction only. If you use this option and have two of these areas next to each
other, align the two areas carefully. This is an advanced option. Use PreferredDirectionRight for
most applications.

Adding a preferred direction to the map
1. Click the Config button, then click on the Robot Operations tab, and select Map Features.
2. In the PreferredDirection (Right or Left) row, enable the PreferredDirection parameters you want to
use, then Save the map.
3. Click the Map button to open the map you want to edit (see Using MobilePlanner Software on page
53 for details).
NOTE: You can have MobilePlanner add grid lines to the map to help you place lines and areas
more accurately. In MobilePlanner’s main menu, click Map > Grid.
4. In the Draw pane, click Advanced Areas, then select the PreferredDirection from the list.
5. Place the mouse cursor on the map where you want the preferred direction to start.
6. Click and hold the left mouse button, drag the mouse to where you want the preferred area to end,
then release the mouse button.
The new area appears on the map, and the Edit Advanced Area dialog box appears.
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Figure 9-10: Edit Advanced Area dialog
Edit Advanced Line
Parameter

Definition

Name

Optional name for the preferred area.

Description

Optional description for the preferred area.

Type

Set to the type of preferred area you selected.

Angle

The preferred area’s rotation angle.

Corner

The X and Y coordinates of the preferred area’s starting corner.

Opposite

The X and Y coordinates of the preferred area’s ending corner.

UseDefaultSideOffset

True or False (Boolean) value. If set to:
l

l

True: uses the default side offset.
False: the mobile robot overrides the path planning settings with
the value of the PreferredDirectionSideOffset parameter.

Use Path Planning Settings to specify default settings (see Path Planning
and Collision Avoidance on page 171 for details).
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Edit Advanced Line
Parameter
PreferredDirectionSide
Offset

Definition
(Integer) Represents how far away from the edge of the preferred direction area the robot can drive.
CAUTION: Setting this value too low can cause the
robot to drive out of the preferred area.

Controlling Robot Speed
You can control the robot’s speed in certain areas by adding Movement Parameter Areas to the map.
Adding Movement Parameter Areas to the Map
NOTE: Movement parameters take effect after the robot is in them.
1. In MobilePlanner, click the Config button, then click the Robot Operations tab, then select Map
Features, then scroll down and click in the checkbox to enable MovementParameterSector.
2. Click the Map button to open the map you want to edit (see Using MobilePlanner Software on page
53 for details).
3. In the MobilePlanner main menu bar, click Map > Grid to display the grid lines on the map.
NOTE: You can have MobilePlanner add grid lines to the map to help you place lines and areas
more accurately. In MobilePlanner’s main menu, click Map > Grid.
4. In the Draw pane, click Advanced Area, then select MovementParameters from pull-down
menu.
The cursor changes to indicate it is in drawing mode.
5. Place the mouse cursor on the map where you want the area to start.
6. Click and hold the left mouse button, drag the mouse to where you want the sector to end, then
release the mouse button.
The new area appears on the map.
Editing Movement Parameter Areas
1. In the Draw pane, click Select, then click on the area you want to edit to highlight it.
2. Right-click on the highlighted area, and select Edit from the pop-up menu.
The Edit Advanced Area dialog box appears.
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Figure 9-11: The Movement Parameters dialog box
The following table describes the parameters available in the Edit Advanced Area dialog box.
Parameter

Definition

Name

An optional name for the area.

Description

An optional description for the area.

Type

Set to MovementParameters. If you select a different type of advanced area, the
highlighted area on the map changes to the selected type and the dialog box updates.

Angle

The angle the area is rotated within the map.

Corner

The X and Y coordinates of the starting corner of the area.

Opposite

The X and Y coordinates of the ending corner of the area.

Parameters

Parameters that affect the robots’ behavior in the sector you drew on the map. A
value of 0 means use defaults.
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Restricting Traffic
You can restrict the mobile robot's movement by adding forbidden lines and areas to the map. These areas
typically correspond to an area of the operating environment that you don't want the mobile robot to
enter, or in which you want to restrict the number of robots operating at the same time (managed motion
sectors). You can also add advanced features to the map that control traffic flow based on certain conditions. For example, you might want the robot to avoid an area during monthly maintenance. You can set
that up using switchable forbidden areas. You might also have an area in which you want only one robot at
a time.
You can set the parameters for these features in MobilePlanner by clicking the Config button, then clicking the Robot Operations tab, and selecting Map Features.
The following features allow you to restrict mobile robot traffic in your operating space:
l

Adding Switchable Forbidden Lines and Areas to the Map on page 182

l

Using Resisted Lines and Sectors on page 185

l

Using Need to Enter Sectors on page 188

l

Using Single Robot Sectors on page 189 (helpful when you have multiple robots operating in the
same environment).

Using Forbidden Lines and Areas
You can place lines and areas on the map that correspond to places in your operating environment where
you do not want the mobile robot to go. You can also add lines and areas that can be temporarily forbidden.
Forbidden lines are invisible barriers (virtual walls) in the operating space that the robot will not cross when
driving in Safe Drive mode (the default driving mode). The cost of map squares under a forbidden line is
infinite. For more information see Driving in Safe Mode on page 1.
Forbidden areas are places in the map that you do not want the robot to enter. For example, if your operating environment has a loading dock that is open to the outside you might not want the mobile robot to
accidentally drive outside, and off the loading dock. The area might be accessible on three sides, so you
could place forbidden areas on the map corresponding to the loading dock.
You can also add forbidden lines and areas that you can turn on and off (switchable forbidden lines and
areas).

Adding Forbidden Lines and Areas to the Map
NOTE: There are no required parameters for Forbidden Lines and Areas, which are always enabled.
1. Click the Map button to open the map you want to edit. Refer to Using MobilePlanner Software on
page 53 for details.
NOTE: MobilePlanner can add grid lines to the map to help you place lines and areas more accurately (main menu, click Map > Grid). Also, ensure Show Robot is OFF.
2. In the Draw pane, click on either Forbidden Line or Forbidden Area.
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The cursor changes to indicate it is in drawing mode, using a box around the icon to indicate an area.
3. Place the mouse cursor on the map where you want the forbidden line or area to start.
4. Click and hold the left mouse button.
5. Drag the mouse to where you want the line or area to end and release the button.
The new forbidden line or area is selected and displayed in the map.

Adding Switchable Forbidden Lines and Areas to the Map
You can have certain tasks activate switchable forbidden lines and areas. These tasks can toggle individual
lines and areas or they can toggle groups of switchable forbidden lines and areas.
1. To enable the SwitchableForbiddenAreaAndLine parameter, click the Config button, click on
the Robot Operation tab, select Map Features, and click the checkbox to the right of the SwitchableForbiddenAreaAndLine parameter.
NOTE: The server will automatically restart when you change the parameters.
2. Click the Map button to open the map you want to edit. See Using MobilePlanner Software on page
53 for details.
NOTE: You can have MobilePlanner add grid lines to the map to help you place lines and areas
more accurately. In MobilePlanner’s main menu, click Map > Grid. Also, ensure Show Robot is
OFF to enable the Draw tools.
3. In the Draw pane, click Advanced Lines or Advanced Areas, depending on what you want to add
to the map.
4. Select SwitchableForbiddenLine or SwitchableForbiddenArea from the corresponding pulldown menu.
The cursor changes to indicate it is in drawing mode, using a box around the icon to indicate an area.
5. Place the mouse cursor on the map where you want the line or area to start.
6. Click and hold the left mouse button, drag the cursor to where you want the line or area to end, then
release the mouse button.
The new switchable forbidden line or area appears on the map, and the Edit Advanced dialog box
appears.

Editing Forbidden and Switchable Areas
NOTE: The following procedures only apply if you want to edit an existing advanced area.
1. Verify Show Robot is OFF then, in the Draw pane, click Select.
2. Either double-click (or right-click) on the area or line in the map, and select Edit from the pop-up
menu.
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Figure 9-12: Edit Advanced Area dialog
The following table describes the options available in the dialog box.
Parameter
Name

Definition
A name for the forbidden area.
NOTE: Since you switch forbidden areas by name, it’s useful to use a common prefix when naming the ones you want to group together.

Description

An optional description for the forbidden area.

Type

Not displayed for ForbiddenLine. If you select a different type of advanced area in
the drop-down list, the highlighted area on the map changes to the selected type
and the dialog box updates accordingly.

Angle

The forbidden area's rotation angle (in degrees) in the map.

Corner

The X and Y coordinates of the forbidden area's starting corner.

Opposite

The X and Y coordinates of the forbidden area's ending corner.

To edit a forbidden line or a switchable forbidden line:
1. Verify Show Robot is OFF then, in the Draw tab, click Select.
2. Either double-click (or right-click) on the line in the map, and select Edit from the pop-up menu.
If you selected a forbidden line, the Edit Forbidden Line dialog box appears. The Edit Advanced Line
dialog box appears if you selected a switchable forbidden line.
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Figure 9-13: Edit Forbidden Line dialog
Edit Forbidden Line
Parameter

Definition

Name

An optional name for the forbidden line.

Description

An optional description for the forbidden line.

Type

Displayed for SwitchableForbiddenLine. If you select a different type of
advanced line from the drop-down menu, the highlighted line changes to
the selected type and the dialog box updates.

Start Point

The X and Y coordinates of the starting point of the forbidden line.

Opposite

The X and Y coordinates of the ending point of the forbidden line.

Switchable Forbidden Lines and Areas
There are two ways to turn on or off a Switchable Forbidden Line or Area:
l

Tasks

l

ARCL

NOTE: ARCL is outside the scope of this manual. Refer to the corresponding reference guides for those
products.
There are four tasks you can use to turn a Switchable Forbidden Line or Area on or off:
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l

switchForbiddenOff

l

switchForbiddenOn

l

l

switchForbiddenOffByPrefix (you can specify a text prefix that turns all switchable areas with that
prefix OFF)
switchForbiddenOnByPrefix (you can specify a text prefix that turns all switchable areas with that
prefix ON)

Driving into a Forbidden Area
Occasionally you might need the mobile robot to drive into a forbidden area. You can make the robot do
this by turning off Safe Drive mode, or using the joystick (even with safe mode on).
1. Click the Map button to open the map containing the forbidden area.
2. Attempt to drive the robot into the forbidden area from multiple sides - the robot should slow down
and stop just before the forbidden area.
3. Click the Safe Drive toolbar button to turn Safe Drive mode OFF.
WARNING: Turning Safe Drive OFF disables the robot's obstacle-avoidance. Use
extreme caution when driving the robot under these circumstances.

4. Select Yes to turn Safe Drive mode off.
5. Drive the mobile robot into the forbidden area - this time the robot should drive into the area.
NOTE: Safe Drive mode must remain OFF to drive the mobile robot out of the forbidden area. Notice
that the background color of the map changes to yellow when Safe Drive mode is turned off.

Using Resisted Lines and Sectors
You can add lines and areas to the map, called resisted lines and sectors, that the mobile robot will attempt
to avoid because they cost more to drive through. The robot's path planning system is similar to a
GPS system that recalculates a route to avoid road construction. However, if another route is not available,
the robot follows the original. Similarly, the mobile robot will resist entering a sector or crossing a boundary
if it is possible to avoid it; however, if it needs to drive through a resisted sector to reach its goal, it will.

Adding Resisted Boundaries and Sectors to the Map
1. In MobilePlanner > Config > Robot Operation > Map Features, enable ResistedSectorAndLine. See Setting the Configuration Parameters on page 126
2. Save your change to the robot.
3. Click the Map button to open the map you want to edit.
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NOTE: You can have MobilePlanner add grid lines to the map to help you place lines and areas
more accurately. In MobilePlanner’s main menu, click Map > Grid.
4. Ensure Show Robot is OFF, then click Draw > Advanced Lines or Draw > Advanced Areas,
depending on what you want to add to the map.
5. In the pull-down menu, select ResistedLine or ResistedSector, and note the cursor changes to
indicate it is in drawing mode (has a box around the icon to indicate an area).
6. Place the mouse cursor on the map where you want the resisted line or sector to start.
7. Click and hold the left mouse button.
8. Drag the mouse to where you want the line or sector to end and release the button to display the
new resisted line or sector in the map, and the Edit Advanced Area dialog box.

Editing Resisted Sectors
1. Verify that Show Robot is OFF then, in the Draw tab, click Select.
2. Either double-click (or right-click) on the sector in the map and select Edit from the pop-up menu.

Figure 9-14: Edit Advanced Area dialog
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Edit Advance Area
Parameter

Definition

Name

A name for the resisted sector.

Description

An optional description for the resisted sector.

Type

Set to ResistedSector. If you select a different type of advanced area,
the highlighted area changes to the new type and the dialog box updates.

Angle

The rotation angle of the resisted sector in the map.

Corner

The X and Y coordinates of the resisted sector’s starting corner.

Opposite

The X and Y coordinates of the resisted sector’s ending corner.

UseDefaultResistance

(Boolean) value. A True setting uses the default resistance setting , and
ignores the Resistance value (default settings are set using the Path Planning Settings - see Path Planning and Collision Avoidance on page 171).
If this is False, the robot overrides the path planning settings with the
value of the Resistance parameter.

Resistance

(Integer) Determines the cost of crossing the area. Defines how much the
robot will resist driving through a particular sector, and find an alternative
path. The cost of driving through a resisted sector is multiplied by its resistance value. A normal area or sector has a cost value of 1. Set this value
to 1 to turn off the resistance behavior.

Editing Restrictive Lines
1. Verify that Show Robot is OFF then, in the Draw tab, click Select.
2. Double-click (or right-click) on the boundary in the map, and select Edit from the pop-up menu.

Figure 9-15: Edit Advanced Line dialog
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Edit Advanced Line
Parameter

Definition

Name

A name for the resisted boundary.

Description

An optional description for the resisted boundary.

Type

Set to ResistedLine. If you select a different type of advanced area, the
highlighted area changes to the new type and the dialog box updates.

Start Point

The X and Y coordinates of the starting corner of the resisted boundary.

End Point

The X and Y coordinates of the ending corner of the resisted boundary.

UseDefaultResistance

(Boolean) A True setting uses the default resistance setting (set in the Path
Planning Settings in the Advanced Areas pull-down menu). See Path Planning and Collision Avoidance on page 171 for details. If False, the robot
overrides path planning settings with the Resistance parameter value.

Resistance

(Integer) Determines the cost of crossing a boundary, how much the robot
resists driving across it, and finds an another path. The cost of driving
across a boundary is multiplied by its resistance value. A normal area has a
cost of 1, so set this value to 1 to turn off the resistance behavior.

Using Need to Enter Sectors
You can add areas to the map that only allow the mobile robot to enter if the goal the robot is trying to
reach is inside the sector. These are referred to as need to enter sectors. If the robot is already in a need to
enter sector, it can drive around in the sector or drive out of it.
Need to enter sectors are useful in (for example) cases in which there are loading or unloading areas where
another robot could cause congestion if it tries to pass through.

Adding Need to Enter Sectors to the Map
1. In MobilePlanner > Config > Robot Operation > Map Features, enable NeedToEnterSector.
For details on how to do this, see Configuring the Robot on page 125.
2. Save your change to the robot.
3. Click the Map button to open the map you want to edit.
NOTE: You can have MobilePlanner add grid lines to the map to help you place lines and areas
more accurately. In MobilePlanner’s main menu, click Map > Grid. Also, ensure Show Robot is
OFF to enable the Draw tools.
4. Click Draw > Advanced Areas.
5. Select Need to Enter from the pull-down menu, and note the cursor changes to indicate it is in
drawing mode.
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6. Place the mouse cursor on the map where you want the sector to start.
7. Click and hold the left mouse button.
8. Drag the mouse to where you want the sector to end and release the button. The new need to
enter sector highlights and appears in the map, and the Edit Advanced Area dialog box appears.

Editing Existing Need to Enter Sectors
1. Click Select.
2. Either double-click on the resisted sector in the map, or right-click on the sector, and select Edit
from the pop-up menu to display the Edit Advanced Area dialog box.

Figure 9-16: Edit Advanced Area dialog
The following table describes the options available on the Edit Advanced Area dialog box.
Parameter

Definition

Name

A name for the need to enter sector.

Description

An optional description for the need to enter sector.

Type

Set to NeedToEnter. If you select a different type of advanced area, the highlighted area on the map changes to the selected type and the dialog box updates
accordingly.

Angle

The angle the sector (rectangle) is rotated within the map.

Corner

The X and Y coordinates of the starting corner of the sector.

Opposite

The X and Y coordinates of the ending corner of the sector.

Using Single Robot Sectors
Single robot sectors allow you to add areas to the map that only allow one mobile robot at a time to be in
the specified area. This is useful for narrow hallways or narrow areas with only one entry/exit.
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Adding Single Robot Sectors to the Map
1. In MobilePlanner > Config > Robot Operation > Map Features, enable SingleRobotSector.
See Configuring the Robot on page 125 for details.
2. Save your change to the robot.
3. Open the map you want to edit. See Using MobilePlanner Software on page 53 for details.
4. Ensure Show Robot is OFF, then click on the Grid toolbar icon to display the grid lines on the map.
This helps you to place the lines and areas more accurately.
5. Click Draw > Advanced Areas.
6. Select SingleRobot from the pull-down menu (the cursor changes to indicate it is in drawing
mode).
7. Place the mouse cursor on the map where you want the single robot sector to start.
8. Click and hold the left mouse button.
9. Drag the mouse to where you want the sector to end and release the button to highlight the new
area in the map.

Editing Existing Single Robot Sectors
1. Click Select.
2. Either double-click on the sector in the map, or right-click on the sector, and select Edit from the
pop-up menu to display the Edit Advanced Area dialog box.
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Figure 9-17: Edit Advanced Area dialog
The following table describes the options available on the Edit Advanced Area dialog box.
Parameter

Definition

Name

A name for the single robot sector.

Description

An optional description for the single robot sector.

Type

Set to SingleRobot. If you select a different type of advanced area from the pulldown menu, the highlighted area on the map changes to the selected type and the
dialog box updates accordingly.

Angle

The angle the sector is rotated within the map.

Corner

The X and Y coordinates of the starting corner of the area.

Opposite

The X and Y coordinates of the ending corner of the area.
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When a moving robot is operating in an environment such as an office building or a warehouse, it must
have some way of tracking its position and orientation on a map. This tracking is called localization. Accurate localization is a prerequisite for intelligent navigation.
This section discusses the types of localization your mobile robot uses. For more information, refer to the
following:

What is Localization?

194

Comparing Laser and Light Localization

195

What Causes the Robot to be Lost?

195

Optimizing Localization

196

Using Laser Localization

197

Using Acuity For Light Localization

201
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What is Localization?
Localization is the way in which the mobile robot knows its location on the map. It is a process the robot
uses to estimate its position in its environment based on data collected during operation. Currently, the
mobile robots can use two types of localization:
l

Using Laser Localization on page 197
Laser localization uses data from the robot's laser in conjunction with the map to calculate the
robot's position. This is the default way the mobile robot keeps track of its position in the operating
space and is most useful in a static environment such as an office building or hospital.

l

Using Acuity For Light Localization on page 201
Optionally, a robot can use overhead lights to track its position in the environment. This localization
process is often used in dynamic environments, such as a warehouse, where objects move too frequently for the robot to localize based on their past positions.

The key to localization is obtaining an accurate map of the environment (see Working with Map Files on
page 111). The robot compares the map to the data collected from its sensors to correct its position. With
this information, the robot knows its position on the map.
NOTE: The robot combines data collected with either of these methods with data from encoders on its
wheels and the gyroscope in its core to determine its location.

Overview of Localization Process
Localization requires an iterative process of correcting for errors in the robot odometry. When a robot is
powered up, it must determine its initial position (which could be its last position when it shut down). During operation, the robot calculates the current position based on its last known position, along with the
robot's speed and direction. The mobile robot periodically recalculates its position to make sure it knows
where it is. If the robot cannot calculate a reliable pose, it is lost and must stop. After the robot recalculates
its position, the current location becomes the last known location.
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Comparing Laser and Light Localization
As discussed earlier, localization is the process the robot uses to determine its position in its environment.
The mobile robot can use data from its laser or from the position of overhead lights (or a combination of the
two), to accurately determine where it is in its physical space and in the map.
The following table highlights the differences between laser and light localization. For more information on
each localization process, refer to the appropriate section.
Laser Localization

Light Localization

Description

Uses a laser range finder loc- Uses a camera located on the mobile robot to
ated on the mobile robot to monitor overhead lights in the environment
perform localization.
as points of reference to perform localization.

Equipment

Laser range finder (standard)

Upward-facing camera option.

Accuracy vs. Reliability

Provides more accurate location data, but the robot
cannot deal with highly
dynamic environments.

Provides more reliable localization in a
dynamic environment, because there is less
chance for the robot to get lost, but the robot
positioning is less accurate.

Recommended
Environment

Static (such as an office
building)

Dynamic (such as a warehouse)

What Causes the Robot to be Lost?
When a robot no longer has enough confidence in its position, it broadcasts that it’s lost, and stops driving
until a human intervenes. When a robot is lost, it stops moving and broadcasts a notification (in the form
of the dialog box below) that it needs attention.

Figure 10-1: Localization dialog - lost robot
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Localizing a Lost Robot
1. Click Localize to Point in the lost robot dialog box.
2. Click and hold the mouse on the map where you want to localize the robot (at the robot’s current
physical location) and, while holding the left mouse button, drag the mouse cursor to set the robot's
heading.
The Localization Score (or confidence threshold) should be 80% or better for optimum navigation.
3. Click Done when the robot's localization score is where you want it to be.

Adjusting the Confidence Threshold
The PassThreshold and LostThresholdDistance parameters (for laser localization) and LockThreshold
and LostLockUncertaintyThreshold parameters (for light localization) set the criteria for when a robot is
lost. With each localization, the robot generates a localization score. The robot is not considered lost until
the localization score drops 20% below the PassThreshold parameter (for laser localization) or -100 on
the LostLockUncertaintyThreshold (for light localization), and fails to recover. Once the localization
score drops below PassThreshold/LockThreshold, the robot will move up to LostThresholdDistance/LostLockUncertaintyThreshold, trying to raise its score. If it fails, it is considered lost. You can
adjust the parameter values as needed.
LostThresholdDistance is the maximum distance (in mm) that the robot will move from the last localized
pose before the robot will be considered lost. This parameter will only come into play if none of the samples
during the sensor correction is higher than PassThreshold. As soon as this happens, the position uncertainty distance will grow based on the movement from the last localized pose.
1. In MobilePlanner, click the Config button, then click the Robot Operation tab, and select Localization settings (or Light Localization settings).
2. Click on the PassThreshold Value (or LockThreshold value for light localization) field and enter
a new threshold value (the minimum score to consider the robot localized ).
3. Click on the LostThresholdDistance Value (or LostLockUncertaintyThreshold value for light
localization) field and enter a new distance value if desired.

Optimizing Localization
Localization accuracy depends on the accuracy of the map and sensor measurements. Typically, the mobile
robot should be able to localize in most indoor environments. Occasionally, however, the robot encounters
situations in which it has trouble localizing, which can impact its ability to navigate.
The most common problem with localization is map accuracy. It might not have been accurate enough to
begin with, or the environment might have changed enough (partitions moved, etc.), that the map no
longer reflects the working environment.
You can improve localization accuracy, to some extent, by adjusting the localization parameters. However,
changing one parameter generally affects other parameters. Therefore you will likely need to adjust several
parameters to fine tune the localization score.
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Laser and Light Localization use different parameters that you can adjust. Those parameters are discussed
in Localization Parameters on page 198 and Light Localization Parameters on page 204 respectively.
However, there are a few general guidelines to consider before you change parameter values.

Before Changing Parameter Values
Before changing any parameters (localization or other), make sure your map contains as much accurately
scanned data as possible. The more static features the map has (walls, doors, shelves, etc.), the better the
robot is at navigating its way through the space.
l

l

l

Don't erase any data from the map unless those points really do not correspond to any real, fixed
object.
Rescan areas where features have been removed from or added to an area in the environment.
If there were errors in the map-making process, and your map does not match the real space, rescan the area again more carefully.
CAUTION: Before changing parameters, save a copy of your current config
file! When experimenting with parameters, try one parameter or a small combination
of parameter changes at a time. Revert to your saved config file if the robot's performance does not improve. See Configuring the Robot on page 125.

Using Laser Localization
Omron Adept mobile robots use one of two methods to locate their position in their environment: laser or
light localization. For more information on using light localization, refer to Using Acuity For Light Localization on page 201.
Laser localization uses a laser range finder, located on the mobile robot, to detect walls and other objects in
the environment. The data collected from the laser is combined with the robot's odometry information and
the map, which enables the robot to determine its location.

Overview of Laser Localization
The most common way to localize a mobile robot in a given space is to use a laser range finder. The laser
range finder takes a planar snapshot of the environment, then compares this with the map of the environment to determine the robot's position. This is a relatively accurate method of localization for environments that tend to be static, such as an office space.
If the laser localization cannot match the laser readings to the map, it does have some logic that allows the
mobile robot to drive for a while before reporting that it is lost. However, this is only useful in temporary
situations, such as the robot driving through a small area where a group of people have gathered.
In a dynamic space where unmapped cargo and equipment move in and out of the area (such as in a warehouse), data from the unmapped objects can easily overwhelm the mapped data, causing the laser localization to fail. In these situations, it is better to use light localization. See Using Acuity For Light
Localization on page 201 for details.
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Key Features
l

Laser localization gives accurate positioning data for precise navigation, particularly in a relatively
static environment.

l

No potentially expensive retrofitting required to use laser localization.

l

The map only needs to be updated if there is a change in the static environment.

l

The mobile robot continues to operate even if some of the map features have changed, resulting in a
flexible solution.

Limitations of Laser Localization
Laser localization is an accurate method of localization in a static environment such as an office, but has
some limitations to consider:
l

l

l

The laser cannot see glass, mirrors, or shiny objects. Environments with a lot of these objects make
it difficult for the robot to localize.
In dynamic environments in which objects frequently change positions (such as a warehouse), laser
data might not match mapped data closely enough for the robot to localize. In these areas, the map
won't contain objects added or moved after you created the map.
In an environment with a lot of high racks for the robot to navigate through, the confidence
threshold could fall below 20% and cause the robot to become lost.

Localization Parameters
In MobilePlanner, you can access the robot's localization parameters and adjust them as needed.
To access the laser localization parameters, click the Config button, then click the Robot Operation tab,
and select Localization settings.
Improving Accuracy and CPU Usage
For laser localization, two settings directly affect the CPU usage for each localization:
l

l

GridRes represents the size of the grid used for localization. The smaller the value is, the more
accurate the localization score.
NumSamples represents the number of poses sampled (or checked) each time the robot moves;
this number scales linearly, so adjusting a value of 2000 to 3000 takes up 1.5 times more processing power.

Other factors, such as TriggerDistance and TriggerAngle determine how often it attempts to re-calculate (or
re-localize) its position. Recalculating uses a lot of CPU so, if the value of NumSamples is set too high, the
robot will localize less often. This can actually cause more problems than a robot that localizes less accurately, but more often.
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The K parameters (KMmPerMm, KDegPerDeg and KDepPerMm) are error parameters, and are explained
below.
Using Laser Localization Parameters
With MobilePlanner, you can access the robot's configuration parameters and adjust them as needed.
To access the laser localization parameters, click the Config button, then click on the Robot Operation
tab, and select Localization settings.
In general, high CPU use for one laser scan might prevent the robot scanning as often as needed. Setting
these parameters requires balance.
You can change parameters that affect the level of detail in a robot's scan, how many possible locations
(poses) the robot will compare those results with, and how frequently, both in time and travel, it rechecks
its location. There are also parameters to adjust the amount of expected error, both linear and rotational.

Localization Parameters and Effects on CPU Use
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Parameter

Description

Effect(s) on Localization

AdjustNumSamples
Flag

Varies the number of
samples based on the localization score.

When enabled, lowers the number of samples
when the robot is moving and the localization
score is high. Reduces CPU demand.

AngleIncrement

Separation (in degrees)
required between laser
settings used for localization.

Discards readings too close together. Reduces
CPU demand.

GridRes

Resolution (in mm) of
map grids.

Scan resolution. Decreasing this value
increases localization accuracy, but increases
demand on RAM.

KMmPerMm

Millimeters of linear error
per linear millimeter of
travel.

Allowed percentage error (in mm) of the robot’s
linear odometry readings. If set too high,
sample poses are too spread out for the robot to
determine its location. If set too low, the robot
might not be able to localize.

KDegPerDeg

Degrees of error per
degrees rotated.

Allowed percentage error (in deg) of the robot’s
rotational odometry readings. If set too high,
sample poses too spread out for the robot to
determine its location. If set too low, the robot
might not be able to localize.

KDegPerMm

Degrees of error per linear Allowed error (in deg) of the robot’s rotation per
mm traveled.
one mm of linear travel. If set too high, sample
poses too spread out for the robot to determine
its location. If set too low, the robot might not
be able to localize.

NumSamples

Number of pose samples
Scan resolution. Increasing this value increases
robot uses for localization. localization computations. If too low, the robot
fails to localize.

TriggerDistance

Distance robot travels (in
mm) before localizing.

How often to localize – helps reduce CPU
demand. The robot only localizes when it
travels beyond listed value.

TriggerAngle

Angle (in deg) robot turns
before triggering localization.

How often to localize – helps reduce CPU
demand. The robot only localizes when it
rotates beyond the listed value.
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Using Acuity For Light Localization
Light Localization uses a wide-angle camera mounted on the mobile robot to detect the fixed overhead
lights in the operating environment. After combining light position data with its odometry readings and
map data, the robot knows where it is in physical space on its map.
NOTE: The navigation laser remains active for obstacle avoidance even when not being used to for navigation.

Overview of Light Localization
Using overhead lights as landmarks, the mobile robot is able to reliably calculate its position within its
environment.
Light Localization allows the robot to localize in a dynamic environment where change is frequent.
A warehouse, for example, includes many boxes, pallets, vehicles and people that move frequently. In this
situation, the robot can use the overhead lights to determine its position in the environment. The mobile
robot uses both camera and odometry data to calculate its current position.
Key Features
Key features of light localization include:
l

No expensive retrofitting required to use light localization.

l

The lights do not require special maintenance.

l

l

l

Because the lights are overhead, they are not blocked by ground level obstructions that could prevent laser sensors from working.
The map does not need to be updated because the light positions typically do not change.
Even if some lights are burned out, the mobile robot still has a reliable solution and continues to
operate.

NOTE: Using light localization in spaces with lights at different heights, or places with lights visually
behind others, can require different scanning techniques not covered in this guide. For details, see the
Mobile Robots - LD Platform Peripherals Guide.

Creating the Light Map
Before creating a Light Localization map, be sure you are familiar with creating an initial map scan. Refer to
Scanning Your Environment for more information.
NOTE: When scanning the operating environment using Light Localization, be sure to drive under the
lights or as close to the lights as possible. You need to do this in both directions, to make sure the camera sees the lights from all angles, collecting pan and tilt data along the way.
Compared with laser localization scan files, Light Localization scan files contain additional information
about the robot's operating environment and, therefore, require extra processing steps. The resulting map
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files also contain information about the location and height of overhead lights detected during the scanning
process.
Light Localization is only available on mobile robots equipped with it, and you must enable the LightLocalization parameter in the MobilePlanner software. Refer to Configuring the Robot on page 125 for details.

Adjusting the Light Analysis Parameters
1. In MobilePlanner’s Config window, select Robot Configuration.
2. Click on the Light Analysis section from the left window pane to view parameters associated with
the light analysis in the right window pane.
3. Select Show Expert+ Parameters to access the main light analysis parameters.
The following table describes the most important parameters for light analysis:
Parameter Name

Description

3d:MinLightHeight

Minimum height (in mm) of the lights above the floor. This value is approximate and should be lower than the real value. It is used to establish a valid
range and eliminate false positives. (Double)

3d:MaxLightHeight

Maximum height (in mm) of the lights above the floor. This value is approximate and should be higher than the real value. It is used to establish a valid
range and eliminate false positives. (Double)

3d:MinLightLength

Minimum length (in mm) of the lights. This value is approximate and should
be slightly lower than the real value. If -1, then this value is ignored.
(Double)

3d:MaxLightLength

Maximum length (in mm) of the lights. This value is approximate and should
be slightly higher than the real value. If -1, then this value is ignored.
(Double)

Set the 3d:MinLightHeight and 3d:MaxLightHeight parameters to a range that encompasses the ceiling
and light heights, but not too large (a few meters).
If the lights are fluorescent tubes or the lights are partially hidden from the camera's view, you may also
need to adjust the 3d:MinLightLength and 3d:MaxLightLength parameters.
After making these adjustments, reprocess the light scan in MobilePlanner. This does not require redoing
the laser portion of the map creation, just reprocessing the light data.

Creating The Light Map
1. Turn all lights ON in the operating environment.
2. Open MobilePlanner and start the scan process. See Scanning Your Environment for details.
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3. Drive the robot around the environment, paying special attention to the overhead lights. Drive
under the overhead lights in both directions.
4. Stop the scan.
5. Turn the scan into a map (see Creating an Initial Map of the Environment for details).
6. Verify the scanned map shows overhead lights in the correct position and with the correct height.
You can view the height data by moving the mouse over the light icon on the map. The overhead
lights appear as blue squares, rectangles or points (depending on the type of light), as shown below.

Figure 10-2: MobilePlanner light map - detail
7. If the light map looks correct, click Finish on the Scan Tools toolbar.
8. If the light map does not look correct, you will need to adjust the light analysis parameters and
reprocess the scan. See Creating the Light Map on page 201 for details.
By default, the overhead lights are hidden from the map after turning the light scan into a light map. You
can view the lights by selecting Map > Map Data > Light Items from the MobilePlanner main screen.
The light map contains data (such as height) about the lights seen by the camera , but does not contain
images of the lights themselves.

Limitations of Light Localization
Light Localization is a reliable method of localization, even in a dynamic, frequently changing environment
such as a warehouse. The number of lights visible lights affects the accuracy of the robot's estimated position and, if the mobile robot travels for a long time in a sparsely lighted area, it will end up with a low localization score. However, in general, the robot tends not to get lost as often using light localization which
is, therefore, more reliable in a dynamic environment.
Consider the following limitations:
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l

The lights must be on and visible for light localization to work.

l

Skylights can be problematic.

l

l

l

l

l

l

l

Currently, light localization works with LED lights, can lights (displayed as squares on the map) and
fluorescent tube lights (displayed as rectangles).
The more lights visible to the robot, the better. Light localization does not work well with only one or
two lights in an area.
The lighting must be direct. The robot must see a bulb or diffuser, not just a light reflection off of
another surface.
An environment that has lights of varying brightness might have problems.
The tilt of the camera is assumed to be fixed. A change to this, such as when the robot is on a tilted
floor in the building, adversely affects the light localization.
The accuracy of the localization depends on the accuracy of the light map. If the lights in the map
are incorrect due to mapping errors, the localization will show a similar offset.
The vertical distance from the camera to the lights should be at least a couple of meters for the light
localization to work well. If the lights are too close to the camera, the error will be more than when
the lights are farther away.

Light Localization Parameters
In MobilePlanner software, you can access the robot's configuration parameters and adjust them as
needed:

Accessing Light Localization Parameters
1. Select Config > Robot Operation from the main menu.
2. Click on the Light Localization settings section from the left pane to see parameters associated with
the light localization in the right pane.
The parameters for light localization are described in the software, and are not repeated here.
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