CX-One

FA Integrated Tool Package

CX-One
Introduction Guide
CX-One CD-ROM contains a setup manual PDF file.
The Setup manual of CX-One is stored in the following file.
Disk1: CX-One_Manuals \ English \ CX-One Setup Manual W463-E1-01.pdf

Before using this product, you must read “Introduction” and “Safety Cautions”.
Cautions and detailed explanation are available on Help and PDF Manual.

* Acrobat Reader 5.0 or later is required to read the PDF file.
Chapter 1 Overview and Installation of CX-One

1. What is CX-One? .................................................. 1-1
2. Features of CX-One ................................................. 1-1
4. CX-One Component Checklist .................................. 1-4
5. CX-One Installation Procedure .................................. 1-5

Chapter 2 Example of PLC System Construction by CX-One

Workflow in This Chapter ..................................... 2-1

1. Design
   1-1. Starting CX-Programmer ..................................... 2-2
   1-2. Creating Unit Configuration .................................. 2-3
   1-3. Setting CPU Bus Units and Special I/O Units ...................... 2-5
   1-4. Checking I/O Assignment ...................................... 2-9
   1-5. Programming .................................................. 2-10
   1-6. Offline Debug ................................................ 2-12
   1-7. Saving a Project ............................................ 2-13

2. Online Debug on a Machine
   2-1. Reading a Project ........................................... 2-14
   2-2. Online Connection to PLC .................................. 2-15
   2-3. Transferring to a Machine .................................. 2-16
   2-4. Program Debug ............................................. 2-21

3. Start-Up / Adjustment On-site
   3-1. Program Modification ....................................... 2-23
   3-2. Unit Parameter Change ...................................... 2-25

Chapter 3 Example of PLC Network System Construction by CX-One

Workflow in This Chapter ..................................... 3-1

1. PLC Network Start-Up
   1-1. PLC Start-Up ................................................ 3-2
   1-2. DeviceNet Start-Up .......................................... 3-6
   1-3. NT Link Start-Up ............................................ 3-8
   1-4. Controller Link Start-Up .................................... 3-10
   1-5. CompoWay/F Start-Up ...................................... 3-12
   1-6. Saving System Configuration ................................ 3-15

2. Adjustment On-site
   2-1. System Configuration Verification ........................... 3-17
   2-2. Controller Link Diagnosis .................................. 3-19

3. Servo/Inverter Settings
   3-1. DeviceNet Connection ...................................... 3-20
   3-2. RS232C Connection ......................................... 3-21

Chapter 4 Appendix

1. Personal Computer Requirements ................................ 4-1
2. List of Software to be Installed .................................. 4-2
3. Comparison of Functions Between Conventional Support Software and CX-One ................................. 4-3
Chapter 1
Overview and Installation of CX-One
1. What is CX-One?

CX-One is an FA Integrated Tool Package that integrates Support Software for OMRON's PLC and other Components.
To construct an FA System based mainly on PLC, traditionally it was necessary to purchase and install individual Support Software compatible with each Unit, start the software individually, and then connect to PLC and individual Components.
Installation of this FA Integrated Tool Package "CX-One" on a personal computer allows integrated operation from setup of OMRON's CPU Bus Units and Special I/O Units (SIOU) and Components to network start-up/monitoring and improving efficiency of PLC System start-up.

2. Features of CX-One

- CX-One allows integrated management of Support Software for OMRON's PLC/Components.
  - Installation on only one personal computer allows a user to handle Support Software for OMRON's products.
  - Only one licensing key is required to install all Support Software.
  - It allows integrated management of one save location for files created by Support Software.
- Support Software dedicated to CPU Bus Units and Special I/O Units can be started on the I/O Table.
  - The appropriate dedicated Support Software can be automatically started by specifying a registered Unit in the I/O Table (Unit configuration table attached to a PLC). In addition, setup information such as PLC model can be passed to the dedicated Support Software at start-up, allowing easier switching between Support Software.
- The following functions are available by the introduction of the ID information file (CPS) for OMRON Components.
  - Setup of CPU Bus Units and Special I/O Units without manual setting and address recognition.
    (Parameter and selection item names as well as available range of setup are automatically displayed)
  - CPU Bus Units and Special I/O Units setting on personal computer and data on actual PLC (CPU Unit) can be verified online, and unmatched item/readout data is displayed graphically.
  - Unit configuration is displayed on the I/O Table based on Unit model.
  - Device type on the network can be checked for its Unit model, allowing exact verification of network configuration.

What is CPS?

CPS (Component and network Profile Sheet) is definition information of CS/CJ series Unit/Components in CX-One. It is provided as a CPS file (XML format file). CX-One recognizes CS/CJ series Unit by information in this CPS file. CPU Bus Units and Special I/O Units setting is created based on this CPS file.
3. Integrated Simulation – New Function in Version 2.0

Integrated Simulation Overview:
Integrated Simulation is a function of CX-One (version 2.0 or higher) that simultaneously tests interoperability between the ladder program and PT (touch panel) and checks screen operation on the computer.

Earlier Versions:
Operation checks had to be performed separately on the ladder program and PT (touch panel) screens. In addition, the program had to be downloaded to the devices.

Using Integrated Simulation:
Provides an interoperability check between the ladder program and touch panel screens.

- Operation can be verified before actual devices such as the PLC and PT (touch panel) are installed and wired, so software quality can be improved in the design stage.
- Time can be saved by eliminating the tasks up to downloading the screen data from the computer to the PT.
- The operation of both the PLC and PT (touch panel) can be verified simultaneously in the computer, which greatly reduces the time required for debugging and equipment downtime during improvements.

Simulation of the PLC – PT (touch panel) system can be started easily, with one click of an icon.
Integrated Simulation Procedure

Use the following procedure to execute an integrated simulation of the ladder program and PT (touch panel) screen. For details, refer to the *CX-Designer Operation Manual* (V088).

1. Create the screen data in the CX-Designer.

2. Click the Icon or select **Tools – Integrated Simulation**. The PLC-PT Integrated Simulation Dialog Box will be displayed.

3. Click the **Browse** Button and select the desired ladder program (CXP) file.

4. Click the **Start** Button. The PLC-PT Integrated Simulation will start automatically.

5. The test window will be displayed. The Test Tool Window will list all of the communications addresses being used in the displayed screen. For example, when “Host SERIAL A” is connected to the CX-Simulator, the CX-Simulator value is reflected in the SERIAL A communications address. (The values can also be changed.)
4. CX-One Component Checklist

CX-One consists of the following items. Check if they are included in the package.

- **CX-One Components**

<table>
<thead>
<tr>
<th>Item</th>
<th>Quantity</th>
</tr>
</thead>
<tbody>
<tr>
<td>Setup Disk (CD-ROM)</td>
<td>3 disks</td>
</tr>
<tr>
<td>CX-One Introduction Guide (this document No.R145)</td>
<td></td>
</tr>
<tr>
<td>CX-Programmer Introduction Guide (No.R132)</td>
<td></td>
</tr>
<tr>
<td>CX-Designer Introduction Guide (No.V089)</td>
<td></td>
</tr>
<tr>
<td>Function Block Introduction Guide (No.R144)</td>
<td></td>
</tr>
<tr>
<td>CX-One Setup Manual (No.W463)</td>
<td></td>
</tr>
<tr>
<td>CX-Programmer Operation Manual (No.W446)</td>
<td></td>
</tr>
<tr>
<td>CX-Programmer Operation Manual, Function Block (No.W447)</td>
<td></td>
</tr>
<tr>
<td>CX-Integrator Operation Manual (No. W464)</td>
<td></td>
</tr>
<tr>
<td>CX-Simulator Operation Manual (No. W366)</td>
<td></td>
</tr>
<tr>
<td>CX-Designer Users Manual (No.V088)</td>
<td></td>
</tr>
<tr>
<td>CX-Motion-NCF Operation Manual (No. W436)</td>
<td></td>
</tr>
<tr>
<td>CX-Motion-MCH Operation Manual (No. W448)</td>
<td></td>
</tr>
<tr>
<td>CX-Position Operation Manual (No. W433)</td>
<td></td>
</tr>
<tr>
<td>CX-Drive Operation Manual (No. W453)</td>
<td></td>
</tr>
<tr>
<td>CX-Protocol Operation Manual (No.W344)</td>
<td></td>
</tr>
<tr>
<td>CX-Process Tool Operation Manual (No.W372)</td>
<td></td>
</tr>
<tr>
<td>CX-Profilbus Operation Manual (No.W05E)</td>
<td></td>
</tr>
<tr>
<td>Face Plate Auto-Builder for NS Operation Manual (No.W418)</td>
<td></td>
</tr>
<tr>
<td>Smart Active Parts Library Reference Manual (*)</td>
<td></td>
</tr>
<tr>
<td>CX-Thermo Operation Manual</td>
<td></td>
</tr>
<tr>
<td>TrajeXia Manual</td>
<td></td>
</tr>
<tr>
<td>Software License Agreement/User Registration Card</td>
<td>1</td>
</tr>
</tbody>
</table>

*PDF Manuals are provided for each Unit.

- **CX-One Software List**

<table>
<thead>
<tr>
<th>Product</th>
<th>Model</th>
<th>Installable peripheral tool</th>
<th>Included data</th>
</tr>
</thead>
<tbody>
<tr>
<td>CX-One Ver.2</td>
<td>CXONE-AL01C-EV2 (for 1 license)</td>
<td>- CX-Programmer Ver.7</td>
<td>OMRON FB</td>
</tr>
<tr>
<td></td>
<td>CXONE-AL01D-EV2 (for 1 license)</td>
<td>- CX-Integrator Ver.2</td>
<td>- Smart Active Parts (SAP)</td>
</tr>
<tr>
<td></td>
<td>CXONE-AL01C-EV2 (for 3 licenses)</td>
<td>- CX-Simulator Ver.1</td>
<td>- CPS</td>
</tr>
<tr>
<td></td>
<td>CXONE-AL01D-EV2 (for 3 licenses)</td>
<td>- CX-Designer Ver.2</td>
<td>- Manual (PDF)</td>
</tr>
<tr>
<td></td>
<td>CXONE-AL10C-EV2 (for 10 licenses)</td>
<td>- CX-Motion Ver.2</td>
<td></td>
</tr>
<tr>
<td></td>
<td>CXONE-AL10D-EV2 (for 10 licenses)</td>
<td>- CX-Motion-NCF Ver.1</td>
<td></td>
</tr>
<tr>
<td></td>
<td>CXONE-AL10C-EV2 (for 30 licenses)</td>
<td>- CX-Motion-MCH Ver.2</td>
<td></td>
</tr>
<tr>
<td></td>
<td>CXONE-AL10D-EV2 (for 30 licenses)</td>
<td>- CX-Position Ver.2</td>
<td></td>
</tr>
<tr>
<td></td>
<td>CXONE-AL10C-EV2 (for 50 licenses)</td>
<td>- CX-Drive Ver.1</td>
<td></td>
</tr>
<tr>
<td></td>
<td>CXONE-AL10D-EV2 (for 50 licenses)</td>
<td>- CX-Protocol Ver.1</td>
<td></td>
</tr>
<tr>
<td></td>
<td>CXONE-AL10C-EV2 (for 50 licenses)</td>
<td>- CX-Process Tool Ver.5</td>
<td></td>
</tr>
<tr>
<td></td>
<td>CXONE-AL10D-EV2 (for 50 licenses)</td>
<td>- CX-Profibus Ver.1</td>
<td></td>
</tr>
<tr>
<td></td>
<td>CXONE-AL10C-EV2 (for 50 licenses)</td>
<td>- Face plate Auto-Builder for NS Ver.3</td>
<td></td>
</tr>
<tr>
<td></td>
<td>CXONE-AL10D-EV2 (for 50 licenses)</td>
<td>- CX-Thermo Ver.3</td>
<td></td>
</tr>
<tr>
<td></td>
<td>CXONE-AL10C-EV2 (for 50 licenses)</td>
<td>- CX-FLnet Ver.1</td>
<td></td>
</tr>
<tr>
<td></td>
<td>CXONE-AL10D-EV2 (for 50 licenses)</td>
<td>- Switch Box Utility Ver.1</td>
<td></td>
</tr>
<tr>
<td></td>
<td>CXONE-AL10C-EV2 (for 50 licenses)</td>
<td>- TrajeXia Ver.2</td>
<td></td>
</tr>
<tr>
<td></td>
<td>CXONE-AL10D-EV2 (for 50 licenses)</td>
<td>- CX-Sensor Ver.1</td>
<td></td>
</tr>
</tbody>
</table>
5. CX-One Installation Procedure

Before installing the CX-One, you must:
- Terminate all Windows programs
- Uninstall previous versions of Support Software (such as CX-Programmer) if already installed.
- Installation takes about 10 to 40 minutes depending on your personal computer. (10 minutes for a personal computer with CPU: Celeron 2.2GHz, main memory: 512MB, and CD-ROM drive: 48x)
- To change/modify/delete CX-One after installation, refer to the PDF manual "CX-One Setup Manual", Chapter 2 "Installation and Uninstallation".

Installing CX-One

In case of the installing procedure by CD-ROM:
Insert CX-One installation disk 1 (CD-ROM) into your personal computer’s CD-ROM drive. [Choose Setup Language] dialog box is displayed. By default the OS language installed on your personal computer is automatically selected. Check if the language is appropriate, then click the [OK] button.

![Choose Setup Language dialog box]

Click [OK]

The CX-One splash screen is displayed and CX-One installation starts.

Uninstall older version of tools such as PLC Tools (PLC System setting and I/O Table), CX-Server, and CX-Programmer if they have been installed.

![Uninstalling CX-Programmer]

Always click [OK]

![Uninstalling CX-Server]
CX-One setup wizard starts.

The [License Agreement] dialog box is displayed. Read the software license agreement carefully. If you agree with all items, select the [I accept the terms of the license agreement] radio button and click the [Next] button.

Select the radio button

The [User information] dialog box is displayed.

Enter [User], [Company], [License] (product serial number of CX-One)

Click [Next]
Select an installation folder, then click [Next].

The [Installation Folder Selection] dialog box and [Setup Type] dialog box are displayed.

Select the radio button [Complete].

Click [Next].

The [Program Folder Selection], [Choose Destination Location of OMRON FB Library], [Select Program Folder], and [Ready to Install the Program] dialog boxes are displayed.

Read the message and click [Next].

By selecting [Custom], you can individually select and install Support Software from the CD-ROM.

Click [Install].

CX-One installation is starts.

Insert CX-One Disks 2 and 3 then click the [OK] button.

Click [Finish].

A dialog box (right) is displayed. Click the [Finish] button to finish the installation wizard. Installation is complete. (When it is necessary to restart the personal computer, a restart confirmation dialog box appears.)
Online Registration

If the personal computer that the software has been installed on has an Internet connection, you can proceed to online user registration.

After installation has been completed the [Online Registration] dialog box is displayed.

If you click the [Register] button, your Web browser connects to “OMRON’s CX-One Web site”.(*1) (*2)

*1: If you click the [Exit] button to cancel online registration, the [Online Registration] dialog box is displayed every time the CX-One Support Software is started.

*2: If you do not have an Internet connection, or you do not want to register online, fill out and send the user registration card that comes with the product.
Chapter 2
Example of PLC System Construction by CX-One
This chapter describes an example of PLC System construction from design, online debugging on the actual machine, and start-up/adjustment on-site as shown below.

CX-Programmer is used for ladder program creation and CPU Bus Units and Special I/O Units (SIOU) setting, while CX-Designer is used for indicator screen generation. Also, a program simulation Support Software CX-Simulator is used as a debugging example.

**Example of PLC System Construction by CX-One**

**Workflow in This Chapter**

This chapter describes an example of PLC System construction from design, online debugging on the actual machine, and start-up/adjustment on-site as shown below.

CX-Programmer is used for ladder program creation and CPU Bus Units and Special I/O Units (SIOU) setting, while CX-Designer is used for indicator screen generation. Also, a program simulation Support Software CX-Simulator is used as a debugging example.

**System Configuration**

<table>
<thead>
<tr>
<th>Unit Name</th>
<th>Model</th>
<th>Specifications</th>
</tr>
</thead>
<tbody>
<tr>
<td>Power Unit</td>
<td>CJ1W-PA202</td>
<td></td>
</tr>
<tr>
<td>CPU Unit</td>
<td>CJ1M-CPU13</td>
<td>640 points, 20K steps</td>
</tr>
<tr>
<td>DC Input Unit</td>
<td>CJ1W-ID211</td>
<td></td>
</tr>
<tr>
<td>Transistor Output Unit</td>
<td>CJ1W-OC211</td>
<td></td>
</tr>
<tr>
<td>Analog Input Unit</td>
<td>CJ1W-AD081-V1</td>
<td>4 analog inputs (Each point selectable from 1<del>5V, 0</del>10V, -10<del>10V, 4</del>20mA)</td>
</tr>
<tr>
<td>Position Control Unit</td>
<td>CJ1W-NCF71</td>
<td></td>
</tr>
<tr>
<td>Motion Control Unit</td>
<td>CJ1W-MCH71</td>
<td></td>
</tr>
<tr>
<td>DeviceNet Master Unit</td>
<td>CJ1W-DRM21</td>
<td>Maximum control: 16 axis</td>
</tr>
<tr>
<td>ControllerLink Unit</td>
<td>CJ1W-CLK21</td>
<td></td>
</tr>
<tr>
<td>Serial Communications Unit</td>
<td>CJ1W-SCU41-V1</td>
<td></td>
</tr>
<tr>
<td>Servo Driver</td>
<td>R86D-WN01L-ML2</td>
<td>8 inches TFT</td>
</tr>
</tbody>
</table>

Below is an example of a System that has CJ1M CPU Unit with basic input/output Unit as well as analog input Unit and NCF Unit to perform the following functions:

- 4~20mA input from a sensor
- Configure a servo driver connected to the NFC Unit.
Starting CX-Programmer

From the [Start] menu, select [Programs] > [OMRON] > [CX-One] > [CX-Programmer] > [CX-Programmer] to start CX-Programmer. (Or select [All Programs] > [OMRON] > [CX-One] > [CX-Programmer] > [CX-Programmer])

Creating a New Project

Click [File] > [New]

Click [Projects] and select PLC model.

Left-click [Settings] and select CPU type.

Select a PLC model from the following to use Function Blocks.
CS1G-H, CS1H-H, CJ1G-H, CJ1H-H, CJ1M

Dedicated Support Software for each Unit can be started, succeeding communications settings from CX-Programmer. You will not have to set up communications using dedicated Support Software if you set up communications here.
Creating Unit Configuration

Start the I/O Table/Unit setup function.

Right-click Empty Slot, select [Add Unit] and determine CPU type.

Then select [General Purpose Analog I/O] from Unit selection window.

When you select [Option] > [Consumption(mA)] from the menu, you can check the width and current consumption after PLC Unit configuration. (Width indication is available only for SYSMAC CJ1)

Double-click [I/O Table and Unit Setup].

Right-click Empty Slot, select [Add Unit] and determine CPU type.

Then select [General Purpose Analog I/O] from Unit selection window.
Click Enter Unit number.
Select Unit and Number.
Select Unit Type.
Click Design
Click OK
Click OK
Double-click the analog Unit

The Analog Unit is registered to the I/O Table as shown below. Set up the next analog Unit’s parameter.

The Analog Unit Setup Screen is displayed.

CPU Bus Units and Special I/O Units Setting Function
Traditionally, initial CPU Bus Unit and Special I/O Unit settings were made by referring to documentation to calculate DM address from the Unit number and entering a hexadecimal number. Now you can set it using the pull-down menu in the CX-Programmer’s I/O Table. Easy setup/transfer/verification operations are available from the integrated parameter settings screen as shown below, without recognizing addresses (this function uses CPS function of CX-One previously described).

Setting CPU Bus Units and Special I/O Units
For example, specify input number designation and range.

Select [Enable] for input No.1 usage designation.

Select [1~5V/4~20mA] for input No.1 range setting.

Click the [OK] button.
Right-click NCF Unit

Point [Start Special Application]

Click [Start with Settings Inherited]

Double-click NCF Unit

Click

Click

Displayed with NCF Unit registered.

Select OMRON W series (with communications function).

Select R88D-WN01L-ML2.

When opening a stored project file after starting the dedicated tool, select [Start Only]. If [Start with Setting Inherited] is selected, a new project is created.
Double-click NCF Unit

Edit NCF Unit parameters.

Set output relay area to CIO100 and input relay area to CIO500.

Select [Axis 01].

Set axis parameters for axis 01.

Click OK

Double-click the servo driver

Edit servo parameters.

Set servo parameters for axis 01 as shown below.
- Pn50A (input signal selection 1): 2881
- Pn50B (input signal selection 2): 8883
- Pn511 (input signal selection 5): 6541

Click OK

Save the project

Refer to Page 2-13 "Saving Project" for details.
Using the MCH Unit

When using the MCH Unit (CJ1W-MCH71) instead of the NCF Unit, use the following settings.

As with Analog Unit, register the MC Unit to the I/O table.
The MCH resides within the Motion Controller.
Then start CX-Motion-MCH using [Start with Settings Inherited].

When opening a stored project file after starting the dedicated tool, select [Start Only].
If [Start with Setting Inherited] is selected, a new project is created.

Right-click MCH Unit

Select [Start Special Application]

Select [Start with Setting Inherited]

Add task, axis, program, and CAM data

Edit position data, parameters, program, and CAM data

Save the project

Start the MCH Unit as registered.

Click to add task, axis, program, and CAM data.

Open the editing screen to edit data by double-clicking position data, parameter, program, or CAM data on the project tree.

Click and save the project to file.
Checking I/O Assignment

As with Analog Unit registration, register the IN and OUT Units.

In this example, CJ1W-ID211 and CJ1W-OD211 are selected as IN and OUT Units respectively.

By registering Units to the I/O Table, you can check I/O assignment status.

In addition, you can check addresses assigned to actual I/O with a print out.

This I/O assignment information can also be checked by IQ indication (IN:I, OUT:Q) during ladder programming.
This section describes programming with Library (OMRON Standard Libraries) that allows easier connection to OMRON’s Components. OMRON Standard Libraries is a group of Components provided by OMRON, which can be categorized into two types; FB Components (OMRON FB Library) to be used for a ladder program and SAP Components (Smart Active Parts Library) to be used for an indicator.

**NCF Unit Programming with OMRON FB Library**

Servo motor (axis 1) connected to Unit number 0 NCF is moved to position 2000 (command Unit) with speed of 2000 (command Unit/s) by relative move command.

Right-click from Function Blocks

Select a folder from [Omronlib] > [Position Controller] > [NCF]

Select OMRON FB Library "_NCF021_MoveRelative_DINT11.cxf"

Paste the selected OMRON FB Library on the ladder, then enter its name (instance name) (in this example, "MoveRelative"). Then create a ladder program as shown below.

OMRON FB Library is a collection of Components that OMRON provides as a Function Block to use functions of OMRON’s Units for PLC and FA Components much easier on a PLC program. * For details, see FB Introduction Guide, Chapter 1.
How to use Smart Active Parts

This section describes how to use Smart Active Parts. In this example, NCF Smart Active Parts “Adjust Operation” is used.

From [Start] menu, select [Programs] > [OMRON] > [CX-One] > [CX-Designer] > [CX-Designer Ver.1.0] to start CX-Designer. (Or select [All Programs] > [OMRON] > [CX-One] > [CX-Designer] > [CX-Designer Ver.1.0].) Select [NS8-TV0[]-V1] and [System Version 6.0] or later.

1. Select SmartActiveParts_E - Motion - NCF - OutCIO_InCIO folder
2. Select _NCF001_xx_Adjust Operation (Check the Title)
3. Drag & drop it on the screen.
4. The selected Smart Active Parts are displayed on the screen.

Refer to Page 2-13 “Saving Project” for details.
This section describes how to debug a program using CX-Simulator, a ladder simulation tool, without the PLC. Additionally, Switch Box Utility is used as a virtual input tool.

### Offline Debug

1. Click the Simulator connection button.
2. Select [Tools] > [SwitchBox Utility].
3. Starting Switch Box Utility.
4. Select and run PLC.
5. Design Screen when online.
6. CX-Simulator debug console starts.
7. Program transfer starts.
8. Switch Box Utility.

It is useful not only for virtual input by simulator but also for debugging while checking the PLC’s wiring or setting the DM and other initial values.
Saving a Project

Unit setting, Unit parameter setting, and programs using the CX-Programmer can be saved all at once.

From the [File] menu, select [Save As…]

Save it with a name. In this example save as “Sample1”.

Created data can be saved for CX-Designer and CX-Motion-NCF/MCH.
Save CX-Motion-NCF as “Sample2.mnf” (CX-Motion-MCH as “Sample5.mnh”), and CX-Designer as “Sample3.ipp”.

If you run a dedicated Support Software such as CX-Motion-NCF or CX-Designer when CX-Programmer is started, the same default folder location as that of CX-Programmer is used for reading and saving files. It allows easier CX-One Support Software file management.
This section describes connection to the machine, transfer of programs, creating Unit settings offline, and how to debug.

**Reading a Project**

Use CX-Programmer to read the project “Sample1” saved in the previous section.

Ladder program “Sample1” is retrieved.

In I/O Table Unit setting function, the Unit parameter setting configured in the previous section is also retrieved.
Verify that PLC model and communications setting created offline and the actual PLC are correct.

Double-click PLC

Check PLC model.

Check communications setting.

Confirm that automatic communication speed recognition is checked.

If a connection cannot be established with the PLC, you can use the automatic online connection function. Save your current project data before using this function because it clears project data being edited. When USB conversion cable (CS1W-CIF31) is used for connection, specify the COM port number of the USB port used.

Serial Port Selection Check: [PLC] > [Automatic online connection] > [Serial Port Selection]
Transferring to the Machine

Transfer programs and Unit setting parameters created by offline project to the PLC. In this example, data is sent at the same time to various Units using the batch transfer function. Data to be sent:

- CPU Unit: Ladder program and PLC System setting data, I/O Table data
- CPU Bus Units and Special I/O Units:
  - AD Unit: Range setting of inputs (1~5v / 4~20mA mode)

Program and configuration data are transferred at the same time to CPU Bus Units and Special I/O Units.

Select [PLC] > [Transfer] > [To PLC]

Click [Transfer All]

Program transfer starts.

Click [Yes].

Click [OK].

Next Page

Online Debug on a Machine
Reading a Project
Online Connection to PLC
Transferring to a Machine
Program Debug
Then data is sent at the same time to NCF Unit and the servo driver connected to NCF Unit.

[Data to be sent]
NCF Unit: Common parameters, axis parameters
Servo Driver: Servo parameters

From CX-Programmer, display the I/O Table, then start CX-Motion-NCF by [Start Only].

Right-click NCF Unit
Point [Start Special Application]
Click [Start Only]

Open a saved project and transfer all NCF Unit and servo driver parameters.

Click
Select “Sample2.mnf”
Click
Double-click NCF Unit

To prevent a servo driver operation using a ladder program, you must set the PLC to PROGRAM mode.

Click
If it does not go online, click and check the communications setting between the personal computer and PLC.

Double-click NCF Unit.
Next, perform jog operation. Carefully read the displayed cautions, then perform the operation. To perform jog operation, it is required to establish a connection, servo lock, and jog setting.

When parameter transfer is completed, confirm that communications is performed normally and has not resulted in an error. Monitor the NCF Unit. Confirm consistent scan list (axis configuration) and communications status and that no axis or common Unit error has resulted.

The Unit restart confirmation screen will be displayed during data transfer. Click the [OK] button after confirming safety. Also, in the case of communication was not established between the NCF Unit and the servo driver, confirm the axis number and restore power to the NCF Unit and servo driver.

Click [Online] > [Test Run]
When using the MCH Unit, transfer data from the CX-Motion-MCH to the MCH Unit and servo driver connected to the MCH Unit.

- **Data to be transferred**
  - MCH Unit: parameter, position data, program, CAM data.
  - Servo driver: servo parameter

Display the I/O table from CX-Programmer and start CX-Motion-MCH with [Start Only]. (Refer to NCF Unit for starting from the I/O table.)

Open the saved project and transfer Unit parameter, position data, program, CAM data, and servo driver parameters to the MCH Unit.

**To prevent a servo driver operation using a ladder program, you must set the PLC to PROGRAM mode.**

If it does not go online, double-click PLC in the project tree and check the communication settings between the personal computer and PLC.

The Unit restart confirmation screen will be displayed during data transfer. Click the [OK] button after confirming safety. Also, in the case of communication was not established between the MCH Unit and the servo driver, confirm the axis number and restore power to the MCH Unit and servo driver.
Transferring NS screen data

This section describes how to transfer screen data to the NS through PLC without changing cables.

From [Start] menu, select [Programs] > [OMRON] > [CX-One] > [CX-Designer] > [CX-Designer Ver.1.0] to start CX-Designer. (Or select [All Programs] > [OMRON] > [CX-One] > [CX-Designer] > [CX-Designer Ver.1.0].) Open a project saved in the previous section.

Select [Transfer]-[Transfer[To PT…]] from the [PT] menu.

*Communication between the NS and the PLC must be established before transferring screen data through PLC without changing cables. If “Connecting…” is displayed at the right bottom of the screen, use Auto Connection (See Chapter 3 1-3 “Setup NT Link”) to connect the NS and the PLC before starting the following procedure.

If the communication between the NS and the PLC has already been established, you do not need to perform the operation described above.

Setup communication route

Check “Pass thru PLC” in the Comm. Method window

Select Serial(Toolbus)

Select NT Link

Transfer screen data

Click on Setting

Start NS transfer program

Click on Setting

Check “Pass thru PLC” to activate the “PC → PLC → NS” route setting.

Select PC – PLC – NS.

Press each setting button.

Set the serial port COM No. for PC → PLC connection. Then, press OK.

Enter NS Unit No. Then, press OK.

Screen data transfer is complete at 100%.
Frame color changes to a specified color during Function Block execution.

Current parameter value is displayed.

Monitor ON/OFF status of contacts and coils.

Make sure that there aren’t any problems if the PLC is started. Do you wish to switch the PLC into Monitor mode?

Click [Yes]
Monitoring - Changing the Current Parameter Value

Change the current value of contact or channel through conductive monitoring.

Move the cursor to D100 of input parameters.

Right-click, then select [Set/Reset (S)] > [Value (V)] from the pull-down menu.

Or
Double-click.

Ensure to add "#" (hexadecimal/BCD) or "&" (decimal) to the left of the value.

Change current value of the input parameter.

Click.
Select [Program] > [Online Edit] > [Start]

Enter the contact number you want to modify (W20.01 in a circuit example).

Select [Program] > [Online Edit] > [Transfer Change]

Shortcut [Ctrl]+[Shift]+[E]
Verifying Program

After modification on-site, you can verify it with the designed program and display the differences graphically. This allows for easier checking of the parts modified on-site.

1. Read the designed program. In this example, read “Sample1”. Then connect online.

   Select [PLC] > [Transfer] > [Compare with PLC]

2. Select verification.

   Click [OK]

3. Display the verification result.

   Click [Section (1)] > [Mnemonic View]

   You can check ladder contact address differences.

   In addition, you can check add, delete, and move contacts, coils, and apply instructions.

   You can check FB parameter differences.
Start-Up / Adjustment On-site

Program Modification

Unit Parameter Change

**Unit Parameter Change and Verification**

After modification on-site, you can verify it with the designed Unit parameter and display the differences graphically. This allows for easier checking of the parts modified on-site.

1. Read the designed program. In this example, read “Sample1”. Then connect online. (If you have already read it in the previous section’s operation, this is not required)

Open the I/O Table/ Unit setting, then double-click the AD Unit.

2. Click the [Compare] button. Now you can see the difference between the designed Unit parameters and the configured parameters in the machine.

3. Unmatched detail differences can also be checked.

You have now completed Chapter 2: Example of PLC System Construction by CX-One. The next chapter describes PLC network construction flow.
Chapter 3
Example of PLC Network System Construction by CX-One
Example of PLC Network System Construction by CX-One

Workflow in This Chapter
This chapter describes an example of PLC network System construction from start-up to reassembly and on-site adjustment as shown below.
This chapter mainly describes how to start up the System using CX-Integrator, an integrated start-up Support Software for various PLC networks.

Start-Up
- Describes details from assembly and wiring of PLC System to program download for a trial run.
- Target of Start-Up
  Aims at removing the cause of errors from a PLC and to turn off all of red LEDs that indicate errors for any component of the PLC System.
  Saving the entire system configuration after completing start-up is recommended. You can utilize it for system adjustment on-site after delivery to reduce the adjustment period.

Adj. On-site
- Describes details from disassembly of a system for which the trial run, delivery, and reassembly on-site as well as operation check have been completed.
- Target of Adjustment On-site
  1) Confirm that no error will occur in its electrical system in the same system configuration as that before delivery.
  2) Confirm that no discrepancy will be found in Controller Link network settings by connecting to a network on-site.

System Configuration
1. From the [Start] menu, select [Programs] > [OMRON] > [CX-One] > [CX-Integrator] > [CX-Integrator] to start CX-Integrator. (Or select [All Programs] > [OMRON] > [CX-One] > [CX-Integrator] > [CX-Integrator])

CX-Integrator starts and automatically connects online.

Select a serial port. When USB conversion cable (CS1W-CIF31) is used for connection, specify the COM port number of the USB port used.

All communications Units and ports of a connected PLC are automatically displayed in the online connection information window.
Move the cursor on the PLC and right-click
Select [Error Log]

(1) Remove the cause of the PLC error, then make it available to run.

(2) Check the PLC error.
Examples of IO settings error and CPU Bus Units and Special I/O Units number overlap error are shown below.

(3) Solve the cause of error.
You must solve the problem through the following procedure:
- Set the PLC to PROGRAM mode (in which you can change settings).
- Change the rotary switch of the CPU Bus Units and Special I/O Units (make sure that it does not overlap).
- Create the I/O Table.

Set the PLC to PROGRAM mode.
From step (1) above, select [Mode Setting] then [Program] mode, and click the [Set] button.
• To change the Unit number, change the rotary switch of CPU Bus Units and Special I/O Units and restart power.

• Check if any error occurs in the PLC (CPU Bus Units and Special I/O Units number overlap error should be solved).

• Create the I/O Table.

• Check if any error occurs in the PLC (all errors should be solved).
Confirming the Routing Table is not Configured

(1) Check that Routing Table is not configured.

Check Routing Table presence. If the Routing Table is not configured, create one.

(2) Configure the Routing Table.

Move the cursor on the PLC and right-click
Select [Start Routing Table]

Right-click and select local network (Unit) [Insert CPU SIOU] or local network (port) [Insert PORT]
Enter its local network number, then click [OK]

(3) Edit the Routing Table and transfer to [PLC]

Set the Routing Table as shown below:
- Assign a network number to a Unit number.
- A Unit number can be checked on the online information window.
- Assign a network number to each network.
- The Controller Link network number is same for other PLCs.

(4) Check if the error is solved.
- Re-connect to the PLC.
- All errors should be solved and no error messages should be displayed.
- The network number is displayed on the communications Unit.
DeviceNet Start-Up

Remove DeviceNet communications errors and establish communications.
⇒ Check DeviceNet Unit’s 7SEG indication and ON state of MS/NS LED.
⇒ Check Slave Unit configuration through CX-Integrator.
Create a scan list of DeviceNet and determine the memory map.

(1) Connect to PLC online, then connect to DeviceNet through the online connection information window.

(2) Next, upload the network configuration information of DeviceNet.

In this example, although one Master Unit (node number #01) and two Slave Units (node number #02, #03) are actually connected, assume in this start-up example that one Slave Unit (#03) is not connected due to disconnection.

(3) After transfer is confirmed, connected devices on the current DeviceNet network are displayed as shown below.

Check if a Slave device on the remote I/O communications actually wired is recognized. Master Unit (#01) and Slave Unit (#02) are recognized, while another Slave Unit (03) is not recognized.
Right-click on the Master Unit icon and select [Monitor] to display the device monitor screen. Select [Status] tab.

(4) Check the error on the device monitor screen.

You can check the Slave status on the device monitor screen as well.

Slave Status
00 01 02 03 04 05

Slave Unit (#02) is recognized, while the other Slave Unit (03) is not recognized.

(5) Wire Slave Unit (#03) correctly.

(6) Re-upload the network configuration information of DeviceNet.

Now it can be confirmed that Slave devices on the remote I/O communications have been recognized and communications have been established.

(7) Configure DeviceNet remote I/O communications (free assignment) and register the Slave to the Master.

Double-click a Master Unit (CJ1W-DRM21) icon

Click twice

Click the [OK] button

Right-click the Master Unit and select [Parameters] > [Edit]

Edit the parameters, then click the [OK] button

Select [Network] > [Transfer [PC to Network]]

(8) Configure assignment of Slaves to areas of a CPU Unit.

If necessary, configure the Slave parameters as well.

<Master Unit parameter edit dialog box>

(9) Start remote I/O communication.

Two Slaves are now registered to the Master.
**NT Link Start-Up**

Remove NT Link communication errors and establish communications.
⇒ Release NS Connecting . . . message.
⇒ Check NS configuration through CX-Integrator.

1. Connect to PLC online, then connect to a CPU Unit through the online connection information window.

   ![Connect to PLC online](image)

   Right-click a CPU Unit under a connection target PLC in the online connection information window, then select [Connect].

2. Select in the order from upper link port to NT link.

   ![Select link port](image)

3. Next, select [NT Link Tool] > [NTLink Auto Online Setting] from the CPU Unit.

   ![Select NT Link Tool](image)

Automatic NT Link connection function is used to automatically connect NS series PT and PLC via serial connection (NT Link). Connection is automatically performed by overwriting the PLC serial communication port settings by adjusting to NS series PT settings.
Click [OK]

(4) Check the CPU DIP switch.
   • Follow the on screen instructions to change the DIP switch.

Click [OK]

(5) Screen message Connecting . . . is now cleared.

Select [Transfer [Network to PC]]

(6) Next, upload the network configuration information of NT Link.

Click [Yes]

(7) After the transfer is confirmed, connected devices on the current NT Link network are displayed as shown below.
Controller Link Start-Up

Remove Controller Link communications errors and establish communications.
⇒ ON state of Controller Link Master Unit’s INS LED
⇒ Check Controller Link configuration through CX-Integrator.

(1) Connect to PLC online, then connect to Controller Link Unit through the online connection information window.

(2) Next, upload the Controller Link network configuration information.

Click [Transfer]
In this example, although three PLCs are actually connected through the Controller Link, in this start-up example explanation assume that only two PLCs are displayed.
(One PLC did not join the communications due to incorrect Routing Table settings)

(3) After the transfer is confirmed, connected devices on the current Controller Link network are displayed as shown below.

(4) Check the Routing Table and configure it correctly.
See “Confirming the Routing Table is not Configured” for configuration details.

(5) Re-upload the Controller Link network configuration information.

(6) Send the network configuration from the network to the personal computer.
This example explains the start-up of a serial communications Unit with two temperature controllers (E5CN) connected via CompoWay/F.

- Two temperature controllers (E5CN) are connected to serial communications Unit (CS1W-SCU41-V1) port no. 1 via RS485. Communication Unit numbers are #001 and #002.
- Communication settings of the serial communications Unit and the two temperature controllers are unmatched.
- Communication settings between the two temperature controllers are unmatched as well.

CompoWay/F Start-Up

Remove CompoWay/F communications errors and establish communications.

⇒ Check CompoWay/F configuration through CX-Integrator.
⇒ Configure serial communications Unit parameters.
⇒ Configure temperature controller communications.

(1) Connect to PLC online, then connect to a CPU Unit through the online connection information window.

Right-click an SCU port in the online connection information window, then select [Connect]

Select SCU port (140)

Select CompoWay/F

Right-click an SCU port in the online connection information window, then select [Transfer [Network to PC]]

Click

Select [Selection], enter 1 for minimum and 2 for maximum values, then click the [OK] button

(2) Upload the CompoWay/F network configuration information.

Select SCU port (140), PORT1

Select the item from the following list

Click

Click [Yes] in the message dialog box

Select finding node range

Yes

Click

Click [OK]
Click [OK]

Then click the [OK] button in the dialog box indicating completion of transmission.

Place the cursor on CJ1M-CPU in the [Network Structure] window and double-click.

From the menu, select [Component | Mode Setting] to display the [PLC Mode Setting] dialog box.
(1) Select [Program] for operation mode
(2) Click [Set]
(3) Click [Close] after changing

From the [Display Parameter] pull-down menu, select [Port1: Serial Gateway Settings].

Configure [Port1: Port settings] to [Manual] and [Port1: Serial communications mode] to [Serial Gateway]. Check other settings as well, and change if necessary.

Click the reset button to enable settings. Click [OK] in the reset confirmation message dialog box.

Click [OK] in the transmission confirmation message dialog box.

Select [HOSTLINK1] and click [OK] button.

Confirm that settings are correct, then select the [Transfer [PC to Unit]] button. Click [OK] in the transmission confirmation message dialog box.

Only the Units for which connection is established are displayed in the [Network Structure] window, as shown on the next page.
The [Network Structure] window shows only the Units for which connection is established, and Units with incorrect communications setting are not displayed.

Check the temperature controller that is not displayed properly and configure it correctly.

Check the settings of the temperature controller that is not displayed in the [Network Structure] window (baud rate, data length, stop bit, parity, Unit number), configure it correctly, then re-upload (Perform step (2) from two pages ago). The [Network Structure] window is updated.

Now the correctly configured Unit is displayed and you can confirm that communications settings are correct.

Move the cursor on E5CN of communications Unit number #002, then select [Start Special Application] > [Start with Setting Inherited].

Dedicated Support Software CX-Thermo is started with the same model and setting as that of the temperature controller. After parameter settings are finished, download the settings to the E5CN of communications Unit number #002.
Save the system configuration for inspection after delivery.

1) Connect online to a PLC on a network.
The online connection information window is displayed.

Move the cursor on the DeviceNet and right-click.
Select [Connect]
Select [Transfer [Network to PC]]

Select [Serial Port] > [NT Link]

(2) Send the network Structure of DeviceNet to the personal computer.
Connect to DeviceNet from the online connection information window. After connection is established, send the network Structure of DeviceNet to the personal computer.

(3) Send the network configuration of NT Link to the personal computer.
Select the connection menu on the CPU port, then select upper link port and NT Link. Next, select the transmission menu on the CPU port.

(4) Send the Controller Link network configuration to the personal computer.
Connect to the Controller Link network. After connection is established, send the network configuration to the personal computer.
Select the [Change connection to this PLC] option.

(5) Connect to a PLC on the Controller Link network.
Select a remote PLC on the Controller Link network configuration screen (a PLC without a square symbol) to switch the connection destination to the PLC.
Destination PLC communication device configuration is displayed in the online connection information window.

A Green frame is displayed on the specified remote PLC.

All communications Units and ports are also displayed in the online connection information window.

Select the [Connect] option.

(6) Send the DeviceNet network configuration on the remote PLC.
Connect to DeviceNet from the online connection information window and send the network configuration to the personal computer.

Select the [Transfer [Network to PC]] option.

(7) Send the DeviceNet network configuration on another remote PLC.
Repeat the steps from (6) and (7). After transmission, all the networks sent to the workspace are displayed.

Select the [Save As…] option.

(8) Save all the configurations.
System Configuration Verification (1)

Confirm that the System has the same wiring and settings as before disassembly.
⇒ CX-Integrator verification is complete.

(1) Connect online to a PLC on a network.
The online connection information window is displayed.

All communications Units and ports of a connected PLC are automatically displayed in the online connection information window.

(2) Verify the DeviceNet network configuration.
Connect to a target DeviceNet from the workspace and verify the network Structure.

(3) Any error found in the configuration verification will be displayed in the verification result dialog box.
If you find a Slave that is not on the network, you may have incorrect wiring in the network.

(4) After solving the error, verify the configuration again.
A message is displayed indicating verification matching and now it can be confirmed that the configuration is the same as that before disassembly.
System Configuration Verification (2)

(5) Verify the NT Link network.
Connect to the NT Link from the workspace and verify the network configuration.
Confirm that the same verification matching message is displayed as in step (4).

(6) Verify the Controller Link network.
Connect to DeviceNet from the online connection information window and verify the network Structure.
Confirm that the same verification matching message is displayed as in step (4).

(7) Connect to a PLC on the Controller Link network.
Connect to a remote PLC using the same procedure as the step (5) for saving a System configuration.
Use steps from (2) to (4) to verify the DeviceNet network.

(8) Verify the DeviceNet configuration on another remote PLC.
Use the same procedure as step (2) for Network “N4” to verify the network Structure.
Controller Link Diagnosis

Confirm that the Controller Link connection is correct with an upper level System.
⇒ Diagnosis result check OK

(1) Connect to PLC online, then connect to Controller Link Unit through the online connection information window.

Right-click a DeviceNet Unit under Target Device in the online connection information window, then select [Connect]

(2) Next, select the Controller Link network tool.

NT Link Tool
Controller Unit Tool

Start Data Link
Start Editing Table

Controller Link Tool
Network Diagnosis
Right-click on 3G3MV-PDRT2 and select [Start Special Application].

Select [Start with Setting Inherited].

DeviceNet Connection

RS232C Connection

Starting CX-Drive via DeviceNet

Setup Drives on DeviceNet and start CX-Drive on CX-Integrator window. An example of 3G3MV-PDRT2 is shown below.

When opening a stored data file after starting the dedicated tool, select [Start Only]. If [Start with Setting Inherited] is selected, new data is created.

Select Settings to set detailed Inverter specifications.

CX-Drive starts and Inverter property settings are shown.

Save data

If more than one drive setting data is edited, drive data is saved by drive type and a total overview is saved in a work file.

Click and save the data.
From the [Start] menu, select [Programs] > [OMRON] > [CX-One] > [CX-Drive] > [CX-Drive] to start CX-Drive when you connect Servo or Inverter with serial connection to your computer.

Connecting a Servo or Inverter to a Personal Computer Serially.

Select [File] > [New] to create new data if the drive specifications are known. If the drive is already connected, select [File] > [Autodetect] to detect the model and specification of this connected drive.

To execute Autodetect, select [Settings] and define the search conditions.

Select [Settings] and save the data.
Appendix
1. Personal Computer Requirements

<table>
<thead>
<tr>
<th>Item</th>
<th>System Requirements (Note 1)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Operating System (OS)</td>
<td>Microsoft® Windows® 98SE</td>
</tr>
<tr>
<td>(Note 1) Japanese or English version</td>
<td>Microsoft® Windows® NT (Service Pack 6a)</td>
</tr>
<tr>
<td></td>
<td>Microsoft® Windows® 2000 (Service Pack 3 or higher)/Windows® Me</td>
</tr>
<tr>
<td></td>
<td>Microsoft® Windows® XP</td>
</tr>
<tr>
<td>Main Unit</td>
<td>DOS/V (IBM AT compatible) computer with a Pentium II 333 MHz processor or higher. Pentium III 1GHz or higher is recommended.</td>
</tr>
<tr>
<td>Memory</td>
<td>256MB or higher required. 512MB or higher is recommended. (Note 2)</td>
</tr>
<tr>
<td>Hard drive</td>
<td>To install entire CX-One, about 1.8GB or more free space is required.</td>
</tr>
<tr>
<td>Display</td>
<td>High quality display with SVGA (800 x 600) or higher and 256 colors or more. CX-Process requires XGA or higher quality display.</td>
</tr>
<tr>
<td>Optical drive</td>
<td>CD-ROM drive</td>
</tr>
<tr>
<td>Communication port</td>
<td>At least 1 RS-232C port (Note 3)</td>
</tr>
<tr>
<td>Others</td>
<td>For online user registration via the Internet, you need appropriate hardware such as modem and Internet access rights.</td>
</tr>
</tbody>
</table>

(Note 1):
About operating System for CX-One:
This product does not run on Microsoft Windows95 or other OS versions other than the specified System requirements.
If you have such an Operating System on a client computer, you must upgrade the Operating System before installing this product.
Note that the required System and hard drive capacity depend on the System environment.

(Note 2):
The required memory depends on the CX-One Support Software. See the User’s manual for details.

(Note 3):
An RS-232C port is required for connection with a PLC using CX-One Support Software. If you only have USB on your personal computer, use a USB-RS-232C conversion cable (CS1W-CIF31).
## 2. List of Software to be Installed

CX-One Support Software installed with CX-One is shown below.

<table>
<thead>
<tr>
<th>Software</th>
<th>Description</th>
<th>Required free space on hard drive</th>
<th>Remarks</th>
</tr>
</thead>
<tbody>
<tr>
<td>CX-Programmer</td>
<td>Software to create and debug programs for SYSMAC CS/CJ series, C series, or CV1/C series.</td>
<td>ca. 200MB</td>
<td>If necessary</td>
</tr>
<tr>
<td>CX-Integrator</td>
<td>Software to start up and configure FA networks such as Controller Link, DeviceNet, and CompoWay/F.</td>
<td>ca. 210MB</td>
<td></td>
</tr>
<tr>
<td>CX-Position</td>
<td>Software to create and monitor various data for SYSMAC CS/CJ series NC Unit.</td>
<td>ca. 20MB</td>
<td></td>
</tr>
<tr>
<td>CX-Motion</td>
<td>Software to create various data for MC Unit of SYSMAC CS/CJ series, alpha series, and CV series and to create and monitor MC programs.</td>
<td>ca. 45MB</td>
<td></td>
</tr>
<tr>
<td>CX-Motion-NCF</td>
<td>Software to create and monitor various data for SYSMAC CS/CJ series NCF Unit.</td>
<td>ca. 100MB</td>
<td></td>
</tr>
<tr>
<td>CX-Motion-MCH</td>
<td>Software to create various data, motion programs and monitor the SYSMAC CS/CJ series MCH Unit.</td>
<td>ca. 60MB</td>
<td></td>
</tr>
<tr>
<td>CX-Drive</td>
<td>Software to configure and adjust various inverter servo data.</td>
<td>ca. 65MB</td>
<td></td>
</tr>
<tr>
<td>CX-Designer</td>
<td>Software to create screen data for programmable terminal NS series.</td>
<td>ca. 660MB</td>
<td></td>
</tr>
<tr>
<td>CX-Process Tool</td>
<td>Software to create and debug instrument block programs for loop control Unit board, process, and loop CPU Unit of SYSMAC CS/CJ series.</td>
<td>ca. 75MB</td>
<td></td>
</tr>
<tr>
<td>Face Plate Auto-Builder for NS</td>
<td>Software to automatically generate NS series project files for monitoring and tuning of a loop controller.</td>
<td>ca. 50MB</td>
<td></td>
</tr>
<tr>
<td>CX-Protocol</td>
<td>Software to create data transmission procedure (protocol) with an external universal device that is connected to a serial communications board/Unit of SYSMAC PLCs.</td>
<td>ca. 20MB</td>
<td></td>
</tr>
<tr>
<td>CX-Profiibus</td>
<td>Software to configure the PROFIBUS Master. (For European market only. Possible to install Windows NT4.0/2000/XP only.)</td>
<td>ca. 30MB</td>
<td></td>
</tr>
<tr>
<td>CX-Simulator</td>
<td>Software to debug programs for SYSMAC CS/CJ series without the CPU Unit by simulating the CPU operation on a personal computer.</td>
<td>ca. 55MB</td>
<td></td>
</tr>
<tr>
<td>CX-Thermo</td>
<td>Software to configure and adjust parameters for devices (Components such as temperature controller). (Possible to install Windows 2000/XP only.)</td>
<td>ca. 45MB</td>
<td></td>
</tr>
<tr>
<td>CX-FLnet</td>
<td>Software to configure and monitor the SYSMAC CS/CJ series FLnet Unit.</td>
<td>ca. 2MB</td>
<td></td>
</tr>
<tr>
<td>Switch Box Utility</td>
<td>Utility software for PLC debugging. Input/output status and current values of address can be monitored and modified easily.</td>
<td>ca. 5MB</td>
<td></td>
</tr>
<tr>
<td>TrajeXia</td>
<td>Software to configure the TrajeXia controller. (For European market only)</td>
<td>ca. 15MB</td>
<td></td>
</tr>
<tr>
<td>CX-Sensor</td>
<td>Software to configure and adjust parameter for sensor devices. (For European market only)</td>
<td>ca. 35MB</td>
<td></td>
</tr>
<tr>
<td>PLC Support Software</td>
<td>A group of Components that are commonly used by software that consists CX-One, such as CX-Programmer and CX-Integrator.</td>
<td>ca.280MB</td>
<td>Always installed</td>
</tr>
<tr>
<td>CX-Server</td>
<td>Middleware required for communications between CX-One Support Software and OMRON’s Components.</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

About 1.8GB of free hard drive space is required on your personal computer to install all CX-One Support Software.
Make sure that sufficient free space is available.
## 3. Comparison of Functions Between Conventional Support Software and CX-One (1/2)

<table>
<thead>
<tr>
<th>Function</th>
<th>Conventional Support Software</th>
<th>CX-One</th>
</tr>
</thead>
<tbody>
<tr>
<td>Handling of CX-Programmer's I/O Table window</td>
<td>Only mounted Unit position information</td>
<td>In addition to traditional functions, the following functions are available:</td>
</tr>
<tr>
<td></td>
<td>● Shows used position:size only (only head address and size of used area in CIO area are displayed)</td>
<td>● Used as a setting terminal of CPU Bus Units and Special I/O Units</td>
</tr>
<tr>
<td></td>
<td>● Assignment DM setting of CPU Bus Units and Special I/O Units is unavailable.</td>
<td>● Used as a terminal to start each Unit's Support Software</td>
</tr>
<tr>
<td>Initial setting of CPU Bus Units and Special I/O Units (assignment DM, assignment relay, CPU Bus Unit System setting)</td>
<td>● Configuring four-digit hexadecimal or other value for each address by referring to assignment DM area on the manual using PLC memory as with universal DM area. (Direct setting in many cases)</td>
<td>● By right-clicking a target Unit on the I/O Table and selecting [Unit Setup], configuration is available of CPU Bus Units and Special I/O Units parameter (mainly allocation DM) setting without referring to a manual in the following dialog box.</td>
</tr>
<tr>
<td></td>
<td>* It is necessary to configure values while checking addresses based on Unit number. And the data are not saved as parameter data for each Unit (only as DM data for a CPU Unit).</td>
<td>* Setting is available using item names without recognizing addresses. Also, data can be saved/read as a parameter setting data file for each Unit.</td>
</tr>
<tr>
<td></td>
<td>● Setup data can be handled in the same way as other I/O memory areas for saving into a CXP project file or as a data file of file memory.</td>
<td>● Setup data can be saved in a parameter setting data file for each Unit, or into a CXP project file for entire Units' parameter settings.</td>
</tr>
<tr>
<td>Network setting</td>
<td>Ethernet network monitor</td>
<td>Ethernet network connection device can be monitored by CX-Integrator.</td>
</tr>
<tr>
<td>Controller Link</td>
<td>Controller Link Unit System Setting for Ethernet Unit</td>
<td>By right-clicking on an Ethernet Unit of the I/O Table and selecting [Unit Setup], Can be saved as a parameter as with other CPU Bus Units and Special I/O Units.</td>
</tr>
<tr>
<td>Controller Link Unit</td>
<td>By right-clicking on a Controller Link Unit of the I/O Table in the online CX-Programmer and selecting [Software Switch Setting].</td>
<td></td>
</tr>
<tr>
<td>Controller Link Data Link (manual or automatic) setting</td>
<td>By CX-Net (Data Link Component) in CX-Programmer.</td>
<td>Trough a Data Link Component by selecting [Tools] &gt; [Start Data Link] from CX-Integrator.</td>
</tr>
<tr>
<td>Controller Link network monitor</td>
<td>No tool for monitoring Controller Link network.</td>
<td>Controller Link network connection device can be monitored by CX-Integrator. Controller Link diagnosis tool can be started as well (By selecting [Tools] &gt; [Controller Link Tool] &gt; [Network Diagnosis] from online CX-Integrator).</td>
</tr>
</tbody>
</table>
### 3. Comparison of Functions between Conventional Support Software and CX-One (2/2)

<table>
<thead>
<tr>
<th>Function</th>
<th>Conventional Support Software</th>
<th>CX-One</th>
</tr>
</thead>
<tbody>
<tr>
<td>Network setting</td>
<td><strong>DeviceNet</strong>&lt;br&gt;Fixed assignment by DeviceNet, or free assignment by assignment DM.</td>
<td>Fixed assignment: No setting tool (by edit on PLC memory).&lt;br&gt;Free assignment: By DeviceNet configurator.</td>
</tr>
<tr>
<td></td>
<td><strong>Free assignment and Slave parameter setting/monitoring by DeviceNet configurator</strong></td>
<td>Fixed assignment: By right-clicking on a DeviceNet Unit of the I/O Table online or offline and selecting [Unit Setup].&lt;br&gt;Free assignment: By right-clicking on a DeviceNet Unit of the I/O Table through online or offline CX-Integrator and selecting [Edit Parameters].</td>
</tr>
<tr>
<td></td>
<td><strong>CompoWay/F</strong>&lt;br&gt;CompoWay/F Slave station parameter setting</td>
<td><strong>Temperature controller</strong>: By right-clicking on a target Unit through online or offline CX-Integrator and selecting [Start Special Application] to start CX-Thermo and edit the setting.&lt;br&gt;Smart sensor: By right-clicking on a target Unit through online or offline CX-Integrator and selecting [Edit Parameters] to edit.</td>
</tr>
<tr>
<td>Routing Table</td>
<td><strong>By CX-Net (Routing Table Component) in CX-Programmer.</strong></td>
<td><strong>By selecting [Tools] &gt; [Start Routing Table] from CX-Integrator to use Routing Table Component.</strong></td>
</tr>
</tbody>
</table>

(Note)<br>I/O Table can be started from CX-Programmer or CX-Integrator on CX-One.