CX-One CD-ROM contains a setup manual PDF file.
The Setup manual of CX-One is stored in the following file.
Disk1: CX-One_Manuals \ English \ CX-One Setup Manual W444-E1-02.pdf

**Before using this product, you must read “Introduction” and “Safety Cautions”.
Cautions and detailed explanation are available on Help and PDF Manual.**

* Acrobat Reader 4.0 or later is required to read the PDF file.
Table of Contents

Chapter 1 Overview and Installation of CX-One
1. What is CX-One? ................................................................. 1-1
2. Features of CX-One ............................................................. 1-1
3. CX-One Component Checklist .................................................. 1-2
4. CX-One Installation Procedure ................................................. 1-3

Chapter 2 Example of PLC System Construction by CX-One
Workflow in This Chapter .......................................................... 2-1
1. Design
   1-1. Starting CX-Programmer .................................................. 2-2
   1-2. Creating Unit Configuration .............................................. 2-3
   1-3. Setting CPU Bus Units and Special I/O Units ......................... 2-5
   1-4. Checking I/O Assignment ................................................... 2-9
   1-5. Programming ................................................................. 2-10
   1-6. Offline Debug ................................................................. 2-12
   1-7. Saving a Project ............................................................... 2-13
2. Online Debug on a Machine
   2-1. Reading a Project ........................................................... 2-14
   2-2. Online Connection to PLC ............................................... 2-15
   2-3. Transferring to a Machine ............................................... 2-16
   2-4. Program Debug ............................................................... 2-21
3. Start-Up / Adjustment On-site
   3-1. Program Modification .................................................... 2-23
   3-2. Unit Parameter Change .................................................... 2-25

Chapter 3 Example of PLC Network System Construction by CX-One
Workflow in This Chapter ......................................................... 3-1
1. PLC Network Start-Up
   1-1. PLC Start-Up ............................................................... 3-2
   1-2. DeviceNet Start-Up ........................................................ 3-6
   1-3. NT Link Start-Up ............................................................ 3-8
   1-4. Controller Link Start-Up ............................................... 3-10
   1-5. CompoWay/F Start-Up ................................................... 3-12
   1-6. Saving System Configuration ............................................ 3-15
2. Adjustment On-site
   2-1. System Configuration Verification ...................................... 3-17
   2-2. Controller Link Diagnosis ............................................... 3-19
3. Servo/Inverter Settings
   3-1. DeviceNet Connection .................................................... 3-20
   3-2. RS232C Connection .......................................................... 3-21

Chapter 4 Appendix
1. Personal Computer Requirements ......................................... 4-1
2. List of Software to be Installed .............................................. 4-2
3. Comparison of Functions Between Conventional Support Software and CX-One ........................................... 4-3
Chapter 1
Overview and Installation of CX-One
1. What is CX-One?

CX-One is an FA Integrated Tool Package that integrates Support Software for OMRON's PLC and other Components.

To construct an FA System based mainly on PLC, traditionally it was necessary to purchase and install individual Support Software compatible with each Unit, start the software individually, and then connect to PLC and individual Components.

Installation of this FA Integrated Tool Package "CX-One" on a personal computer allows integrated operation from setup of OMRON's CPU Bus Units and Special I/O Units (SIOU) and Components to network start-up/monitoring and improving efficiency of PLC System start-up.

2. Features of CX-One

- CX-One allows integrated management of Support Software for OMRON's PLC/Components.
  - Installation on only one personal computer allows a user to handle Support Software for OMRON's products.
  - Only one licensing key is required to install all Support Software.
  - It allows integrated management of one save location for files created by Support Software.

- Support Software dedicated to CPU Bus Units and Special I/O Units can be started on the I/O Table.
  - The appropriate dedicated Support Software can be automatically started by specifying a registered Unit in the I/O Table (Unit configuration table attached to a PLC). In addition, setup information such as PLC model can be passed to the dedicated Support Software at start-up, allowing easier switching between Support Software.

- The following functions are available by the introduction of the ID information file (CPS) for OMRON Components.
  - Setup of CPU Bus Units and Special I/O Units without manual setting and address recognition. (Parameter and selection item names as well as available range of setup are automatically displayed)
  - CPU Bus Units and Special I/O Units setting on personal computer and data on actual PLC (CPU Unit) can be verified online, and unmatched item/readout data is displayed graphically.
  - Unit configuration is displayed on the I/O Table based on Unit model.
  - Device type on the network can be checked for its Unit model, allowing exact verification of network configuration.

What is CPS?

CPS (Component and network Profile Sheet) is definition information of CS/CJ series Unit/Components in CX-One. It is provided as a CPS file (XML format file).

CX-One recognizes CS/CJ series Unit by information in this CPS file. CPU Bus Units and Special I/O Units setting is created based on this CPS file.
3. CX-One Component Checklist

CX-One consists of the following items. Check if they are included in the package.

- **CX-One Components**

<table>
<thead>
<tr>
<th>Item</th>
<th>Print</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Setup Disk (CD-ROM)</td>
<td>3 disks</td>
<td>Printed document and PDF data on CD-ROM</td>
</tr>
<tr>
<td>CX-One Introduction Guide (this document No.R135)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>CX-Programmer Introduction Guide (No.R132)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>CX-Designer Introduction Guide (No.V089)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Function Block Introduction Guide (No.R133)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>CX-One Setup Manual (No.W444)</td>
<td>PDF data on CD-ROM (Only major manuals listed.)</td>
<td></td>
</tr>
<tr>
<td>CX-Programmer Operation Manual (No.W446)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>CX-Programmer Operation Manual, Function Block (No.W447)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>CX-Integrator Operation Manual (No.W445)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>CX-Simulator Operation Manual (No.W366)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>CX-Designer Users Manual (No.V088)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>CX-Motion-NCF Operation Manual (No.W436)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>CX-Motion-MCH Operation Manual (No.W448)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>CX-Position Operation Manual (No.W433)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>CX-Drive Operation Manual (No.W453)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>CX-Protocol Operation Manual (No.W344)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>CX-Process Tool Operation Manual (No.W372)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>CX-Profibus Operation Manual (No.W056)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Face Plate Auto-Builder for NS Operation Manual (No.W418)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>OMRON FB Library Reference Manual (No.W442)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Smart Active Parts Library Reference Manual (*)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>CX-Thermo Operation Manual</td>
<td>Online help only</td>
<td></td>
</tr>
<tr>
<td>Software License Agreement/User Registration Card</td>
<td>1</td>
<td></td>
</tr>
</tbody>
</table>

* PDF Manuals are provided for each Unit.

- **CX-One Software List**

<table>
<thead>
<tr>
<th>Product</th>
<th>Model</th>
<th>Installable peripheral tool</th>
<th>Included data</th>
</tr>
</thead>
<tbody>
<tr>
<td>CX-One</td>
<td>CXONE-AL01C-E (for 1 license)</td>
<td>- CX-Programmer</td>
<td>- OMRON FB</td>
</tr>
<tr>
<td></td>
<td>CXONE-AL03C-E (for 3 licenses)</td>
<td>- CX-Integrator</td>
<td>- Smart Active Parts (SAP)</td>
</tr>
<tr>
<td></td>
<td>CXONE-AL10C-E (for 10 licenses)</td>
<td>- CX-Simulator</td>
<td>- CPS</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- CX-Designer</td>
<td>- Manual (PDF)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- CX-Motion</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>- CX-Motion-NCF</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>- CX-Motion-MCH</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>- CX-Position</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>- CX-Drive</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>- CX-Protocol</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>- CX-Process Tool</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>- CX-Profibus</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>- Face plate Auto-Builder for NS</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>- CX-Thermo</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>- CX-FLnet</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>- Switch Box Utility</td>
<td></td>
</tr>
</tbody>
</table>
4. CX-One Installation Procedure

Before installing the CX-One, you must:
• terminate all Windows programs
• Uninstall previous versions of Support Software (such as CX-Programmer) if already installed.
• Installation takes about 10 to 40 minutes depending on your personal computer. (10 minutes for a personal computer with CPU: Celeron 2.2GHz, main memory: 512MB, and CD-ROM drive: 48x)
• To change/modify/delete CX-One after installation, refer to the PDF manual "CX-One Setup Manual", Chapter 2 "Installation and Uninstallation".

Installing CX-One

Insert CX-One installation disk 1 (CD-ROM) into your personal computer’s CD-ROM drive. [Choose Setup Language] dialog box is displayed. By default the OS language installed on your personal computer is automatically selected. Check if the language is appropriate, then click the [OK] button.

The CX-One splash screen is displayed and CX-One installation starts.

Uninstall older version of tools such as PLC Tools (PLC System setting and I/O Table), CX-Server, and CX-Programmer if they have been installed.

Always click [OK]
CX-One setup wizard starts.

The License Agreement dialog box is displayed. Read the software license agreement carefully. If you agree with all items, select the I accept the terms of the license agreement radio button and click the Next button.

Select the radio button

Click [Next]

The User information dialog box is displayed.

Enter [User], [Company], [License] (product serial number of CX-One)

Click [Next]
Select an installation folder, then click [Next].

Select the radio button [Complete].

Click [Next].

Read the message and click [Next].

The [Installation Folder Selection] dialog box and [Setup Type] dialog box are displayed.

By selecting [Custom], you can individually select and install Support Software from the CD-ROM.

Click [Next].

The [Program Folder Selection], [Choose Destination Location of OMRON FB Library], [Select Program Folder], and [Ready to Install the Program] dialog boxes are displayed.

Click [Install].

CX-One installation is starts.

A dialog box (right) is displayed. Click the [Finish] button to finish the installation wizard. Installation is complete. (When it is necessary to restart the personal computer, a restart confirmation dialog box appears.)

Click [Finish].

Insert CX-One Disks 2 and 3 then click the [OK] button.
Online Registration

If the personal computer that the software has been installed on has an Internet connection, you can proceed to online user registration.

After installation has been completed the [Online Registration] dialog box is displayed.

If you click the [Register] button, your Web browser connects to "OMRON’s CX-One Web site". (*1) (*2)

*1: If you click the [Exit] button to cancel online registration, the [Online Registration] dialog box is displayed every time the CX-One Support Software is started.

*2: If you do not have an Internet connection, or you do not want to register online, fill out and send the user registration card that comes with the product.
Chapter 2
Example of PLC System Construction by CX-One
This chapter describes an example of PLC System construction from design, online debugging on the actual machine, and start-up/adjustment on-site as shown below. CX-Programmer is used for ladder program creation and CPU Bus Units and Special I/O Units (SIOU) setting, while CX-Designer is used for indicator screen generation. Also, a program simulation Support Software CX-Simulator is used as a debugging example.

**Workflow in This Chapter**

This chapter describes an example of PLC System construction from design, online debugging on the actual machine, and start-up/adjustment on-site as shown below. CX-Programmer is used for ladder program creation and CPU Bus Units and Special I/O Units (SIOU) setting, while CX-Designer is used for indicator screen generation. Also, a program simulation Support Software CX-Simulator is used as a debugging example.

**System Configuration**

- **Unit Name** | **Model** | **Specifications**
- Power Unit | CJ1W-PA202 |  
- CPU Unit | CJ1M-CPU13 | 640 points, 20K steps  
- DC Input Unit | CJ1W-ID211 |  
- Transistor Output Unit | CJ1W-OC211 |  
- Analog Input Unit | CJ1W-AD081-V1 | 4 analog inputs (Each point selectable from 1~5V, 0~10V, -10~10V, 4~20mA)  
- Position Control Unit | CJ1W-NCF71 | Maximum control: 16 axis  
- Motion Control Unit | CJ1W-MCH71 | Maximum control: 30 axis  
- DeviceNet Master Unit | CJ1W-DRM21 |  
- Controller Link Unit | CJ1W-CLK21 |  
- Serial Communications Unit | CJ1W-SCU41-V1 |  
- Servo Driver | R88D-WN01L-ML2 |  
- NS Series PT | NS8-TV00B-V1 | 8 inches TFT

Below is an example of a System that has CJ1M CPU Unit with basic input/output Unit as well as analog input Unit and NCF Unit to perform the following functions:
- 4~20mA input from a sensor
- Configure a servo driver connected to the NFC Unit.
Starting CX-Programmer

From the [Start] menu, select [Programs] > [OMRON] > [CX-One] > [CX-Programmer] > [CX-Programmer] to start CX-Programmer. (Or select [All Programs] > [OMRON] > [CX-One] > [CX-Programmer] > [CX-Programmer]).

Creating a New Project

Click this button to create a new CX-Programmer project.

Click and select PLC model.

Select a PLC model from the following to use Function Blocks:
CS1G-H, CS1H-H, CJ1G-H, CJ1H-H, CJ1M

Click [OK] and determine CPU type.

Dedicated Support Software for each Unit can be started, succeeding communications settings from CX-Programmer. You will not have to set up communications using dedicated Support Software if you set up communications here.
Creating Unit Configuration

Start the I/O Table/Unit setup function.

Double-click [I/O Table and Unit Setup].

Right-click Empty Slot, select [Add Unit] and determine CPU type.
Then select [General Purpose Analog I/O] from Unit selection window.

When you select [Option] > [Consumption(mA)] from the menu, you can check the width and current consumption after PLC Unit configuration. (Width indication is available only for SYSMAC CJ1)

Right-click Empty Slot, select [Add Unit] and determine CPU type.
Then select [General Purpose Analog I/O] from Unit selection window.
Click to Enter Unit number.
Select Unit and Number.
Select Unit Type.
Click OK
Click OK
Select Unit Type.
Select Unit and Number.
Double-click the analog Unit

The Analog Unit is registered to the I/O Table as shown below. Set up the next analog Unit’s parameter.

The Analog Unit Setup Screen is displayed.

CPU Bus Units and Special I/O Units Setting Function
Traditionally, initial CPU Bus Unit and Special I/O Unit settings were made by referring to documentation to calculate DM address from the Unit number and entering a hexadecimal number. Now you can set it using the pull-down menu in the CX-Programmer’s I/O Table. Easy setup/transfer/verification operations are available from the integrated parameter settings screen as shown below, without recognizing addresses (this function uses CPS function of CX-One previously described).

Setting CPU Bus Units and Special I/O Units

For example, specify input number designation and range.

Select [Enable] for input No.1 usage designation.

Select [1~5V/4~20mA] for input No.1 range setting.

Click the [OK] button.
NCF Unit and Servo Driver Connected to the NCF Unit Setup

As with Analog Unit registration, register the NCF Unit (CJ1W-NCF71). The NCF Unit resides within a position control Unit. Next, start CX-Motion-NCF using [Start with Settings Inherited].

When opening a stored project file after starting the dedicated tool, select [Start Only]. If [Start with Setting Inherited] is selected, a new project is created.
Double-click NCF Unit

Edit NCF Unit parameters.

Set output relay area to CIO100 and input relay area to CIO500.

Select [Communications Setting]

Click Auto Communications Setting

Select [Axis 01].

Set axis parameters for axis 01.

Click OK

Double-click the servo driver

Edit servo parameters.

Set servo parameters for axis 01 as shown below.
- Pn50A (input signal selection 1): 2881
- Pn50B (input signal selection 2): 8883
- Pn511 (input signal selection 5): 6541

Click OK

Save the project

Refer to Page 2-13 "Saving Project" for details.
Using the MCH Unit

When using the MCH Unit (CJ1W-MCH71) instead of the NCF Unit, use the following settings.

As with Analog Unit, register the MC Unit to the I/O table.
The MCH resides within the Motion Controller.
Then start CX-Motion-MCH using [Start with Settings Inherited].

When opening a stored project file after starting the dedicated tool, select [Start Only].
If [Start with Setting Inherited] is selected, a new project is created.

Right-click MCH Unit

Point [Start Special Application]

Select [Start with Setting Inherited]

Add task, axis, program, and CAM data

Edit position data, parameters, program, and CAM data

Save the project

Start the MCH Unit as registered.

Click to add task, axis, program, and CAM data.

Open the editing screen to edit data by double-clicking position data, parameter, program, or CAM data on the project tree.

Click and save the project to file.
Register basic I/O Unit

As with Analog Unit registration, register the IN and OUT Units.

In this example, CJ1W-ID211 and CJ1W-OD211 are selected as IN and OUT Units respectively.

Checking I/O Assignment

By registering Units to the I/O Table, you can check I/O assignment status.

In addition, you can check addresses assigned to actual I/O with a print out.

This I/O assignment information can also be checked by IQ indication (IN:I, OUT:Q) during ladder programming.
This section describes programming with Library (OMRON Standard Libraries) that allows easier connection to OMRON’s Components. OMRON Standard Libraries is a group of Components provided by OMRON, which can be categorized into two types; FB Components (OMRON FB Library) to be used for a ladder program and SAP Components (Smart Active Parts Library) to be used for an indicator.

- **NCF Unit Programming with OMRON FB Library**
  Servo motor (axis 1) connected to Unit number 0 NCF is moved to position 2000 (command Unit) with speed of 2000 (command Unit/s) by relative move command.

  ![Diagram of NCF Unit Programming with OMRON FB Library]

  Right-click from Function Blocks
  Select a folder from [Omronlib] > [Position Controller] > [NCF]

  Select OMRON FB Library "NCF021_MoveRelative_DINT11.cxf"

  Paste the selected OMRON FB Library on the ladder, then enter its name (instance name) (in this example, "MoveRelative"). Then create a ladder program as shown below.

OMRON FB Library is a collection of Components that OMRON provides as a Function Block to use functions of OMRON’s Units for PLC and FA Components much easier on a PLC program. * For details, see FB Introduction Guide, Chapter 1.
How to use Smart Active Parts

This section describes how to use Smart Active Parts. In this example, NCF Smart Active Parts “Adjust Operation” is used.

From [Start] menu, select [Programs] > [OMRON] > [CX-One] > [CX-Designer] > [CX-Designer Ver.1.0] to start CX-Designer. (Or select [All Programs] > [OMRON] > [CX-One] > [CX-Designer] > [CX-Designer Ver.1.0].) Select [NS8-TV0][V1] and [System Version 6.0] or later.

1. Select SmartActiveParts_E -Motion - NCF - OutCIO_InCIO folder
2. Select _NCF001_xx _Adjust Operation (Check the Title)
3. Drag & drop it on the screen.
4. The selected Smart Active Parts are displayed on the screen.

Setup Smart Active Parts

1. Double-click
2. Set 4 to the Destination Unit No.
3. Click [OK]

Smart Active Parts Setting is complete

Setup is completed at 100%

Save the Project.

Refer to Page 2-13 “Saving Project” for details.

Communication address is automatically calculated according to the corresponding Unit.
This section describes how to debug a program using CX-Simulator, a ladder simulation tool, without the PLC. Additionally, Switch Box Utility is used as a virtual input tool.

Click [OK]

(Screen when online)

CX-Simulator debug console is starts

Starting Switch Box Utility
Select [Tools] > [SwitchBox Utility]

Run PLC

Switch Box Utility
It is useful not only for virtual input by simulator but also for debugging while checking the PLC’s wiring or setting the DM and other initial values.
Saving a Project

Unit setting, Unit parameter setting, and programs using the CX-Programmer can be saved all at once.

From the [File] menu, select [Save As…]

Save it with a name. In this example save as “Sample1”.

Created data can be saved for CX-Designer and CX-Motion-NCF/MCH.
Save CX-Motion-NCF as “Sample2.mnf” (CX-Motion-MCH as “Sample5.mnh”), and CX-Designer as “Sample3.ipp”.

If you run a dedicated Support Software such as CX-Motion-NCF or CX-Designer when CX-Programmer is started, the same default folder location as that of CX-Programmer is used for reading and saving files. It allows easier CX-One Support Software file management.
This section describes connection to the machine, transfer of programs, creating Unit settings offline, and how to debug.

### Reading a Project

Use CX-Programmer to read the project “Sample1” saved in the previous section.

Ladder program “Sample1” is retrieved.

In I/O Table Unit setting function, the Unit parameter setting configured in the previous section is also retrieved.
Online Connection to PLC

Verify that PLC model and communications setting created offline and the actual PLC are correct.

Double-click PLC

Check PLC model. Check communications setting.

Click (Online connection button)

If a connection cannot be established with the PLC, you can use the automatic online connection function. Save your current project data before using this function because it clears project data being edited. When USB conversion cable (CS1W-CIF31) is used for connection, specify the COM port number of the USB port used.

(Automatic online connection button)

Serial Port Selection Check: [PLC] > [Automatic online connection] > [Serial Port Selection]

Confirm that automatic communication speed recognition is checked.
Transferring to the Machine

Transfer programs and Unit setting parameters created by offline project to the PLC. In this example, data is sent at the same time to various Units using the batch transfer function.

[Data to be sent]
- CPU Unit: Ladder program and PLC System setting data, I/O Table data
- CPU Bus Units and Special I/O Units:
  - AD Unit: Range setting of inputs (1~5v / 4~20mA mode)

Program and configuration data are transferred at the same time to CPU Bus Units and Special I/O Units.
Then data is sent at the same time to NCF Unit and the servo driver connected to NCF Unit.

[Data to be sent]
NCF Unit: Common parameters, axis parameters
Servo Driver: Servo parameters

From CX-Programmer, display the I/O Table, then start CX-Motion-NCF by [Start Only].

Open a saved project and transfer all NCF Unit and servo driver parameters.

To prevent a servo driver operation using a ladder program, you must set the PLC to PROGRAM mode.

If it does not go online, click and check the communications setting between the personal computer and PLC.
Next, perform jog operation. Carefully read the displayed cautions, then perform the operation. To perform jog operation, it is required to establish a connection, servo lock, and jog setting.

The Unit restart confirmation screen will be displayed during data transfer. Click the [OK] button after confirming safety. Also, in the case of communication was not established between the NCF Unit and the servo driver, confirm the axis number and restore power to the NCF Unit and servo driver.

When parameter transfer is completed, confirm that communications is performed normally and has not resulted in an error. Monitor the NCF Unit. Confirm consistent scan list (axis configuration) and communications status and that no axis or common Unit error has resulted.

Next, perform jog operation. Carefully read the displayed cautions, then perform the operation.

To perform jog operation, it is required to establish a connection, servo lock, and jog setting.
When using the MCH Unit, transfer data from the CX-Motion-MCH to the MCH Unit and servo driver connected to the MCH Unit.

- **Data to be transferred**
  - MCH Unit: parameter, position data, program, CAM data.
  - Servo driver: servo parameter

Display the I/O table from CX-Programmer and start CX-Motion-MCH with [Start Only]. (Refer to NCF Unit for starting from the I/O table.)

Open the saved project and transfer Unit parameter, position data, program, CAM data, and servo driver parameters to the MCH Unit.

To prevent a servo driver operation using a ladder program, you must set the PLC to PROGRAM mode.

If it does not go online, double-click PLC in the project tree and check the communication settings between the personal computer and PLC.

The Unit restart confirmation screen will be displayed during data transfer. Click the [OK] button after confirming safety. Also, in the case of communication was not established between the MCH Unit and the servo driver, confirm the axis number and restore power to the MCH Unit and servo driver.
Transferring NS screen data

This section describes how to transfer screen data to the NS through PLC without changing cables.

From [Start] menu, select [Programs] > [OMRON] > [CX-One] > [CX-Designer] > [CX-Designer Ver.1.0] to start CX-Designer. (Or select [All Programs] > [OMRON] > [CX-One] > [CX-Designer] > [CX-Designer Ver.1.0].) Open a project saved in the previous section.

Select [Transfer]-[Transfer[To PT…]] from the [PT] menu.

*Communication between the NS and the PLC must be established before transferring screen data through PLC without changing cables.

If “Connecting…” is displayed at the right bottom of the screen, use Auto Connection (See Chapter 3 1-3 “Setup NT Link”) to connect the NS and the PLC before starting the following procedure.

If the communication between the NS and the PLC has already been established, you do not need to perform the operation described above.

Click on Setting in the Comm. Method window.

Check “Pass thru PLC” to activate the “PC → PLC → NS” route setting.

Select PC – PLC – NS.

Set the serial port COM No. for PC → PLC connection. Then, press OK.

Select Serial(Toolbus).

Press each setting button.

Select NT Link.

Enter NS Unit No. Then, press OK.

Setup “Data transfer to the NS through PLC”.

Click OK to start transfer.

Screen data transfer is complete at 100%.
Program Debug

Transfer programs and Unit setting parameters created by an offline project to the PLC. In this example, data is sent at the same time to various Units using the batch transfer function.

Monitoring

Monitor ON/OFF status of contacts and coils.

Frame color changes to a specified color during Function Block execution.

Current parameter value is displayed.

Click [Yes]... ON/OFF of monitoring
Monitoring - Changing the Current Parameter Value

Change the current value of contact or channel through conductive monitoring.

Move the cursor to D100 of input parameters

Right-click, then select [Set/Reset (S)] > [Value (V)] from the pull-down menu

Or

Double-click

Change current value of the input parameter.

Click

Ensure to add "#" (hexadecimal/BCD) or "&" (decimal) to the left of the value.
Select [Program] > [Online Edit] > [Start]

Enter the contact number you want to modify (W20.01 in a circuit example).

Select [Program] > [Online Edit] > [Transfer Change]

Double-click Double-click

Move the cursor on the circuit you want to modify

You can use drag-and-drop to specify more than one circuit at the same time

Move the cursor on the contact you want to modify and double-click

Enter the contact number you want to modify (W20.01 in a circuit example).

Shortcut [Ctrl]+[E]

Shortcut [Ctrl]+[Shift]+[E]
Verifying Program

After modification on-site, you can verify it with the designed program and display the differences graphically. This allows for easier checking of the parts modified on-site.

1. Read the designed program. In this example, read “Sample1”. Then connect online.

2. Select verification.

3. Display the verification result.

You can check ladder contact address differences.

In addition, you can check add, delete, and move contacts, coils, and apply instructions.

You can check FB parameter differences.
Unit Parameter Change and Verification

After modification on-site, you can verify it with the designed Unit parameter and display the differences graphically. This allows for easier checking of the parts modified on-site.

1. Read the designed program. In this example, read “Sample1”. Then connect online. (If you have already read it in the previous section’s operation, this is not required)

Open the I/O Table/ Unit setting, then double-click the AD Unit.

2. Click the [Compare] button.

Now you can see the difference between the designed Unit parameters and the configured parameters in the machine.

3. Unmatched detail differences can also be checked.

Unmatched items are shown in orange.

You can check the number of unmatched items.

You have now completed Chapter 2: Example of PLC System Construction by CX-One. The next chapter describes PLC network construction flow.
Chapter 3
Example of PLC Network System Construction by CX-One
Example of PLC Network System Construction by CX-One

Workflow in This Chapter

This chapter describes an example of PLC network System construction from start-up to reassembly and on-site adjustment as shown below.

This chapter mainly describes how to start up the System using CX-Integrator, an integrated start-up Support Software for various PLC networks.

Start-Up

- Describes details from assembly and wiring of PLC System to program download for a trial run.
- Target of Start-Up
  Aims at removing the cause of errors from a PLC and to turn off all of red LEDs that indicate errors for any component of the PLC System.
- Saving the entire system configuration after completing start-up is recommended. You can utilize it for system adjustment on-site after delivery to reduce the adjustment period.

Adj. On-site

- Describes details from disassembly of a system for which the trial run, delivery, and reassembly on-site as well as operation check have been completed.
- Target of Adjustment On-site
  1) Confirm that no error will occur in its electrical system in the same system configuration as that before delivery.
  2) Confirm that no discrepancy will be found in Controller Link network settings by connecting to a network on-site.

System Configuration

- The Local Network Table is required in order to attach more than one network communications Units.

Controller Link (Wire) Network Address = 1
DeviceNet  Network Address = 4
Use at 125K bits/sec
I/O Relay Terminal

Use at 125K bits/sec
I/O Relay Terminal

Routing Table
System Version 6.0 or later
Note) The Local Network Table is required in order to attach more than one network communications Units.
Select a serial port.
When USB conversion cable (CS1W-CIF31) is used for connection, specify the COM port number of the USB port used.

All communications Units and ports of a connected PLC are automatically displayed in the online connection information window.
Checking PLC Error

1) Remove the cause of the PLC error, then make it available to run.

Select [Error Log]

(2) Check the PLC error.
Examples of IO settings error and CPU Bus Units and Special I/O Units number overlap error are shown below.

You can check an error in a CPU Unit and error history.
(You can use the same function in the error history of CX-Programmer's online screen)

(3) Solve the cause of error.

You must solve the problem through the following procedure:
- Set the PLC to PROGRAM mode (in which you can change settings).
- Change the rotary switch of the CPU Bus Units and Special I/O Units (make sure that it does not overlap).
- Create the I/O Table.

• Set the PLC to PROGRAM mode.
From step (1) above, select [Mode Setting] then [Program] mode, and click the [Set] button.

Click [Yes].
To change the Unit number, change the rotary switch of CPU Bus Units and Special I/O Units and restart power.

Check if any error occurs in the PLC (CPU Bus Units and Special I/O Units number overlap error should be solved).

Create the I/O Table.

Check if any error occurs in the PLC (all errors should be solved).
Confirming the Routing Table is not Configured

1. Check that Routing Table is not configured.
   - Check Routing Table presence. If the Routing Table is not configured, create one.
   - Move the cursor on the PLC and right-click
   - Select [Start Routing Table]

2. Configure the Routing Table.
   - Move the cursor on the PLC and right-click
   - Select [Start Routing Table]

3. Edit the Routing Table and transfer to [PLC].
   - Right-click and select local network (Unit) [Insert CPU SIOU] or local network (port) [Insert PORT]
   - Enter its local network number, then click [OK]

4. Check if the error is solved.
   - Re-connect to the PLC.
   - All errors should be solved and no error messages should be displayed.
   - The network number is displayed on the communications Unit.
DeviceNet Start-Up

Remove DeviceNet communications errors and establish communications.
⇒ Check DeviceNet Unit's 7SEG indication and ON state of MS/NS LED.
⇒ Check Slave Unit configuration through CX-Integrator.
Create a scan list of DeviceNet and determine the memory map.

(1) Connect to PLC online, then connect to DeviceNet through the online connection information window.

(2) Next, upload the network configuration information of DeviceNet.

In this example, although one Master Unit (node number #01) and two Slave Units (node number #02, #03) are actually connected, assume in this start-up example that one Slave Unit (#03) is not connected due to disconnection.

(3) After transfer is confirmed, connected devices on the current DeviceNet network are displayed as shown below.

Check if a Slave device on the remote I/O communications actually wired is recognized. Master Unit (#01) and Slave Unit (#02) are recognized, while another Slave Unit (#03) is not recognized.
Right-click on the Master Unit icon and select [Monitor] to display the device monitor screen. Select [Status] tab.

(4) Check the error on the device monitor screen.
You can check the Slave status on the device monitor screen as well.

Slave Unit (#02) is recognized, while the other Slave Unit (03) is not recognized.

(5) Wire Slave Unit (#03) correctly.

(6) Re-upload the network configuration information of DeviceNet.

Now it can be confirmed that Slave devices on the remote I/O communications have been recognized and communications have been established.

Double-click a Master Unit (CJ1W-DRM21) icon

Click twice

Click the [OK] button

(7) Configure DeviceNet remote I/O communications (free assignment) and register the Slave to the Master.

Two Slaves are now registered to the Master.

Right-click the Master Unit and select [Parameters] > [Edit]

Edit the parameters, then click the [OK] button

Select [Network] > [Transfer [PC to Network]]

(8) Configure assignment of Slaves to areas of a CPU Unit. If necessary, configure the Slave parameters as well.

(9) Start remote I/O communication.
(1) Connect to PLC online, then connect to a CPU Unit through the online connection information window.

(2) Select in the order from upper link port to NT link.

(3) Next, select [NT Link Tool] > [NTLink Auto Online Setting] from the CPU Unit.

Automatic NT Link connection function is used to automatically connect NS series PT and PLC via serial connection (NT Link). Connection is automatically performed by overwriting the PLC serial communication port settings by adjusting to NS series PT settings.
Click [OK]

(4) Check the CPU DIP switch.
   • Follow the on screen instructions to change the DIP switch.

Click [OK]

(5) Screen message Connecting . . . is now cleared.

(6) Next, upload the network configuration information of NT Link.

Select [Transfer [Network to PC]]

Click [Yes]

(7) After the transfer is confirmed, connected devices on the current NT Link network are displayed as shown below.
Controller Link Start-Up

Remove Controller Link communications errors and establish communications.
⇒ ON state of Controller Link Master Unit’s INS LED
⇒ Check Controller Link configuration through CX-Integrator.

(1) Connect to PLC online, then connect to Controller Link Unit through the online connection information window.

Right-click a Controller Link Unit in the online connection information window, then select [Connect]

Select [Transfer [Network to PC]]

Click [Transfer]

(2) Next, upload the Controller Link network configuration information.
In this example, although three PLCs are actually connected through the Controller Link, in this start-up example explanation assume that only two PLCs are displayed. (One PLC did not join the communications due to incorrect Routing Table settings)

(3) After the transfer is confirmed, connected devices on the current Controller Link network are displayed as shown below.

(4) Check the Routing Table and configure it correctly. See “Confirming the Routing Table is not Configured” for configuration details.

(5) Re-upload the Controller Link network configuration information.

(6) Send the network configuration from the network to the personal computer.
This example explains the start-up of a serial communications Unit with two temperature controllers (E5CN) connected via CompoWay/F.

- Two temperature controllers (E5CN) are connected to serial communications Unit (CS1W-SCU41-V1) port no. 1 via RS485. Communication Unit numbers are #001 and #002.
- Communication settings of the serial communications Unit and the two temperature controllers are unmatched.
- Communication settings between the two temperature controllers are unmatched as well.

**CompoWay/F Start-Up**

Remove CompoWay/F communications errors and establish communications.

⇒ Check CompoWay/F configuration through CX-Integrator.
⇒ Configure serial communications Unit parameters.
⇒ Configure temperature controller communications.

(1) Connect to PLC online, then connect to a CPU Unit through the online connection information window.

Right-click an SCU port in the online connection information window, then select [Connect].

Select SCU port (140)

Select CompoWay/F

Right-click an SCU port in the online connection information window, then select [Transfer [Network to PC]]

Click [Yes] in the message dialog box

Select [Selection], enter 1 for minimum and 2 for maximum values, then click the [OK] button

(2) Upload the CompoWay/F network configuration information.

Click [OK]

Click [OK]

Click [OK] in the message dialog box

Click [OK]
This dialog box is displayed because communication is not established between the serial communications Unit and temperature controllers.

(3) Adjust the serial communications board parameters settings to those of the CompoWay/F.

The [Network Structure] window shows a CPU Unit (CJ1M-CPU13) that has a serial communications Unit, but neither of the two temperature controllers.

Configure [Port1: Port settings] to [Manual] and [Port1: Serial communications mode] to [Serial Gateway]. Check other settings as well, and change if necessary.

Click the reset button to enable settings. Click [OK] in the reset confirmation message dialog box.

Click the [OK] button in the [Display Parameter] pull-down menu, select [Port1: Serial Gateway Settings]

Click [OK] in the [Edit Parameters] dialog box and close the dialog box

Select [HOSTLINK1] and click [OK] button.

(4) Re-upload the network configuration information of CompoWay/F. Perform the step (2) from the previous page.

Only the Units for which connection is established are displayed in the [Network Structure] window, as shown on the next page.

Perform the step (2) in the previous page

Click [OK] button in a dialog box indicating completion of transmission

Click [OK] button in the dialog box indicating completion of transmission

Then click the [OK] button in the dialog box indicating completion of transmission

Place the cursor on CJ1M-CPU in the [Network Structure] window and double-click

From the menu, select [Component | Mode Setting] to display the [PLC Mode Setting] dialog box
(1) Select [Program] for operation mode
(2) Click [Set]
(3) Click [Close] after changing

From the [Display Parameter] pull-down menu, select [Port1: Serial Gateway Settings]

Click [OK] in the [Edit Parameters] dialog box and close the dialog box

Click [OK] button in a dialog box indicating completion of transmission

Click [OK] button in the [Network Structure] window, as shown on the next page.

Perform the step (2) in the previous page

Click [OK] button in a dialog box indicating completion of transmission

Click [OK] button in the [Network Structure] window, as shown on the next page.

This dialog box is displayed because communication is not established between the serial communications Unit and temperature controllers.
The [Network Structure] window shows only the Units for which connection is established, and Units with incorrect communications setting are not displayed.

(5) Check the settings of the temperature controller that is not displayed in the [Network Structure] window (baud rate, data length, stop bit, parity, Unit number), configure it correctly, then re-upload (Perform step (2) from two pages ago). The [Network Structure] window is updated.

Now the correctly configured Unit is displayed and you can confirm that communications settings are correct.

(6) Move the cursor on E5CN of communications Unit number #002, then select [Start Special Application] > [Start with Setting Inherited].

(6) Dedicated Support Software CX-Thermo is started with the same model and setting as that of the temperature controller.

After parameter settings are finished, select [Communications] > [Download to Device], then select either [Download all], [Download Changed Parameters], or [Download Changed from Default].
Save the system configuration for inspection after delivery.

1. Connect online to a PLC on a network.
   The online connection information window is displayed.
   - All communications units and ports of a connected PLC are automatically displayed in the online connection information window. From this window, connect to each network and save the configuration to a project file.

2. Send the network Structure of DeviceNet to the personal computer.
   Connect to DeviceNet from the online connection information window. After connection is established, send the network Structure of DeviceNet to the personal computer.

   - Move the cursor on the DeviceNet and right-click
   - Select [Connect]
   - Select [Transfer [Network to PC]]

3. Send the network configuration of NT Link to the personal computer.
   Select the connection menu on the CPU port, then select upper link port and NT Link. Next, select the transmission menu on the CPU port.

   - Select [Serial Port] > [NT Link]
   - Select [Connect]
   - Select [Transfer [Network to PC]]

4. Send the Controller Link network configuration to the personal computer.
   Connect to the Controller Link network. After connection is established, send the network configuration to the personal computer.

   - Select [Connect]
   - Select [Transfer [Network to PC]]
(5) Connect to a PLC on the Controller Link network. Select a remote PLC on the Controller Link network configuration screen (a PLC without a square symbol) to switch the connection destination to the PLC. Destination PLC communication device configuration is displayed in the online connection information window.

(6) Send the DeviceNet network configuration on the remote PLC. Connect to DeviceNet from the online connection information window and send the network configuration to the personal computer.

(7) Send the DeviceNet network configuration on another remote PLC. Repeat the steps from (6) and (7). After transmission, all the networks sent to the workspace are displayed.

(8) Save all the configurations.
Select [Connect]

Confirm that the System has the same wiring and settings as before disassembly.
⇒ CX-Integrator verification is complete.

(1) Connect online to a PLC on a network.
   The online connection information window is displayed.

   All communications Units and ports of a connected PLC are automatically displayed in the online connection information window.

Select [Connect]

(2) Verify the DeviceNet network configuration.
   Connect to a target DeviceNet from the workspace and verify the network Structure.

Select [Compare]

(3) Any error found in the configuration verification will be displayed in the verification result dialog box.

   If you find a Slave that is not on the network, you may have incorrect wiring in the network.

Click [Close]

(4) After solving the error, verify the configuration again.

   A message is displayed indicating verification matching and now it can be confirmed that the configuration is the same as that before disassembly.

Click [OK]
(5) Verify the NT Link network.
Connect to the NT Link from the workspace and verify the network configuration.
Confirm that the same verification matching message is displayed as in step (4).

(6) Verify the Controller Link network.
Connect to DeviceNet from the online connection information window and verify the network structure.
Confirm that the same verification matching message is displayed as in step (4).

(7) Connect to a PLC on the Controller Link network.
Connect to a remote PLC using the same procedure as the step (5) for saving a System configuration.
Use steps from (2) to (4) to verify the DeviceNet network.

(8) Verify the DeviceNet configuration on another remote PLC.
Use the same procedure as step (2) for Network "N4" to verify the network structure.
Controller Link Diagnosis

Confirm that the Controller Link connection is correct with an upper level System.
⇒ Diagnosis result check OK

(1) Connect to PLC online, then connect to Controller Link Unit through the online connection information window.

Right-click a DeviceNet Unit under Target Device in the online connection information window, then select [Connect].

(2) Next, select the Controller Link network tool.

Next, select [Connect].
Right-click on 3G3MV-PDRT2 and select [Start Special Application].

Select [Start with Setting Inherited].

When opening a stored data file after starting the dedicated tool, select [Start Only]. If [Start with Setting Inherited] is selected, new data is created.

Starting CX-Drive via DeviceNet

Setup Drives on DeviceNet and start CX-Drive on CX-Integrator window. An example of 3G3MV-PDRT2 is shown below.

Select Settings to set detailed Inverter specifications.

CX-Drive starts and Inverter property settings are shown.

Save data

If more than one drive setting data is edited, drive data is saved by drive type and a total overview is saved in a work file.
From the [Start] menu, select [Programs] > [OMRON] > [CX-One] > [CX-Drive] > [CX-Drive] to start CX-Drive when you connect Servo or Inverter with serial connection to your computer.

Select [File] > [New] to create new data if the drive specifications are known. If the drive is already connected, select [File] > [Autodetect] to detect the model and specification of this connected drive.

To execute Autodetect, select [Settings] and define the search conditions.

Select [Settings] and save the data.

Or, select [File] > [Autodetect] to detect the connected drive specification.

Click and save the data.
Appendix
# 1. Personal Computer Requirements

<table>
<thead>
<tr>
<th>Item</th>
<th>System Requirements*</th>
</tr>
</thead>
<tbody>
<tr>
<td>Operating System (OS)</td>
<td><strong>Japanese or English version</strong></td>
</tr>
<tr>
<td></td>
<td>Microsoft® Windows® 98SE</td>
</tr>
<tr>
<td></td>
<td>Microsoft® Windows® NT (Service Pack 6a)</td>
</tr>
<tr>
<td></td>
<td>Microsoft® Windows® 2000 (Service Pack 3 or higher)/Windows® Me</td>
</tr>
<tr>
<td></td>
<td>Microsoft® Windows® XP</td>
</tr>
<tr>
<td>Main Unit</td>
<td>DOS/V (IBM AT compatible) computer with a Pentium II 333 MHz processor or higher.</td>
</tr>
<tr>
<td></td>
<td>Pentium III 1GHz or higher is recommended.</td>
</tr>
<tr>
<td>Memory</td>
<td>256MB or higher required (Note 2)</td>
</tr>
<tr>
<td>Hard drive</td>
<td>To install entire CX-One, about 1.8GB or more free space is required.</td>
</tr>
<tr>
<td>Display</td>
<td>High quality display with SVGA (800 x 600) or higher and 256 colors or more.</td>
</tr>
<tr>
<td>Optical drive</td>
<td>CD-ROM drive</td>
</tr>
<tr>
<td>Communication port</td>
<td>At least 1 RS-232C port (Note 3)</td>
</tr>
<tr>
<td>Others</td>
<td>For online user registration via the Internet, you need appropriate hardware such as modem and Internet access rights.</td>
</tr>
</tbody>
</table>

(Note 1):  
About operating System for CX-One:  
This product does not run on Microsoft Windows95 or other OS versions other than the specified System requirements.  
If you have such an Operating System on a client computer, you must upgrade the Operating System before installing this product.  
Note that the required System and hard drive capacity depend on the System environment.

(Note 2):  
The required memory depends on the CX-One Support Software. See the User’s manual for details.

(Note 3):  
An RS-232C port is required for connection with a PLC using CX-One Support Software. If you only have USB on your personal computer, use a USB-RS-232C conversion cable (CS1W-CIF31).
## 2. List of Software to be Installed

CX-One Support Software installed with CX-One is shown below.

<table>
<thead>
<tr>
<th>CX-One Support Software</th>
<th>Description</th>
<th>Required free space on hard drive</th>
<th>Remarks</th>
</tr>
</thead>
<tbody>
<tr>
<td>CX-Programmer</td>
<td>Software to create and debug programs for SYSMAC CS/CJ series, C series, or CVM1/C series.</td>
<td>ca. 250MB</td>
<td>If necessary</td>
</tr>
<tr>
<td>CX-Integrator</td>
<td>Software to start up and configure FA networks such as Controller Link, DeviceNet, and CompoWay/F.</td>
<td>ca. 100MB</td>
<td></td>
</tr>
<tr>
<td>CX-Position</td>
<td>Software to create and monitor various data for SYSMAC CS/CJ series NC Unit.</td>
<td>ca. 15MB</td>
<td></td>
</tr>
<tr>
<td>CX-Motion</td>
<td>Software to create various data for MC Unit of SYSMAC CS/CJ series, alpha series, and CV series and to create and monitor MC programs.</td>
<td>ca. 40MB</td>
<td></td>
</tr>
<tr>
<td>CX-Motion-NCF</td>
<td>Software to create and monitor various data for SYSMAC CS/CJ series NCF Unit.</td>
<td>ca. 100MB</td>
<td></td>
</tr>
<tr>
<td>CX-Motion-MCH</td>
<td>Software to create various data, motion programs and monitor the SYSMAC CS/CJ series MCH Unit.</td>
<td>ca. 100MB</td>
<td></td>
</tr>
<tr>
<td>CX-Drive</td>
<td>Software to configure and adjust various inverter servo data.</td>
<td>ca. 100MB</td>
<td></td>
</tr>
<tr>
<td>CX-Designer</td>
<td>Software to create screen data for programmable terminal NS series.</td>
<td>ca. 500MB</td>
<td></td>
</tr>
<tr>
<td>CX-Process Tool</td>
<td>Software to create and debug instrument block programs for loop control Unit board, process, and loop CPU Unit of SYSMAC CS/CJ series.</td>
<td>ca. 65MB</td>
<td></td>
</tr>
<tr>
<td>Face Plate Auto-Builder for NS</td>
<td>Software to automatically generate NS series project files for monitoring and tuning of a loop controller.</td>
<td>ca. 50MB</td>
<td></td>
</tr>
<tr>
<td>CX-Protocol</td>
<td>Software to create data transmission procedure (protocol) with an external universal device that is connected to a serial communications board/Unit of SYSMAC CS/CJ series and SYSMAC alpha series.</td>
<td>ca. 20MB</td>
<td></td>
</tr>
<tr>
<td>CX-ProfiBus</td>
<td>Software to configure the PROFIBUS Master. (Possible to install Windows NT4.0/2000/XP only.)</td>
<td>ca. 10MB</td>
<td></td>
</tr>
<tr>
<td>CX-Simulator</td>
<td>Software to debug programs for SYSMAC CS/CJ series without the CPU Unit by simulating the CPU operation on a personal computer.</td>
<td>ca. 40MB</td>
<td></td>
</tr>
<tr>
<td>CX-Thermo</td>
<td>Software to configure and adjust parameters for devices (Components such as temperature controller). (Possible to install Windows 2000/XP only.)</td>
<td>ca. 20MB</td>
<td></td>
</tr>
<tr>
<td>CX-FLNet</td>
<td>Software to configure and monitor the SYSMAC CS/CJ series FLnet Unit.</td>
<td>ca. 1MB</td>
<td></td>
</tr>
<tr>
<td>Switch Box Utility</td>
<td>Utility software to support PLC debugging. Input/output status and current values of address in a user-specified PLC can be monitored and modified easily.</td>
<td>ca. 5MB</td>
<td></td>
</tr>
<tr>
<td>PLC Support Software</td>
<td>A group of Components that are commonly used by software that consists CX-One, such as CX-Programmer and CX-Integrator.</td>
<td>ca. 300MB</td>
<td></td>
</tr>
<tr>
<td>CX-Server</td>
<td>Middleware required for communications between CX-One Support Software and OMRON’s Components such as PLC, indicator, or temperature controller.</td>
<td>ca. 300MB</td>
<td>Always installed</td>
</tr>
</tbody>
</table>

About 1.8GB of free hard drive space is required on your personal computer to install all CX-One Support Software. Make sure that sufficient free space is available.
### 3. Comparison of Functions Between Conventional Support Software and CX-One (1/2)

<table>
<thead>
<tr>
<th>Function</th>
<th>Conventional Support Software</th>
<th>CX-One</th>
</tr>
</thead>
<tbody>
<tr>
<td>Handling of CX-Programmer's I/O Table window</td>
<td>Only mounted Unit position information&lt;br&gt;- Shows used position/size only (only head address and size of used area in CIO area are displayed)&lt;br&gt;- Assignment DM setting of CPU Bus Units and Special I/O Units is unavailable.</td>
<td>In addition to traditional functions, the following functions are available:&lt;br&gt;- Used as a setting terminal of CPU Bus Units and Special I/O Units&lt;br&gt;- Used as a terminal to start each Unit's Support Software</td>
</tr>
<tr>
<td>Initial setting of CPU Bus Units and Special I/O Units (assignment DM, assignment relay, CPU Bus Unit System setting)</td>
<td>Configuring four-digit hexadecimal or other value for each address by referring to assignment DM area on the manual using PLC memory as with universal DM area. (Direct setting in many cases)</td>
<td>By right-clicking a target Unit on the I/O Table and selecting [Unit Setup], configuration is available of CPU Bus Units and Special I/O Units parameter (mainly allocation DM) setting without referring to a manual in the following dialog box.</td>
</tr>
<tr>
<td></td>
<td>* It is necessary to configure values while checking addresses based on Unit number. And the data are not saved as parameter data for each Unit (only as DM data for a CPU Unit).</td>
<td>* Setting is available using item names without recognizing addresses. Also, data can be saved/read as a parameter setting data file for each Unit.</td>
</tr>
<tr>
<td></td>
<td>Setup data can be handled in the same way as other I/O memory areas for saving into a CXP project file or as a data file of file memory.</td>
<td>Setup data can be saved in a parameter setting data file for each Unit, or into a CXP project file for entire Units' parameter settings.</td>
</tr>
</tbody>
</table>

#### Network setting

<table>
<thead>
<tr>
<th>Network setting</th>
<th>Ethernet Network Setting for Ethernet Unit</th>
<th>By [Unit Setting] in the online CX-Programmer's I/O Table.</th>
<th>By right-clicking on an Ethernet Unit of the I/O Table and selecting [Unit Setup]. Can be saved as a parameter as with other CPU Bus Units and Special I/O Units.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ethernet network monitor</td>
<td>No tool for monitoring Ethernet network.</td>
<td>Ethernet network connection device can be monitored by CX-Integrator.</td>
<td>By right-clicking on an Controller Link Unit of the I/O Table online or offline and selecting [Unit Setup].</td>
</tr>
<tr>
<td>Controller Link</td>
<td>Controller Link Unit soft-switch setting</td>
<td>By right-clicking on a Controller Link Unit of the I/O Table in the online CX-Programmer and selecting [Software Switch Setting].</td>
<td>Through a Data Link Component by selecting [Tools] &gt; [Start Data Link] from CX-Integrator.</td>
</tr>
<tr>
<td>Controller Link Data Link (manual or automatic) setting</td>
<td>By CX-Net (Data Link Component) in CX-Programmer.</td>
<td>Controller Link network connection device can be started as well (By selecting [Tools] &gt; [Controller Link Tool] &gt; [Network Diagnosis] from online CX-Integrator).</td>
<td></td>
</tr>
<tr>
<td>Controller Link network monitor</td>
<td>No tool for monitoring Controller Link network.</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

* It is necessary to configure values while checking addresses based on Unit number. And the data are not saved as parameter data for each Unit (only as DM data for a CPU Unit).

* Setting is available using item names without recognizing addresses. Also, data can be saved/read as a parameter setting data file for each Unit.
### 3. Comparison of Functions between Conventional Support Software and CX-One (2/2)

<table>
<thead>
<tr>
<th>Function</th>
<th>Conventional Support Software</th>
<th>CX-One</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Network setting</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>DeviceNet</td>
<td>Fixed assignment by DeviceNet, or free assignment by assignment DM.</td>
<td>Fixed assignment: No setting tool (by edit on PLC memory). Fixed assignment: By DeviceNet configurator.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Free assignment: By right-clicking on a DeviceNet Unit of the I/O Table through online or offline CX-Integrator and selecting [Edit Parameters].</td>
</tr>
<tr>
<td></td>
<td>Free assignment and Slave parameter setting/monitoring by DeviceNet configurator</td>
<td>By DeviceNet configurator.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>By right-clicking on a DeviceNet Unit of the I/O Table and selecting [Start Special Application] for device parameter edit.</td>
</tr>
<tr>
<td>CompoWay/F</td>
<td>CompoWay/F Slave station parameter setting</td>
<td>By CX-Thermo</td>
</tr>
<tr>
<td></td>
<td>By CX-Net (Routing Table Component) in CX-Programmer.</td>
<td>Temperature controller: By right-clicking on a target Unit through online or offline CX-Integrator and selecting [Start Special Application] to start CX-Thermo and edit the setting.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Smart sensor: By right-clicking on a target Unit through online or offline CX-Integrator and selecting [Edit Parameters] to edit.</td>
</tr>
<tr>
<td>Routing Table</td>
<td>By CX-Net (Routing Table Component) in CX-Programmer.</td>
<td>By selecting [Tools] &gt; [Start Routing Table] from CX-Integrator to use Routing Table Component.</td>
</tr>
</tbody>
</table>

(Note) I/O Table can be started from CX-Programmer or CX-Integrator on CX-One.